Update to 3.04 and some fix.
Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
parent
597430141a
commit
81c7cd60e2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=24153
4 changed files with 46 additions and 7 deletions
|
@ -1,22 +1,24 @@
|
|||
# New ports collection makefile for: whirlgif
|
||||
# Version required: 2.01
|
||||
# Version required: 3.04
|
||||
# Date created: 20 Oct 1996
|
||||
# Whom: Yukihiro Nakai <nakai@mlab.t.u-tokyo.ac.jp>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= whirlgif
|
||||
PKGNAME= whirlgif-2.01
|
||||
DISTNAME= whirlgif304
|
||||
PKGNAME= whirlgif-3.04
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.msg.net/utility/whirlgif/
|
||||
MASTER_SITES= http://www.danbbs.dk/~dino/whirlgif/
|
||||
|
||||
MAINTAINER= nacai@iname.com
|
||||
MAINTAINER= nakai@FreeBSD.org
|
||||
|
||||
NO_WRKSUBDIR= yes
|
||||
|
||||
MAN1= whirlgif.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/whirlgif ${PREFIX}/bin/whirlgif
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/whirlgif ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/whirlgif.1 ${PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (whirlgif.tar.gz) = fe2dd31d15f5cc228d782ad125b96294
|
||||
MD5 (whirlgif304.tar.gz) = f34db0c396fda20f5937c489eb086850
|
||||
|
|
35
graphics/whirlgif/files/patch-aa
Normal file
35
graphics/whirlgif/files/patch-aa
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- Makefile.orig Tue Feb 23 04:35:18 1999
|
||||
+++ Makefile Mon Dec 27 16:38:29 1999
|
||||
@@ -32,7 +32,7 @@
|
||||
# Amiga: SASC
|
||||
# CC = sc
|
||||
# standard
|
||||
-CC = cc
|
||||
+CC ?= cc
|
||||
|
||||
###########################################################
|
||||
# Optimization flags
|
||||
@@ -41,12 +41,12 @@
|
||||
#OPTIMIZE= -fcombine-regs -O
|
||||
# for Amiga's SASC compiler remove Optimization flags.
|
||||
# standard:
|
||||
-OPTIMIZE = -O
|
||||
+#OPTIMIZE = -O
|
||||
|
||||
###########################################################
|
||||
# Debug flags
|
||||
#
|
||||
-DEBUG = -g
|
||||
+#DEBUG = -g
|
||||
#DEBUG = -ggdb
|
||||
|
||||
###########################################################
|
||||
@@ -62,7 +62,7 @@
|
||||
# for the Amiga:
|
||||
# CFLAGS = DATA=FAR MATH=IEEE CPU=68020 PARAMETERS=BOTH ANSI STRICT NOICONS IGNORE=51
|
||||
# standard:
|
||||
-CFLAGS = $(DEBUG) $(OPTIMIZE) $(VIS_GNU_W32) $(STRS_H) $(WARNINGS)
|
||||
+CFLAGS += $(DEBUG) $(OPTIMIZE) $(VIS_GNU_W32) $(STRS_H) $(WARNINGS)
|
||||
|
||||
all: $(TARG_WH)
|
||||
|
|
@ -9,3 +9,5 @@ and want to loop 100 times, then you can do something like:
|
|||
whirlgif -loop 100 img*.gif
|
||||
|
||||
to create an animation.
|
||||
|
||||
WWW: http://www.danbbs.dk/~dino/whirlgif/
|
||||
|
|
Loading…
Reference in a new issue