2012-06-16 ftp/IglooFTP: No longer supported
This commit is contained in:
parent
1a41cfa951
commit
81e57af4a4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299585
14 changed files with 1 additions and 593 deletions
1
MOVED
1
MOVED
|
@ -3480,3 +3480,4 @@ www/trac-ticketdelete||2012-06-14|Has expired: Functionality of this plugin has
|
|||
x11-themes/gtk-qt-engine||2012-06-16|Has expired: BROKEN for more than 6 month
|
||||
devel/bazaar|devel/baz|2012-06-17|Project renamed
|
||||
devel/bazaar-ng|devel/bzr|2012-06-17|Project renamed
|
||||
ftp/IglooFTP||2012-06-18|Has expired: No longer supported
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
# New ports collection makefile for: IglooFTP
|
||||
# Date created: 3 May 1999
|
||||
# Whom: Andrey Zakhvatov
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= IglooFTP
|
||||
PORTVERSION= 0.6.1
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= ftp
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
|
||||
ftp://littleigloo.org/pub/iglooftp/
|
||||
MASTER_SITE_SUBDIR= system/network/file-transfer
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
|
||||
|
||||
MAINTAINER= beech@FreeBSD.org
|
||||
COMMENT= Easy to use FTP client for X Window System
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
|
||||
|
||||
USE_XORG= x11 xmu
|
||||
USE_GNOME= gtk12
|
||||
ALL_TARGET= # empty
|
||||
MAKE_ARGS= CC=${CC} C_FLAGS="${CFLAGS}" DESTDIR=${PREFIX}
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
DEPRECATED= No longer supported
|
||||
EXPIRATION_DATE= 2012-06-16
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-extract:
|
||||
@${RM} ${WRKSRC}/../share/docs/LICENSE~
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|(char) user_rc.default_session.firewall_login_type|user_rc.default_session.firewall_login_type|' \
|
||||
${WRKSRC}/custom_io.h
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
.for file in AUTHORS BUGS COPYRIGHT THANKS TODO
|
||||
${INSTALL_DATA} ${WRKSRC}/../${file} ${PREFIX}/share/IglooFTP/docs
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (IglooFTP-0.6.1.src.tar.gz) = f25e2bd1203445ee64123140f0046259797b116c173428726ac8e4abbf663d5b
|
||||
SIZE (IglooFTP-0.6.1.src.tar.gz) = 300553
|
|
@ -1,16 +0,0 @@
|
|||
--- FTP.c.orig Thu Apr 15 20:05:13 1999
|
||||
+++ FTP.c Mon May 3 12:59:56 1999
|
||||
@@ -15,12 +15,12 @@
|
||||
*/
|
||||
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
#include <netinet/in.h>
|
||||
#include <netdb.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <arpa/telnet.h>
|
||||
-#include <sys/types.h>
|
||||
#include <sys/time.h>
|
||||
#include <resolv.h>
|
||||
|
|
@ -1,156 +0,0 @@
|
|||
--- FTPcommands.h.orig Thu Apr 15 17:05:15 1999
|
||||
+++ FTPcommands.h Sat Feb 4 01:12:52 2006
|
||||
@@ -14,8 +14,12 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#include "defines.h"
|
||||
+
|
||||
#define ERROR_REPLY_CODE (FTPctrl->reply[0] == '5' || FTPctrl->reply[0] == '4')
|
||||
|
||||
+extern char tmpfile_template[];
|
||||
+
|
||||
|
||||
|
||||
/* LOGIN */
|
||||
@@ -282,11 +286,14 @@
|
||||
char
|
||||
FTP_LIST (FTP * FTPctrl, char *filename)
|
||||
{
|
||||
+ int fd = -1;
|
||||
char tmp_filename[256];
|
||||
char list_command[10];
|
||||
int data_socket = FTP_open_data_connection (FTPctrl);
|
||||
FILE *local;
|
||||
|
||||
+ sprintf(tmp_filename, tmpfile_template);
|
||||
+
|
||||
if (FTPctrl->host_type == HOST_VMS)
|
||||
strcpy (list_command, "LIST");
|
||||
else
|
||||
@@ -296,11 +303,18 @@
|
||||
|
||||
FTP_TYPE_ASCII (FTPctrl);
|
||||
|
||||
- tmpnam (tmp_filename);
|
||||
if (!FTP_exec_command (FTPctrl, list_command) || ERROR_REPLY_CODE)
|
||||
return FTP_error (FALSE, "LIST command failed.", "", data_socket);
|
||||
|
||||
- local = fopen (tmp_filename, "w");
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1 || (local = fdopen (fd, "w")) == NULL)
|
||||
+ {
|
||||
+ if (fd != -1) {
|
||||
+ unlink(tmp_filename);
|
||||
+ close(fd);
|
||||
+ }
|
||||
+ return FTP_error (FALSE, "Unable to create temporary file.", "", 0);
|
||||
+ }
|
||||
+
|
||||
if (!FTP_download (FTPctrl, data_socket, local))
|
||||
return FTP_error (FALSE, "Unable to retreive directory listing. ", "", data_socket);
|
||||
|
||||
--- custom_profiles.h.orig Thu Apr 15 17:05:15 1999
|
||||
+++ custom_profiles.h Sat Feb 4 00:59:51 2006
|
||||
@@ -169,6 +169,7 @@
|
||||
static void
|
||||
delete_user_prof_from_file (GtkWidget * widget, gpointer data)
|
||||
{
|
||||
+ int fd = -1;
|
||||
const int remove_this_one = (int) GTK_CLIST (clist)->selection->data;
|
||||
char tmp_filename[256];
|
||||
char prof_path[1024];
|
||||
@@ -180,9 +181,21 @@
|
||||
|
||||
gtk_widget_destroy (gtk_widget_get_toplevel (widget));
|
||||
sprintf (prof_path, "%s/%s/%s", home_path, PREFERENCES_PATH, USER_PROF);
|
||||
- tmpnam (tmp_filename);
|
||||
+ sprintf (tmp_filename, "%s.%s", prof_path, "tmp.XXXXXXXX");
|
||||
+
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1) {
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ close (fd);
|
||||
+
|
||||
rename (prof_path, tmp_filename);
|
||||
- file_handle = open (tmp_filename, O_RDONLY, RC_PERM);
|
||||
+
|
||||
+ if ((file_handle = open (tmp_filename, O_RDONLY|O_EXCL, RC_PERM)) == -1) {
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
for (index = 0; index < index_total; index++)
|
||||
{
|
||||
--- defines.h.orig Thu Apr 15 17:05:15 1999
|
||||
+++ defines.h Sat Feb 4 01:10:47 2006
|
||||
@@ -47,6 +47,9 @@
|
||||
#define SHARE_PATH "/usr/local/src/IglooFTP"
|
||||
#endif
|
||||
|
||||
+#define TMPFILE_FILE "IglooFTP.tmp.XXXXXXXX"
|
||||
+char tmpfile_template[256];
|
||||
+
|
||||
|
||||
#define PREFERENCES_PATH ".IglooFTP"
|
||||
#define USER_LAYOUT "user.layout"
|
||||
--- dirlist.c.orig Thu Apr 15 17:05:14 1999
|
||||
+++ dirlist.c Fri Feb 3 23:20:24 2006
|
||||
@@ -1619,6 +1619,7 @@
|
||||
upload_selection_recursive (void)
|
||||
{
|
||||
|
||||
+ int fd = -1;
|
||||
GdkColor done_color = GREYCYAN;
|
||||
GdkColormap *colormap;
|
||||
GList *selection = GTK_CLIST (clist)->selection;
|
||||
@@ -1635,8 +1636,15 @@
|
||||
|
||||
getcwd (current_local_dir, sizeof (current_local_dir));
|
||||
|
||||
- tmpnam (tmp_filename);
|
||||
- tmp = fopen (tmp_filename, "w");
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1 || (tmp = fdopen (fd, "w")) == NULL)
|
||||
+ {
|
||||
+ if (fd != -1) {
|
||||
+ unlink(tmp_filename);
|
||||
+ close(fd);
|
||||
+ }
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
colormap = gtk_widget_get_colormap (window);
|
||||
gdk_color_alloc (colormap, &done_color);
|
||||
--- session.c.orig Thu Apr 15 17:05:15 1999
|
||||
+++ session.c Fri Feb 3 23:20:24 2006
|
||||
@@ -32,7 +32,8 @@
|
||||
{
|
||||
FILE *out = NULL;
|
||||
FTPsession that_session;
|
||||
- int file_handle;
|
||||
+ int fd = -1;
|
||||
+ FILE *file_handle = NULL;
|
||||
char tmp_filename[MPLEN];
|
||||
char spawn_tmp[MPLEN];
|
||||
|
||||
@@ -41,8 +42,16 @@
|
||||
|
||||
strcpy (that_session.start_dir, this_session.cwd_dir);
|
||||
|
||||
- tmpnam (tmp_filename);
|
||||
- file_handle = open (tmp_filename, O_CREAT | O_RDWR, RC_PERM);
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1 || (file_handle = fdopen (fd, "w")) == NULL)
|
||||
+ {
|
||||
+ if (fd != -1) {
|
||||
+ unlink(tmp_filename);
|
||||
+ close(fd);
|
||||
+ }
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
write (file_handle, &that_session, sizeof (FTPsession));
|
||||
close (file_handle);
|
||||
|
|
@ -1,55 +0,0 @@
|
|||
--- Makefile.orig 1999-04-15 18:05:15.000000000 +0200
|
||||
+++ Makefile 2009-03-24 13:47:15.000000000 +0100
|
||||
@@ -1,9 +1,9 @@
|
||||
SHELL=/bin/sh
|
||||
CC = gcc
|
||||
C_FLAGS = -Wall -g -O2 -m486 -fno-strength-reduce
|
||||
-GTK_CFLAGS = `gtk-config --cflags`
|
||||
-GTK_LIBS = `gtk-config --libs`
|
||||
-LFLAGS = $(GTK_LIBS) -lresolv -lXmu -lXt -lSM -lICE
|
||||
+GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
|
||||
+GTK_LIBS = `$(GTK_CONFIG) --libs`
|
||||
+LFLAGS = $(GTK_LIBS) -lXmu -lXt -lSM -lICE
|
||||
PROGNAME = IglooFTP
|
||||
PROGNAME-STATIC = IglooFTP-static
|
||||
VERSION = 0.6.1
|
||||
@@ -50,14 +50,14 @@
|
||||
@if ! test -e $(SHARE_PATH)/app_ass; then \
|
||||
echo "Making $(SHARE_PATH)/app_ass directory ..."; mkdir -m 0755 $(SHARE_PATH)/app_ass; \
|
||||
else :; fi;
|
||||
- /usr/bin/install -s -m 755 $(PROGNAME) $(BIN_PATH)
|
||||
- /usr/bin/install -m 644 ../share/docs/* $(SHARE_PATH)/docs/
|
||||
- /usr/bin/install -m 644 ../share/html/*.* $(SHARE_PATH)/html/
|
||||
- /usr/bin/install -m 644 ../share/html/images/*.* $(SHARE_PATH)/html/images/
|
||||
- /usr/bin/install -m 644 ../share/xpm/* $(SHARE_PATH)/xpm/
|
||||
- /usr/bin/install -m 644 ../share/bookmarks/* $(SHARE_PATH)/bookmarks/
|
||||
- /usr/bin/install -m 644 ../share/app_ass/* $(SHARE_PATH)/app_ass/
|
||||
- /usr/bin/install -m 644 ../share/gtkrc $(SHARE_PATH)/gtkrc
|
||||
+ ${BSD_INSTALL_PROGRAM} $(PROGNAME) $(BIN_PATH)
|
||||
+ ${BSD_INSTALL_DATA} ../share/docs/* $(SHARE_PATH)/docs/
|
||||
+ ${BSD_INSTALL_DATA} ../share/html/*.* $(SHARE_PATH)/html/
|
||||
+ ${BSD_INSTALL_DATA} ../share/html/images/*.* $(SHARE_PATH)/html/images/
|
||||
+ ${BSD_INSTALL_DATA} ../share/xpm/* $(SHARE_PATH)/xpm/
|
||||
+ ${BSD_INSTALL_DATA} ../share/bookmarks/* $(SHARE_PATH)/bookmarks/
|
||||
+ ${BSD_INSTALL_DATA} ../share/app_ass/* $(SHARE_PATH)/app_ass/
|
||||
+ ${BSD_INSTALL_DATA} ../share/gtkrc $(SHARE_PATH)/gtkrc
|
||||
|
||||
|
||||
|
||||
@@ -99,6 +99,7 @@
|
||||
|
||||
version.o : version.h
|
||||
|
||||
+custom.o: custom.c version.h
|
||||
|
||||
version.h : FORCE
|
||||
@echo "/* this header is automatically generated */" > version.h
|
||||
@@ -111,7 +112,7 @@
|
||||
@echo "#define COMPILE_TIME \"`date +%T`\"" >> version.h
|
||||
@echo "#define COMPILE_BY \"`whoami`\"" >> version.h
|
||||
@echo "#define COMPILE_HOST \"`hostname`\"" >> version.h
|
||||
- @echo "#define GTK_VERSION \"GTK+ `gtk-config --version`\"" >> version.h
|
||||
+ @echo "#define GTK_VERSION \"GTK+ `$(GTK_CONFIG) --version`\"" >> version.h
|
||||
@echo "#define CC_VERSION \"`$(CC) -v 2>&1 | tail -1`\"">>version.h
|
||||
@echo "#define CODE_LINES \"`cat *.c *.h | grep -ch -e \"[[:alpha:]|[:punct:]]\"`\"">>version.h
|
||||
|
|
@ -1,70 +0,0 @@
|
|||
--- dialog.c.orig Thu Apr 15 17:05:14 1999
|
||||
+++ dialog.c Thu Feb 2 16:40:36 2006
|
||||
@@ -112,10 +112,15 @@
|
||||
gtk_widget_set_usize (fixed_top, 353, 225);
|
||||
|
||||
sprintf (pixmap_path, "%s/xpm/iglooftp.xpm", SHARE_PATH);
|
||||
- pixmap = gdk_pixmap_create_from_xpm (startup_window->window, &mask, &startup_window->style->bg[GTK_STATE_NORMAL], pixmap_path);
|
||||
- igloo_pixmap = gtk_pixmap_new (pixmap, mask);
|
||||
|
||||
- gtk_fixed_put (GTK_FIXED (fixed_top), igloo_pixmap, 0, 0);
|
||||
+ if (eaccess(pixmap_path, R_OK) == 0) {
|
||||
+ pixmap = gdk_pixmap_create_from_xpm (startup_window->window, &mask, &startup_window->style->bg[GTK_STATE_NORMAL], pixmap_path);
|
||||
+ igloo_pixmap = gtk_pixmap_new (pixmap, mask);
|
||||
+
|
||||
+ gtk_fixed_put (GTK_FIXED (fixed_top), igloo_pixmap, 0, 0);
|
||||
+ } else {
|
||||
+ mask = pixmap = NULL;
|
||||
+ }
|
||||
|
||||
startup_label = fixed_label (fixed_top, 10, 205, " ");
|
||||
gtk_widget_set_usize (startup_label, 300, 24);
|
||||
@@ -126,8 +131,8 @@
|
||||
gtk_widget_show_all (startup_window);
|
||||
|
||||
PROCESS_EVENTS;
|
||||
- gdk_pixmap_unref (pixmap);
|
||||
- gdk_pixmap_unref (mask);
|
||||
+ if (pixmap) gdk_pixmap_unref (pixmap);
|
||||
+ if (mask) gdk_pixmap_unref (mask);
|
||||
}
|
||||
|
||||
|
||||
@@ -173,14 +178,22 @@
|
||||
alert_hbox = h_box (alert_vbox, FALSE, 0, 0);
|
||||
|
||||
sprintf (pixmap_path, "%s/xpm/little_igloo.xpm", SHARE_PATH);
|
||||
- pixmap = gdk_pixmap_create_from_xpm (alert_window->window, &mask, &alert_window->style->bg[GTK_STATE_NORMAL], pixmap_path);
|
||||
- igloo_pixmap = gtk_pixmap_new (pixmap, mask);
|
||||
+
|
||||
+ if (eaccess(pixmap_path, R_OK) == 0) {
|
||||
+ pixmap = gdk_pixmap_create_from_xpm (alert_window->window, &mask, &alert_window->style->bg[GTK_STATE_NORMAL], pixmap_path);
|
||||
+ igloo_pixmap = gtk_pixmap_new (pixmap, mask);
|
||||
+ } else {
|
||||
+ pixmap = mask = NULL;
|
||||
+ }
|
||||
|
||||
alert_button = gtk_button_new ();
|
||||
gtk_button_set_relief (GTK_BUTTON (alert_button), GTK_RELIEF_NONE);
|
||||
|
||||
- gtk_container_add (GTK_CONTAINER (alert_button), igloo_pixmap);
|
||||
- gtk_widget_show (igloo_pixmap);
|
||||
+ if (pixmap) {
|
||||
+ gtk_container_add (GTK_CONTAINER (alert_button), igloo_pixmap);
|
||||
+ gtk_widget_show (igloo_pixmap);
|
||||
+ }
|
||||
+
|
||||
gtk_box_pack_start (GTK_BOX (alert_hbox), alert_button, TRUE, TRUE, 0);
|
||||
gtk_widget_show (alert_button);
|
||||
gtk_signal_connect (GTK_OBJECT (alert_button), "clicked", GTK_SIGNAL_FUNC (open_URL_from_widget), strdup (HOME_URL));
|
||||
@@ -198,8 +211,8 @@
|
||||
|
||||
gtk_widget_show (alert_window);
|
||||
|
||||
- gdk_pixmap_unref (pixmap);
|
||||
- gdk_pixmap_unref (mask);
|
||||
+ if (pixmap) gdk_pixmap_unref (pixmap);
|
||||
+ if (mask) gdk_pixmap_unref (mask);
|
||||
}
|
||||
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
--- dir_tree.c.orig Thu Apr 15 17:05:14 1999
|
||||
+++ dir_tree.c Thu Feb 2 02:26:20 2006
|
||||
@@ -153,7 +153,6 @@
|
||||
new_ptr[0] = 'B';
|
||||
gtk_ctree_node_set_row_data_full (ctree, parent, strdup (new_ptr), (GtkDestroyNotify) free);
|
||||
free (new_ptr);
|
||||
- free (ptr); // verify that this is a good thing to do
|
||||
|
||||
PARENT_BROWSED_FLAG = TRUE;
|
||||
}
|
|
@ -1,15 +0,0 @@
|
|||
--- src/ftp_tree.h.orig Sat Aug 14 11:40:27 2004
|
||||
+++ ftp_tree.h Sat Aug 14 11:41:17 2004
|
||||
@@ -321,10 +321,12 @@
|
||||
break;
|
||||
|
||||
default:
|
||||
+ break;
|
||||
}
|
||||
break;
|
||||
|
||||
default:
|
||||
+ break;
|
||||
}
|
||||
return FALSE;
|
||||
}
|
|
@ -1,109 +0,0 @@
|
|||
--- ftplist.c.orig Thu Apr 15 19:05:15 1999
|
||||
+++ ftplist.c Fri Feb 10 22:53:16 2006
|
||||
@@ -1158,6 +1158,7 @@
|
||||
int this_row = GTK_CLIST (clist)->focus_row;
|
||||
char this_path[1024];
|
||||
char temp_path[1024];
|
||||
+ char msg_buf[1024];
|
||||
gchar *filename;
|
||||
gchar *filesize;
|
||||
gchar *filedate;
|
||||
@@ -1189,6 +1190,14 @@
|
||||
IDLE_END;
|
||||
CHECK_CONNEXION_VOID;
|
||||
|
||||
+ /* Is it worth trying to handle this better? */
|
||||
+
|
||||
+ if ((strchr(filename, '/') != NULL) || (strstr(filename, "..") != NULL)) {
|
||||
+ snprintf (msg_buf, sizeof(msg_buf), "Skipping non-relative filename: %s", filename);
|
||||
+ error_message (msg_buf);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
if (IGLOO_download (filename, filesize, filedate, NULL))
|
||||
{
|
||||
char that_path[1024];
|
||||
@@ -1255,6 +1264,7 @@
|
||||
static void
|
||||
perfom_recursive_command_on_selection (char recursive_command, char *optionnal_arg, char IS_TOP_DIR)
|
||||
{
|
||||
+ int fd = -1;
|
||||
GList *selection = GTK_CLIST (clist)->selection;
|
||||
gchar *filename;
|
||||
gchar *fileperm;
|
||||
@@ -1265,9 +1275,17 @@
|
||||
char DIR_FOUND_IN_SELECTION = FALSE;
|
||||
char *current_remote_dir = strdup (this_session.cwd_dir);
|
||||
|
||||
- tmpnam (tmp_filename);
|
||||
- tmp = fopen (tmp_filename, "w");
|
||||
+ sprintf(tmp_filename, tmpfile_template);
|
||||
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1 || (tmp = fdopen (fd, "w")) == NULL)
|
||||
+ {
|
||||
+ if (fd != -1) {
|
||||
+ unlink(tmp_filename);
|
||||
+ close(fd);
|
||||
+ }
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
while (selection && (!want_abort))
|
||||
{
|
||||
@@ -1710,6 +1728,7 @@
|
||||
static char
|
||||
download_selection_recursive (void)
|
||||
{
|
||||
+ int fd = -1;
|
||||
GdkColor done_color = GREYCYAN;
|
||||
GdkColormap *colormap;
|
||||
GList *selection = GTK_CLIST (clist)->selection;
|
||||
@@ -1725,10 +1744,19 @@
|
||||
char *current_remote_dir = strdup (this_session.cwd_dir);
|
||||
char current_local_dir[1024];
|
||||
|
||||
+ sprintf(tmp_filename, tmpfile_template);
|
||||
+
|
||||
getcwd (current_local_dir, sizeof (current_local_dir));
|
||||
|
||||
- tmpnam (tmp_filename);
|
||||
- tmp = fopen (tmp_filename, "w");
|
||||
+ if ((fd = mkstemp (tmp_filename)) == -1 || (tmp = fdopen (fd, "w")) == NULL)
|
||||
+ {
|
||||
+ if (fd != -1) {
|
||||
+ unlink(tmp_filename);
|
||||
+ close(fd);
|
||||
+ }
|
||||
+ DEBUG("Unable to create temporary file.");
|
||||
+ return FALSE;
|
||||
+ }
|
||||
|
||||
colormap = gtk_widget_get_colormap (window);
|
||||
gdk_color_alloc (colormap, &done_color);
|
||||
@@ -1736,6 +1764,7 @@
|
||||
while (selection && (!xfer_abort) && (!want_abort))
|
||||
{
|
||||
static GtkStyle *cell_style;
|
||||
+ char msg_buf[1024];
|
||||
index = (int) selection->data;
|
||||
|
||||
cell_style = gtk_clist_get_cell_style (GTK_CLIST (clist), index, 3);
|
||||
@@ -1748,6 +1777,17 @@
|
||||
gtk_clist_get_text (GTK_CLIST (clist), index, 2, &filesize);
|
||||
gtk_clist_get_text (GTK_CLIST (clist), index, 3, &filedate);
|
||||
gtk_clist_get_text (GTK_CLIST (clist), index, 4, &fileperm);
|
||||
+
|
||||
+ /* Basic sanity checks */
|
||||
+
|
||||
+ if ((strchr(filename, '/') != NULL) || (strstr(filename, "..") != NULL)) {
|
||||
+ snprintf (msg_buf, sizeof(msg_buf), "Skipping non-relative filename: %s", filename);
|
||||
+ error_message (msg_buf);
|
||||
+ selection = selection->next;
|
||||
+ gtk_clist_unselect_row (GTK_CLIST (clist), index, 0);
|
||||
+ gtk_clist_moveto (GTK_CLIST (clist), index, 0, 0.5, 0);
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
if (fileperm[0] != 'd')
|
||||
{
|
|
@ -1,35 +0,0 @@
|
|||
--- main.c.orig Thu Apr 15 19:05:15 1999
|
||||
+++ main.c Fri Feb 10 22:43:48 2006
|
||||
@@ -20,6 +20,9 @@
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <floatingpoint.h>
|
||||
+#endif
|
||||
#include "protos.h"
|
||||
|
||||
|
||||
@@ -100,7 +103,22 @@
|
||||
GtkWidget *hbox;
|
||||
GtkWidget *vbox1;
|
||||
char IS_SPAWNED = FALSE;
|
||||
+ char *td;
|
||||
register int f;
|
||||
+
|
||||
+#ifdef __FreeBSD__
|
||||
+ fpsetmask(0);
|
||||
+#endif
|
||||
+ if ((td = getenv("TMPDIR")) != NULL && strlen(td) != 0) {
|
||||
+ if (td[strlen(td)-1] == '/')
|
||||
+ strncpy(tmpfile_template, td, strlen(td)-1);
|
||||
+ else
|
||||
+ strncpy(tmpfile_template, td, strlen(td));
|
||||
+ } else {
|
||||
+ strcpy(tmpfile_template, "/tmp");
|
||||
+ }
|
||||
+ strncat(tmpfile_template, "/", sizeof(tmpfile_template));
|
||||
+ strncat(tmpfile_template, TMPFILE_FILE, sizeof(tmpfile_template));
|
||||
|
||||
gtk_set_locale ();
|
||||
gtk_init (&argc, &argv);
|
|
@ -1,19 +0,0 @@
|
|||
IglooFTP is a new graphical FTP client written from scratch.
|
||||
Its main goals is to be easy to use and intuitive when used
|
||||
by novice, but powerful and fully configurable in the hand
|
||||
of experienced users.
|
||||
|
||||
Already available features are :
|
||||
|
||||
Intuitive user friendly interface, graphical configurability,
|
||||
toolbar, fast-connect bar, graphical directories browser,
|
||||
tree hierarchical site manager with site groups, user profile
|
||||
management, local and remote prompt command,
|
||||
directories creation/deletion, recursive downloads/uploads
|
||||
delete/move/chmod, file transfert resume, resolution of
|
||||
symbolic links, support of passive and non-passive data
|
||||
connection, possibility to show / hide hidden file,
|
||||
anti-idle tool, DND support, firewall support,
|
||||
own Netscape mini-toolbar and a great appearance.
|
||||
|
||||
WWW: http://www.littleigloo.org/iglooftp.php3
|
|
@ -1,58 +0,0 @@
|
|||
bin/IglooFTP
|
||||
%%DATADIR%%/app_ass/app_ass.GNOME
|
||||
%%DATADIR%%/app_ass/app_ass.KDE
|
||||
%%DATADIR%%/app_ass/app_ass.default
|
||||
%%DATADIR%%/bookmarks/default.bmk
|
||||
%%PORTDOCS%%%%DATADIR%%/docs/AUTHORS
|
||||
%%PORTDOCS%%%%DATADIR%%/docs/BUGS
|
||||
%%PORTDOCS%%%%DATADIR%%/docs/COPYRIGHT
|
||||
%%DATADIR%%/docs/ChangeLog
|
||||
%%DATADIR%%/docs/LICENSE
|
||||
%%DATADIR%%/docs/README
|
||||
%%PORTDOCS%%%%DATADIR%%/docs/THANKS
|
||||
%%PORTDOCS%%%%DATADIR%%/docs/TODO
|
||||
%%DATADIR%%/docs/welcome.msg
|
||||
%%DATADIR%%/gtkrc
|
||||
%%DATADIR%%/html/default.html
|
||||
%%DATADIR%%/html/images/amazon_mini.gif
|
||||
%%DATADIR%%/html/images/banner.gif
|
||||
%%DATADIR%%/html/images/bannerbg.gif
|
||||
%%DATADIR%%/html/images/bannerbg_bottom.gif
|
||||
%%DATADIR%%/html/images/bgsnow.gif
|
||||
%%DATADIR%%/html/images/bookshelf.gif
|
||||
%%DATADIR%%/html/images/hopbanner.gif
|
||||
%%DATADIR%%/html/images/hot100.jpg
|
||||
%%DATADIR%%/html/images/iglooftp.gif
|
||||
%%DATADIR%%/html/images/iglooftp_now1.gif
|
||||
%%DATADIR%%/html/images/iglooftp_now8.gif
|
||||
%%DATADIR%%/html/images/join.gif
|
||||
%%DATADIR%%/html/images/nav_books.gif
|
||||
%%DATADIR%%/html/images/nav_booksG.gif
|
||||
%%DATADIR%%/html/images/nav_download.gif
|
||||
%%DATADIR%%/html/images/nav_downloadG.gif
|
||||
%%DATADIR%%/html/images/nav_home.gif
|
||||
%%DATADIR%%/html/images/nav_homeG.gif
|
||||
%%DATADIR%%/html/images/nav_link.gif
|
||||
%%DATADIR%%/html/images/nav_linkG.gif
|
||||
%%DATADIR%%/html/images/nav_museum.gif
|
||||
%%DATADIR%%/html/images/nav_museumG.gif
|
||||
%%DATADIR%%/html/images/nav_news.gif
|
||||
%%DATADIR%%/html/images/nav_newsG.gif
|
||||
%%DATADIR%%/html/images/nav_search.gif
|
||||
%%DATADIR%%/html/images/nav_searchG.gif
|
||||
%%DATADIR%%/html/images/nav_soft.gif
|
||||
%%DATADIR%%/html/images/nav_softG.gif
|
||||
%%DATADIR%%/html/images/nav_tut.gif
|
||||
%%DATADIR%%/html/images/nav_tutG.gif
|
||||
%%DATADIR%%/html/images/search.gif
|
||||
%%DATADIR%%/html/images/softwares.jpg
|
||||
%%DATADIR%%/html/images/viglooftp.gif
|
||||
%%DATADIR%%/xpm/iglooftp.xpm
|
||||
%%DATADIR%%/xpm/little_igloo.xpm
|
||||
@dirrm %%DATADIR%%/app_ass
|
||||
@dirrm %%DATADIR%%/bookmarks
|
||||
@dirrm %%DATADIR%%/docs
|
||||
@dirrm %%DATADIR%%/html/images
|
||||
@dirrm %%DATADIR%%/html
|
||||
@dirrm %%DATADIR%%/xpm
|
||||
@dirrm %%DATADIR%%
|
|
@ -3,7 +3,6 @@
|
|||
|
||||
COMMENT = FTP client and server utilities
|
||||
|
||||
SUBDIR += IglooFTP
|
||||
SUBDIR += R-cran-RCurl
|
||||
SUBDIR += atftp
|
||||
SUBDIR += axel
|
||||
|
|
Loading…
Reference in a new issue