- Fix build with gcc 3.4 [1]
- Fix build on amd64 Reported by: pointyhat via kris [1]
This commit is contained in:
parent
c19459766b
commit
820e0a1724
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116161
2 changed files with 30 additions and 1 deletions
|
@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e 's|-O2||g; s|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
@${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -0,0 +1,29 @@
|
|||
--- src/libfungcalc/fparser/fparser.cc.orig Sat Aug 14 00:53:10 2004
|
||||
+++ src/libfungcalc/fparser/fparser.cc Sat Aug 14 00:54:04 2004
|
||||
@@ -163,7 +163,7 @@
|
||||
}
|
||||
return 0;
|
||||
}
|
||||
-};
|
||||
+}
|
||||
|
||||
//---------------------------------------------------------------------------
|
||||
// Constructors and destructors
|
||||
@@ -236,7 +236,7 @@
|
||||
}
|
||||
return true;
|
||||
}
|
||||
-};
|
||||
+}
|
||||
|
||||
bool FunctionParser::isValidName(const std::string& name)
|
||||
{
|
||||
@@ -361,7 +361,7 @@
|
||||
{
|
||||
while(F[Ind] && F[Ind] == ' ') ++Ind;
|
||||
}
|
||||
-};
|
||||
+}
|
||||
|
||||
// Returns an iterator to the variable with the same name as 'F', or to
|
||||
// Variables.end() if no such variable exists:
|
Loading…
Reference in a new issue