Astro::FITS::CFITSIO is a perl interface to William Pence's cfitsio
subroutine library. For more information on cfitsio, see http://heasarc.gsfc.nasa.gov/fitsio. This module attempts to provide a wrapper for nearly every cfitsio routine, while retaining as much cfitsio behavior as possible. As such, one should be aware that it is still somewhat low-level, in the sense that handing an array which is not the correct size to a routine like fits_write_img() may cause SIGSEGVs. WWW: http://search.cpan.org/dist/Astro-FITS-CFITSIO/
This commit is contained in:
parent
5d5fd5bc3a
commit
821a876f05
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267438
6 changed files with 65 additions and 0 deletions
|
@ -53,6 +53,7 @@
|
|||
SUBDIR += p5-Astro-Catalog
|
||||
SUBDIR += p5-Astro-Constants
|
||||
SUBDIR += p5-Astro-DSS
|
||||
SUBDIR += p5-Astro-FITS-CFITSIO
|
||||
SUBDIR += p5-Astro-FITS-Header
|
||||
SUBDIR += p5-Astro-Hipparcos
|
||||
SUBDIR += p5-Astro-MoonPhase
|
||||
|
|
28
astro/p5-Astro-FITS-CFITSIO/Makefile
Normal file
28
astro/p5-Astro-FITS-CFITSIO/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
# Ports collection makefile for: Astro-FITS-CFITSIO
|
||||
# Date created: Jan 6, 2010
|
||||
# Whom: Wen Heping <wen@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= Astro-FITS-CFITSIO
|
||||
PORTVERSION= 1.05
|
||||
CATEGORIES= astro perl5
|
||||
MASTER_SITES= CPAN
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= wen@FreeBSD.org
|
||||
COMMENT= Perl extension for using the cfitsio library
|
||||
|
||||
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= Astro::FITS::CFITSIO.3
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' ${WRKSRC}/Makefile.PL
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
astro/p5-Astro-FITS-CFITSIO/distinfo
Normal file
2
astro/p5-Astro-FITS-CFITSIO/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (Astro-FITS-CFITSIO-1.05.tar.gz) = bbeb6fd3b17b290842a88a8179c2526abae21fa67172295385a742b51bbfab70
|
||||
SIZE (Astro-FITS-CFITSIO-1.05.tar.gz) = 194185
|
13
astro/p5-Astro-FITS-CFITSIO/files/patch-Makefile.PL
Normal file
13
astro/p5-Astro-FITS-CFITSIO/files/patch-Makefile.PL
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.PL.orig 2011-01-05 10:36:07.000000000 +0800
|
||||
+++ Makefile.PL 2011-01-05 10:36:27.000000000 +0800
|
||||
@@ -8,8 +8,8 @@
|
||||
}
|
||||
else {
|
||||
warn("CFITSIO environment variable not found, assuming /usr/local/cfitsio\n");
|
||||
- $inc = "-I/usr/local/cfitsio";
|
||||
- $libs = "-L/usr/local/cfitsio -lcfitsio -lm";
|
||||
+ $inc = "-I/usr/local/include";
|
||||
+ $libs = "-L/usr/local/lib -lcfitsio -lm";
|
||||
}
|
||||
|
||||
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
|
11
astro/p5-Astro-FITS-CFITSIO/pkg-descr
Normal file
11
astro/p5-Astro-FITS-CFITSIO/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
Astro::FITS::CFITSIO is a perl interface to William Pence's cfitsio
|
||||
subroutine library. For more information on cfitsio, see
|
||||
http://heasarc.gsfc.nasa.gov/fitsio.
|
||||
|
||||
This module attempts to provide a wrapper for nearly every cfitsio
|
||||
routine, while retaining as much cfitsio behavior as possible. As
|
||||
such, one should be aware that it is still somewhat low-level, in
|
||||
the sense that handing an array which is not the correct size to a
|
||||
routine like fits_write_img() may cause SIGSEGVs.
|
||||
|
||||
WWW: http://search.cpan.org/dist/Astro-FITS-CFITSIO/
|
10
astro/p5-Astro-FITS-CFITSIO/pkg-plist
Normal file
10
astro/p5-Astro-FITS-CFITSIO/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/Astro/FITS/CFITSIO.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS/CFITSIO/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS/CFITSIO/autosplit.ix
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS/CFITSIO/CFITSIO.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS/CFITSIO/CFITSIO.so
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS/CFITSIO
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/FITS
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Astro/FITS
|
||||
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Astro
|
Loading…
Reference in a new issue