Update to version 3.1.1c.

PR:		14021
Submitted by:	KATO Tsuguru <tkato@prontomail.ne.jp>
This commit is contained in:
Steve Price 1999-10-10 23:49:55 +00:00
parent 440b794870
commit 8231c48269
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22336
7 changed files with 138 additions and 21 deletions

View file

@ -1,18 +1,47 @@
# New ports collection makefile for: xspread
# Version required: 2.1
# Version required: 3.1.1c
# Date created: 28 June 1995
# Whom: janek@gaja.ipan.lublin.pl
#
# $FreeBSD$
#
DISTNAME= xspread2.1
PKGNAME= xspread-2.1
DISTNAME= xspread3.1.1c
PKGNAME= xspread-3.1.1c
CATEGORIES= math
MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/distributions/slackware/source/xap/xspread/
# ${MASTER_SITE_SUNSITE} isn't appropriate because distributions/ isn't
# mirrored.
MASTER_SITES= http://www.linuxberg.com/files/x11/office/
USE_IMAKE= yes
USE_GMAKE= yes
MAN1= xspread.1
MAINTAINER= ports@FreeBSD.org
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
INSTALL_TARGET= install install.man
MAN1= xspread.1 pxspread.1
XS_DIR= ${PREFIX}/share/xspread
post-extract:
.for file in config.cache config.h config.log config.status
@${RM} ${WRKSRC}/${file} || ${TRUE}
.endfor
post-install:
.if !defined(NOPORTDOCS)
@find ${WRKSRC} -name "*.tmp" -delete || ${TRUE}
@${MKDIR} ${XS_DIR}
@${MKDIR} ${XS_DIR}/doc
@${MKDIR} ${XS_DIR}/documents
@${MKDIR} ${XS_DIR}/sample_files
@${MKDIR} ${XS_DIR}/tests
${INSTALL_DATA} ${WRKSRC}/README ${XS_DIR}
${INSTALL_DATA} ${WRKSRC}/x/notes ${XS_DIR}
${INSTALL_DATA} ${WRKSRC}/doc/* ${XS_DIR}/doc
${INSTALL_DATA} ${WRKSRC}/documents/* ${XS_DIR}/documents
${INSTALL_DATA} ${WRKSRC}/sample_files/* ${XS_DIR}/sample_files
${INSTALL_DATA} ${WRKSRC}/tests/* ${XS_DIR}/tests
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (xspread2.1.tar.gz) = 1c8cb085a16f2ea4754223c28ef051d6
MD5 (xspread3.1.1c.tar.gz) = 140bae9ed5c727b8d901634ca3958dc4

View file

@ -0,0 +1,20 @@
--- Makefile.in.orig Tue Nov 7 11:17:18 1995
+++ Makefile.in Tue Sep 28 01:41:35 1999
@@ -1,7 +1,7 @@
# Common prefix for installation directories.
# NOTE: This directory must exist when you start the install.
-prefix = /usr/local
+prefix = @prefix@
exec_prefix = $(prefix)
# Where to put the executables.
bindir = $(exec_prefix)/bin
@@ -19,7 +19,7 @@
CFLAGS = @CFLAGS@
DEFS = @DEFS@
LIBS = @LIBS@
-INCLUDEDIR = -I. -I$(srcdir)
+INCLUDEDIR = -I. -I$(srcdir) @CPPFLAGS@
LN = @LN_S@
RM = rm -f
SHELL = /bin/sh

View file

@ -0,0 +1,11 @@
--- config_h.in.orig Tue Nov 7 11:17:21 1995
+++ config_h.in Tue Sep 28 04:00:50 1999
@@ -12,7 +12,7 @@
#define SAVENAME "SC.SAVE"
/* The default file viewer */
-#define DFLT_PAGER "less"
+/* #define DFLT_PAGER "less" */
/* Define CRYPT_PATH if you want crypt support compiled in */
#undef CRYPT_PATH

View file

@ -1 +1 @@
A spreadsheet program under X
A spreadsheet program for X and terminals

View file

@ -1,10 +1,3 @@
This is a much modified version of the public domain spread sheet sc,
posted several years ago by Mark Weiser as vc, originally by James Gosling.
CHANGES lists the changes since 6.1 to 6.21.
Sc6.16 was released to comp.sources.misc and four sets of patches
bring Sc6.16->6.17->6.18->6.19->6.21.
Current maintainer: nstar!sawmill!prslnk!buhrt (Jeff Buhrt)
This is version 2.1.
The program xspread is a public domain spreadsheet which runs under
X Window system or ascii terminals. Xspread uses the X Window system
if available or curses and term[cap/info] for ascii displays.

View file

@ -1 +1,65 @@
bin/xspread
bin/pxspread
share/xspread/README
share/xspread/notes
share/xspread/doc/Sample_Run
share/xspread/doc/final_rpt
share/xspread/doc/last_xspread
share/xspread/doc/prog_rpt
share/xspread/doc/sc.changes
share/xspread/doc/sc.readme
share/xspread/doc/sc.vms_notes
share/xspread/doc/xspread.aux
share/xspread/doc/xspread.dvi
share/xspread/doc/xspread.log
share/xspread/doc/xspread.ps
share/xspread/doc/xspread.tex
share/xspread/doc/xspread.toc
share/xspread/doc/xspread_prog.asc
share/xspread/documents/progress.aux
share/xspread/documents/progress.dvi
share/xspread/documents/progress.log
share/xspread/documents/progress.ps
share/xspread/documents/progress.tex
share/xspread/documents/report.aux
share/xspread/documents/report.dvi
share/xspread/documents/report.log
share/xspread/documents/report.ps
share/xspread/documents/report.tex
share/xspread/sample_files/demo_dates
share/xspread/sample_files/demo_func
share/xspread/sample_files/demo_math
share/xspread/sample_files/demo_matrix
share/xspread/sample_files/demo_strval
share/xspread/sample_files/ex1
share/xspread/sample_files/ex1o
share/xspread/sample_files/ex2
share/xspread/sample_files/ex2o
share/xspread/sample_files/ex3
share/xspread/sample_files/tutorial
share/xspread/tests/Makefile
share/xspread/tests/READ_ME
share/xspread/tests/copy.cmp
share/xspread/tests/copy.input
share/xspread/tests/copy.output
share/xspread/tests/copy.sc
share/xspread/tests/intfunc.cmp
share/xspread/tests/intfunc.input
share/xspread/tests/intfunc.output
share/xspread/tests/intfunc.sc
share/xspread/tests/irr.cmp
share/xspread/tests/irr.input
share/xspread/tests/irr.output
share/xspread/tests/irr.sc
share/xspread/tests/read.cmp
share/xspread/tests/read.data
share/xspread/tests/read.input
share/xspread/tests/read.output
share/xspread/tests/read.sc
share/xspread/tests/tester.sh
share/xspread/tests/txt.sc
@dirrm share/xspread/tests
@dirrm share/xspread/sample_files
@dirrm share/xspread/documents
@dirrm share/xspread/doc
@dirrm share/xspread