Fix build on -current (#include <stdlib.h> for exit() prototype) and
respect CC and CFLAGS
This commit is contained in:
parent
311a5e1811
commit
824d2a80b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=68456
2 changed files with 35 additions and 3 deletions
28
www/dhttpd/files/patch-Makefile
Normal file
28
www/dhttpd/files/patch-Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- src/Makefile.orig Mon Mar 3 16:35:53 1997
|
||||
+++ src/Makefile Sun Oct 20 17:42:06 2002
|
||||
@@ -1,22 +1,21 @@
|
||||
# if compiling for SunOS, you need to add -lsocket to the LIBS variable
|
||||
|
||||
SH = /bin/sh
|
||||
-CC = gcc
|
||||
+CXX ?= c++
|
||||
MAKEFILE= Makefile
|
||||
-CFLAGS = -O2 --pipe
|
||||
LIBS =
|
||||
|
||||
OBJECTS = main.o socket.o httpsock.o
|
||||
|
||||
.cc.o:
|
||||
- $(CC) $(CFLAGS) -c -o $*.o $<
|
||||
+ $(CXX) $(CXXFLAGS) -c -o $*.o $<
|
||||
|
||||
all: compile dhttpd
|
||||
|
||||
compile: $(OBJECTS)
|
||||
|
||||
dhttpd: $(OBJECTS)
|
||||
- $(CC) -o dhttpd $(OBJECTS) $(LIBS)
|
||||
+ $(CXX) -o dhttpd $(OBJECTS) $(LIBS)
|
||||
strip dhttpd
|
||||
|
||||
clean:
|
|
@ -1,6 +1,6 @@
|
|||
--- src/main.cc Tue Mar 4 09:10:41 1997
|
||||
+++ src/main.cc.orig Mon Jun 24 15:12:32 2002
|
||||
@@ -18,7 +18,6 @@
|
||||
--- src/main.cc.orig Mon Mar 3 17:10:41 1997
|
||||
+++ src/main.cc Sun Oct 20 17:41:25 2002
|
||||
@@ -18,10 +18,10 @@
|
||||
*/
|
||||
|
||||
#include <errno.h>
|
||||
|
@ -8,3 +8,7 @@
|
|||
#include <pwd.h>
|
||||
#include <signal.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
#include <sys/socket.h>
|
||||
#include <sys/types.h>
|
||||
|
|
Loading…
Reference in a new issue