add libsigcx 0.6.0
libSigC++ Extras
This commit is contained in:
parent
18074c438c
commit
826a3e61e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=78402
7 changed files with 120 additions and 0 deletions
|
@ -327,6 +327,7 @@
|
|||
SUBDIR += libshhopt
|
||||
SUBDIR += libsigc++
|
||||
SUBDIR += libsigc++12
|
||||
SUBDIR += libsigcx
|
||||
SUBDIR += libslang
|
||||
SUBDIR += libstocks
|
||||
SUBDIR += libstrfunc
|
||||
|
|
30
devel/libsigcx/Makefile
Normal file
30
devel/libsigcx/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: libsigcx
|
||||
# Date created: Apr 6, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libsigcx
|
||||
PORTVERSION= 0.6.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= libsigcx
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= libSigC++ Extras
|
||||
|
||||
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
|
||||
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
|
||||
|
||||
USE_REINPLACE= yes
|
||||
USE_GNOME= gtk20
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
|
||||
|
||||
.include <bsd.port.mk>
|
1
devel/libsigcx/distinfo
Normal file
1
devel/libsigcx/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libsigcx-0.6.0.tar.gz) = 5abb6e0d707c6b0039445019645145b8
|
13
devel/libsigcx/files/patch-Makefile.in
Normal file
13
devel/libsigcx/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- Makefile.in.orig Sun Apr 6 15:08:21 2003
|
||||
+++ Makefile.in Sun Apr 6 15:08:35 2003
|
||||
@@ -142,8 +142,8 @@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = sigcx tests doc
|
||||
-DIST_SUBDIRS = sigcx tests examples doc scripts
|
||||
+SUBDIRS = sigcx tests
|
||||
+DIST_SUBDIRS = sigcx tests examples scripts
|
||||
|
||||
ACLOCAL_AMFLAGS = -I scripts
|
||||
|
41
devel/libsigcx/files/patch-ltmain.sh
Normal file
41
devel/libsigcx/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- scripts/ltmain.sh.orig Sat Mar 8 14:36:10 2003
|
||||
+++ scripts/ltmain.sh Sun Apr 6 15:01:17 2003
|
||||
@@ -1065,14 +1065,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd*)
|
||||
+ *-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd* | *-*-freebsd*)
|
||||
+ *-*-openbsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -2495,7 +2495,7 @@
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd*)
|
||||
+ *-*-openbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*)
|
||||
@@ -4325,10 +4325,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
5
devel/libsigcx/pkg-descr
Normal file
5
devel/libsigcx/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
libSigC++ Extras is a library consisting of new features built on top of
|
||||
libSigC++ and features that formerly were in libSigC++ and were removed
|
||||
from it.
|
||||
|
||||
WWW: http://libsigcx.sourceforge.net/
|
29
devel/libsigcx/pkg-plist
Normal file
29
devel/libsigcx/pkg-plist
Normal file
|
@ -0,0 +1,29 @@
|
|||
include/sigcx-0.6/sigcx/bind3.h
|
||||
include/sigcx-0.6/sigcx/convert.h
|
||||
include/sigcx-0.6/sigcx/dispatch.h
|
||||
include/sigcx-0.6/sigcx/gtk_dispatch.h
|
||||
include/sigcx-0.6/sigcx/macros/bind3.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/convert.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/corba_base.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/corba_convert.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/corba_signal.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/corba_slot.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/corba_tunnel.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/ref_slot.h.m4
|
||||
include/sigcx-0.6/sigcx/macros/template.macros.m4
|
||||
include/sigcx-0.6/sigcx/macros/tunnel.h.m4
|
||||
include/sigcx-0.6/sigcx/ref_slot.h
|
||||
include/sigcx-0.6/sigcx/thread.h
|
||||
include/sigcx-0.6/sigcx/thread_tunnel.h
|
||||
include/sigcx-0.6/sigcx/timeval.h
|
||||
include/sigcx-0.6/sigcx/tunnel.h
|
||||
include/sigcx-0.6/sigcx/util.h
|
||||
@dirrm include/sigcx-0.6/sigcx/macros
|
||||
@dirrm include/sigcx-0.6/sigcx
|
||||
@dirrm include/sigcx-0.6
|
||||
lib/libsigcx-0.6.so
|
||||
lib/libsigcx-0.6.so.0
|
||||
lib/libsigcx-gtk-0.6.so
|
||||
lib/libsigcx-gtk-0.6.so.0
|
||||
lib/pkgconfig/sigcx-0.6-gtk+.pc
|
||||
lib/pkgconfig/sigcx-0.6.pc
|
Loading…
Reference in a new issue