This plugin lets you remove attachments from emails.

PR:		ports/95456
Submitted by:	Pawel Pekala <c0rn@o2.pl>
This commit is contained in:
Pav Lucistnik 2006-04-29 14:58:22 +00:00
parent d622f81068
commit 8280754ea7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=160783
9 changed files with 95 additions and 0 deletions

View file

@ -523,6 +523,7 @@
SUBDIR += swaks
SUBDIR += sylpheed
SUBDIR += sylpheed-claws
SUBDIR += sylpheed-claws-att_remover
SUBDIR += sylpheed-claws-cachesaver
SUBDIR += sylpheed-claws-etpan_privacy
SUBDIR += sylpheed-claws-fetchinfo

View file

@ -0,0 +1,28 @@
# New ports collection makefile for: sylpheed-claws-att_remover
# Date created: 3 April 2006
# Whom: Pawel Pekala <c0rn@o2.pl>
#
# $FreeBSD$
#
PORTNAME= att_remover
PORTVERSION= 1.0
CATEGORIES= mail
MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
PKGNAMEPREFIX= sylpheed-claws-
MAINTAINER= c0rn@o2.pl
COMMENT= Attachments removing plugin for sylpheed-claws
BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= autoconf:259
PLIST_FILES= lib/sylpheed-claws/plugins/att_remover.a \
lib/sylpheed-claws/plugins/att_remover.la \
lib/sylpheed-claws/plugins/att_remover.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (att_remover-1.0.tar.gz) = 2bcc8bfa17a3a0c649126a6fd1821250
SHA256 (att_remover-1.0.tar.gz) = 524a5cfa69c687593c5ef7b8554aa225e05dbc02c9f34a68140176473c85f5ce
SIZE (att_remover-1.0.tar.gz) = 316733

View file

@ -0,0 +1,15 @@
--- configure.ac.orig Wed Apr 5 19:44:43 2006
+++ configure.ac Wed Apr 5 19:49:44 2006
@@ -42,7 +42,11 @@
dnl check for sylpheed-claws
PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+if test -z $prefix ; then
+ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+else
+ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
+fi
AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
AC_SUBST(SYLPHEED_CLAWS_LIBS)
AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)

View file

@ -0,0 +1 @@
This plugin lets you remove attachments from emails.

View file

@ -0,0 +1,28 @@
# New ports collection makefile for: sylpheed-claws-att_remover
# Date created: 3 April 2006
# Whom: Pawel Pekala <c0rn@o2.pl>
#
# $FreeBSD$
#
PORTNAME= att_remover
PORTVERSION= 1.0
CATEGORIES= mail
MASTER_SITES= http://claws.sylpheed.org/downloads/plugins/
PKGNAMEPREFIX= sylpheed-claws-
MAINTAINER= c0rn@o2.pl
COMMENT= Attachments removing plugin for sylpheed-claws
BUILD_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
RUN_DEPENDS= sylpheed-claws>=2.0:${PORTSDIR}/mail/sylpheed-claws
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_AUTOTOOLS= autoconf:259
PLIST_FILES= lib/sylpheed-claws/plugins/att_remover.a \
lib/sylpheed-claws/plugins/att_remover.la \
lib/sylpheed-claws/plugins/att_remover.so
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
MD5 (att_remover-1.0.tar.gz) = 2bcc8bfa17a3a0c649126a6fd1821250
SHA256 (att_remover-1.0.tar.gz) = 524a5cfa69c687593c5ef7b8554aa225e05dbc02c9f34a68140176473c85f5ce
SIZE (att_remover-1.0.tar.gz) = 316733

View file

@ -0,0 +1,15 @@
--- configure.ac.orig Wed Apr 5 19:44:43 2006
+++ configure.ac Wed Apr 5 19:49:44 2006
@@ -42,7 +42,11 @@
dnl check for sylpheed-claws
PKG_CHECK_MODULES(SYLPHEED_CLAWS, sylpheed-claws >= 1.9.100.93)
-SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+if test -z $prefix ; then
+ SYLPHEED_CLAWS_PLUGINDIR=$( $PKG_CONFIG --variable=plugindir sylpheed-claws )
+else
+ SYLPHEED_CLAWS_PLUGINDIR=${prefix}/lib/sylpheed-claws/plugins
+fi
AC_SUBST(SYLPHEED_CLAWS_CFLAGS)
AC_SUBST(SYLPHEED_CLAWS_LIBS)
AC_SUBST(SYLPHEED_CLAWS_PLUGINDIR)

View file

@ -0,0 +1 @@
This plugin lets you remove attachments from emails.