Sunpoet Po-Chuan Hsieh 2011-08-25 06:54:21 +00:00
parent febfb169f9
commit 82a2b59921
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=280384
4 changed files with 18 additions and 66 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= viking
PORTVERSION= 1.1
PORTREVISION= 1
PORTVERSION= 1.2.1
CATEGORIES= astro
MASTER_SITES= SF
@ -18,18 +17,18 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
USE_PERL5_RUN= yes
USE_GMAKE= yes
USE_GNOME= gtk20 libglade2 gnomedocutils
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
OPTIONS= GPSD "Enable realtime GPS tracking" off
.include <bsd.port.pre.mk>
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CPPFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
USE_GNOME= gnomedocutils gtk20 libglade2
USE_PERL5_RUN= yes
.include <bsd.port.options.mk>
.if defined(WITH_GPSD)
LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
@ -45,4 +44,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.post.mk>
post-patch:
@${REINPLACE_CMD} -e 's|gps_poll|gps_read|g' ${WRKSRC}/configure
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (viking-1.1.tar.gz) = 5c34a76c09b6fda092e8170f7546606814382cf9d13174e87c4ee43fffa36743
SIZE (viking-1.1.tar.gz) = 1012813
SHA256 (viking-1.2.1.tar.gz) = 7c4b36398a9ec121ab11b66f042d17368dd46cf328a2a0e00bda38fd357a9743
SIZE (viking-1.2.1.tar.gz) = 1054364

View file

@ -1,50 +0,0 @@
--- configure.orig 2011-03-22 22:22:02.000000000 +0300
+++ configure 2011-03-22 22:22:13.000000000 +0300
@@ -8239,9 +8239,9 @@
$as_echo "$ac_cv_enable_realtimegpstracking" >&6; }
case $ac_cv_enable_realtimegpstracking in
yes)
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gps_poll in -lgps" >&5
-$as_echo_n "checking for gps_poll in -lgps... " >&6; }
-if test "${ac_cv_lib_gps_gps_poll+set}" = set; then :
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for gps_read in -lgps" >&5
+$as_echo_n "checking for gps_read in -lgps... " >&6; }
+if test "${ac_cv_lib_gps_gps_read+set}" = set; then :
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -8255,27 +8255,27 @@
#ifdef __cplusplus
extern "C"
#endif
-char gps_poll ();
+char gps_read ();
int
main ()
{
-return gps_poll ();
+return gps_read ();
;
return 0;
}
_ACEOF
if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_lib_gps_gps_poll=yes
+ ac_cv_lib_gps_gps_read=yes
else
- ac_cv_lib_gps_gps_poll=no
+ ac_cv_lib_gps_gps_read=no
fi
rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_gps_gps_poll" >&5
-$as_echo "$ac_cv_lib_gps_gps_poll" >&6; }
-if test "x$ac_cv_lib_gps_gps_poll" = x""yes; then :
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_gps_gps_read" >&5
+$as_echo "$ac_cv_lib_gps_gps_read" >&6; }
+if test "x$ac_cv_lib_gps_gps_read" = x""yes; then :
cat >>confdefs.h <<_ACEOF
#define HAVE_LIBGPS 1
_ACEOF

View file

@ -7,4 +7,4 @@ tracks and waypoints, see real-time GPS position, etc.
It is written in C with the GTK+ 2 toolkit, available for Linux, other POSIX
operating systems, and Windows, and is licensed under the GNU GPL.
WWW: http://viking.sourceforge.net
WWW: http://viking.sourceforge.net/