- Update to build17
- Trim header Feature safe: yes
This commit is contained in:
parent
2023a73d29
commit
82cdc2a0b2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308070
7 changed files with 36 additions and 103 deletions
|
@ -1,24 +1,19 @@
|
|||
# Ports collection makefile for: widelands
|
||||
# Date created: 8 April 2007
|
||||
# Whom: Bartosz Fabianowski <freebsd@chillt.de>
|
||||
#
|
||||
# Created by: Bartosz Fabianowski <freebsd@chillt.de>
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= widelands
|
||||
DISTVERSION= build16
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= build17
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://launchpadlibrarian.net/69520494/ \
|
||||
MASTER_SITES= https://launchpadlibrarian.net/102893896/ \
|
||||
http://mirror.amdmi3.ru/distfiles/
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Realtime strategy game inspired by Settlers II
|
||||
|
||||
LIB_DEPENDS= ggzcore.9:${PORTSDIR}/games/ggz-client-libs \
|
||||
png15:${PORTSDIR}/graphics/png \
|
||||
GLEW.1:${PORTSDIR}/graphics/glew
|
||||
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
|
||||
GLEW.1:${PORTSDIR}/graphics/glew \
|
||||
execinfo:${PORTSDIR}/devel/libexecinfo
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
USE_BZIP2= yes
|
||||
|
@ -32,7 +27,6 @@ CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
|
|||
USE_LUA= 5.1+
|
||||
USE_SDL= sdl mixer image net ttf gfx
|
||||
USE_PYTHON_BUILD=2.5+
|
||||
CFLAGS+= -I${LOCALBASE}/include/libpng15
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
PLIST_FILES= bin/widelands
|
||||
|
@ -45,8 +39,6 @@ DESKTOP_ENTRIES="Widelands" \
|
|||
false
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/ifndef/ s|__APPLE__|__FreeBSD__|' \
|
||||
${WRKSRC}/src/backtrace.cc
|
||||
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
|
||||
${WRKSRC}/cmake/Modules/*.cmake
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (widelands-build16-src.tar.bz2) = d8db3c15c30314cb220c6d79d93d3d31e7bce2722c93d2c385d643c3c669625d
|
||||
SIZE (widelands-build16-src.tar.bz2) = 137808494
|
||||
SHA256 (widelands-build17-src.tar.bz2) = be48b3b8f342a537b39a3aec2f7702250a6a47e427188ba3bece67d7d90f3cc5
|
||||
SIZE (widelands-build17-src.tar.bz2) = 175547379
|
||||
|
|
|
@ -1,11 +1,30 @@
|
|||
--- CMakeLists.txt.orig 2011-04-15 22:40:26.000000000 +0400
|
||||
+++ CMakeLists.txt 2011-05-25 01:12:54.000000000 +0400
|
||||
@@ -204,7 +204,7 @@
|
||||
set (CMAKE_CXX_FLAGS_DEBUG "-g -DDEBUG -DNOPARACHUTE${WL_COMPILERFLAG_OLDSTYLECAST}${WL_COMPILERFLAG_GENERICWARNINGS}${WL_COMPILERFLAG_EXTRAWARNINGS}${WL_COMPILERFLAG_STRICT}" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
--- CMakeLists.txt.orig 2012-04-23 13:46:49.000000000 +0400
|
||||
+++ CMakeLists.txt 2012-11-30 17:28:03.093935459 +0400
|
||||
@@ -219,12 +219,10 @@
|
||||
)
|
||||
STRING(REGEX REPLACE ".*(4)\\.(5)\\.([0-9]).*" "\\1.\\2.\\3" WLBUILD_COMPILERVERSION_REP ${WLBUILD_COMPILERVERSION})
|
||||
IF (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
|
||||
- message("Detected gcc ${WLBUILD_COMPILERVERSION_REP}")
|
||||
- message("Suffering from gcc bug, disabling -O3")
|
||||
- set (CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
+ set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
ELSE (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
|
||||
#This line is the default and should be preserved.
|
||||
- set (CMAKE_CXX_FLAGS_RELEASE "-O3 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
+ set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
ENDIF (WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.1" OR WLBUILD_COMPILERVERSION_REP STREQUAL "4.5.2")
|
||||
ENDIF (${CMAKE_COMPILER_IS_GNUCXX})
|
||||
|
||||
# CMAKE defines "-O3 -DNDEBUG", but we better say -O2 (see gcc manual)
|
||||
-set (CMAKE_CXX_FLAGS_RELEASE "-O2 -DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
+set (CMAKE_CXX_FLAGS_RELEASE "-DNDEBUG" CACHE STRING "Set by widelands CMakeLists.txt" FORCE)
|
||||
@@ -391,10 +389,10 @@
|
||||
find_package(ZLIB REQUIRED)
|
||||
include_directories(${ZLIB_INCLUDE_DIR})
|
||||
|
||||
#If building with MSVC, then check for 3rdparty libs
|
||||
if (DEFINED MSVC)
|
||||
-if (APPLE OR WIN32)
|
||||
+if (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
|
||||
find_package(intl REQUIRED)
|
||||
include_directories(${INTL_INCLUDE_DIR})
|
||||
-endif (APPLE OR WIN32)
|
||||
+endif (APPLE OR WIN32 OR CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
|
||||
|
||||
find_package(SDL REQUIRED)
|
||||
include_directories(${SDL_INCLUDE_DIR})
|
||||
|
|
|
@ -1,8 +0,0 @@
|
|||
--- doc/CMakeLists.txt.orig 2011-04-15 22:40:26.000000000 +0400
|
||||
+++ doc/CMakeLists.txt 2011-05-25 01:42:25.000000000 +0400
|
||||
@@ -1,5 +1,4 @@
|
||||
IF (NOT WIN32)
|
||||
- find_package(Doxygen)
|
||||
if (DOXYGEN_FOUND)
|
||||
include(Documentation)
|
||||
file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/sourcecode)
|
|
@ -1,35 +0,0 @@
|
|||
--- src/graphic/SDL_mng.cc.orig 2011-04-15 20:40:26.000000000 +0200
|
||||
+++ src/graphic/SDL_mng.cc 2012-05-03 23:15:20.000000000 +0200
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <SDL_endian.h>
|
||||
|
||||
#include <png.h>
|
||||
+#include <pngpriv.h>
|
||||
|
||||
/* Chunk structure */
|
||||
struct chunk_t {
|
||||
@@ -230,7 +231,7 @@
|
||||
}
|
||||
|
||||
/* png_read_data callback; return <size> bytes from wherever */
|
||||
-static void png_read_data(png_structp ctx, png_bytep area, png_size_t size)
|
||||
+static void local_png_read_data(png_structp ctx, png_bytep area, png_size_t size)
|
||||
{
|
||||
SDL_RWread(static_cast<SDL_RWops *>(png_get_io_ptr(ctx)), area, size, 1);
|
||||
}
|
||||
@@ -276,13 +277,13 @@
|
||||
* the normal method of doing things with libpng). REQUIRED unless you
|
||||
* set up your own error handlers in png_create_read_struct() earlier.
|
||||
*/
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
SDL_SetError("Error reading the PNG file.");
|
||||
goto done;
|
||||
}
|
||||
|
||||
/* Set up the input control */
|
||||
- png_set_read_fn(png_ptr, src, png_read_data);
|
||||
+ png_set_read_fn(png_ptr, src, local_png_read_data);
|
||||
|
||||
/* tell PNG not to read the signature */
|
||||
png_set_sig_bytes(png_ptr, 8);
|
|
@ -1,16 +0,0 @@
|
|||
--- src/io/filesystem/disk_filesystem.cc.orig 2011-04-15 22:40:26.000000000 +0400
|
||||
+++ src/io/filesystem/disk_filesystem.cc 2011-05-25 00:53:00.000000000 +0400
|
||||
@@ -436,10 +436,10 @@
|
||||
int file = 0;
|
||||
void * data = 0;
|
||||
|
||||
-#ifdef __APPLE__
|
||||
- file = open(fullname.c_str(), O_RDONLY);
|
||||
-#else
|
||||
+#ifdef __linux__
|
||||
file = open(fullname.c_str(), O_RDONLY|O_NOATIME);
|
||||
+#else
|
||||
+ file = open(fullname.c_str(), O_RDONLY);
|
||||
#endif
|
||||
length = lseek(file, 0, SEEK_END);
|
||||
lseek(file, 0, SEEK_SET);
|
|
@ -1,19 +0,0 @@
|
|||
--- src/wlapplication.cc.orig 2011-04-15 22:40:26.000000000 +0400
|
||||
+++ src/wlapplication.cc 2011-05-25 08:48:45.000000000 +0400
|
||||
@@ -963,12 +963,12 @@
|
||||
int result = -1;
|
||||
|
||||
//add default video mode
|
||||
-#ifdef linux
|
||||
- videomode.push_back("x11");
|
||||
-#elif WIN32
|
||||
+#if defined WIN32
|
||||
videomode.push_back("windib");
|
||||
-#elif __APPLE__
|
||||
+#elif defined __APPLE__
|
||||
videomode.push_back("Quartz");
|
||||
+#else
|
||||
+ videomode.push_back("x11");
|
||||
#endif
|
||||
//if a video mode is given on the command line, add that one first
|
||||
const char * videodrv;
|
Loading…
Reference in a new issue