Add a small patch so that it works with 5.005_03.
Approved by: maintainer (pav)
This commit is contained in:
parent
5e8a7e0ef2
commit
82d597dab2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101396
3 changed files with 106 additions and 4 deletions
|
@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
|
|||
MAINTAINER= pav@FreeBSD.org
|
||||
COMMENT= Implementation of SMTP, ESMTP and LMTP protocols
|
||||
|
||||
RUN_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
|
||||
BUILD_DEPENDS= ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
|
@ -27,7 +28,8 @@ MAN3= Net::Server::Mail.3 \
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
IGNORE= This port needs Perl 5.006 or greater, please upgrade your Perl
|
||||
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/INET.pm:${PORTSDIR}/devel/p5-IO
|
||||
EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
98
mail/p5-Net-Server-Mail/files/5.005_03.diff
Normal file
98
mail/p5-Net-Server-Mail/files/5.005_03.diff
Normal file
|
@ -0,0 +1,98 @@
|
|||
diff -ru lib.old/Net/Server/Mail/ESMTP/8BITMIME.pm lib/Net/Server/Mail/ESMTP/8BITMIME.pm
|
||||
--- lib.old/Net/Server/Mail/ESMTP/8BITMIME.pm Tue Jun 25 15:53:21 2002
|
||||
+++ lib/Net/Server/Mail/ESMTP/8BITMIME.pm Thu Feb 19 15:27:11 2004
|
||||
@@ -1,6 +1,5 @@
|
||||
package Net::Server::Mail::ESMTP::8BITMIME;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use base qw(Net::Server::Mail::ESMTP::Extension);
|
||||
+BEGIN {require Net::Server::Mail::ESMTP::Extension;@Net::Server::Mail::ESMTP::8BITMIME::ISA = ('Net::Server::Mail::ESMTP::Extension')};
|
||||
|
||||
diff -ru lib.old/Net/Server/Mail/ESMTP/Extension.pm lib/Net/Server/Mail/ESMTP/Extension.pm
|
||||
--- lib.old/Net/Server/Mail/ESMTP/Extension.pm Thu Nov 7 18:53:51 2002
|
||||
+++ lib/Net/Server/Mail/ESMTP/Extension.pm Thu Feb 19 15:27:13 2004
|
||||
@@ -1,6 +1,5 @@
|
||||
package Net::Server::Mail::ESMTP::Extension;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
|
||||
=pod
|
||||
diff -ru lib.old/Net/Server/Mail/ESMTP/PIPELINING.pm lib/Net/Server/Mail/ESMTP/PIPELINING.pm
|
||||
--- lib.old/Net/Server/Mail/ESMTP/PIPELINING.pm Mon Jan 6 12:21:43 2003
|
||||
+++ lib/Net/Server/Mail/ESMTP/PIPELINING.pm Thu Feb 19 15:27:16 2004
|
||||
@@ -1,6 +1,5 @@
|
||||
package Net::Server::Mail::ESMTP::PIPELINING;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use base 'Net::Server::Mail::ESMTP::Extension';
|
||||
+BEGIN {require Net::Server::Mail::ESMTP::Extension;@Net::Server::Mail::ESMTP::PIPELINING::ISA = ('Net::Server::Mail::ESMTP::Extension')};
|
||||
use constant GROUP_COMMANDS => [qw(RSET MAIL SEND SOML SAML RCPT)];
|
||||
diff -ru lib.old/Net/Server/Mail/ESMTP.pm lib/Net/Server/Mail/ESMTP.pm
|
||||
--- lib.old/Net/Server/Mail/ESMTP.pm Sun Apr 6 17:33:02 2003
|
||||
+++ lib/Net/Server/Mail/ESMTP.pm Thu Feb 19 15:32:21 2004
|
||||
@@ -1,9 +1,8 @@
|
||||
package Net::Server::Mail::ESMTP;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
use Carp;
|
||||
-use base qw(Net::Server::Mail::SMTP);
|
||||
+BEGIN {require Net::Server::Mail::SMTP;@Net::Server::Mail::ESMTP::ISA = ('Net::Server::Mail::SMTP')};
|
||||
|
||||
=pod
|
||||
|
||||
diff -ru lib.old/Net/Server/Mail/LMTP.pm lib/Net/Server/Mail/LMTP.pm
|
||||
--- lib.old/Net/Server/Mail/LMTP.pm Fri Mar 14 16:25:03 2003
|
||||
+++ lib/Net/Server/Mail/LMTP.pm Thu Feb 19 15:26:59 2004
|
||||
@@ -1,6 +1,5 @@
|
||||
package Net::Server::Mail::LMTP;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use base qw(Net::Server::Mail::ESMTP);
|
||||
+BEGIN {require Net::Server::Mail::ESMTP;@Net::Server::Mail::LMTP::ISA = ('Net::Server::Mail::ESMTP')};
|
||||
|
||||
diff -ru lib.old/Net/Server/Mail/SMTP.pm lib/Net/Server/Mail/SMTP.pm
|
||||
--- lib.old/Net/Server/Mail/SMTP.pm Sun Apr 6 17:36:40 2003
|
||||
+++ lib/Net/Server/Mail/SMTP.pm Thu Feb 19 15:32:24 2004
|
||||
@@ -1,8 +1,7 @@
|
||||
package Net::Server::Mail::SMTP;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
-use base 'Net::Server::Mail';
|
||||
+BEGIN {require Net::Server::Mail;@Net::Server::Mail::SMTP::ISA = ('Net::Server::Mail')};
|
||||
|
||||
=pod
|
||||
|
||||
diff -ru lib.old/Net/Server/Mail.pm lib/Net/Server/Mail.pm
|
||||
--- lib.old/Net/Server/Mail.pm Sun Apr 6 17:18:17 2003
|
||||
+++ lib/Net/Server/Mail.pm Thu Feb 19 15:50:38 2004
|
||||
@@ -1,6 +1,5 @@
|
||||
package Net::Server::Mail;
|
||||
|
||||
-use 5.006;
|
||||
use strict;
|
||||
use Sys::Hostname;
|
||||
use IO::Select;
|
||||
@@ -500,7 +499,7 @@
|
||||
else
|
||||
{
|
||||
next unless defined;
|
||||
- my $rv = $self->{process_operation}($self, $_);
|
||||
+ my $rv = $self->{process_operation}->($self, $_);
|
||||
# if $rv is defined, we have to close the connection
|
||||
return $rv if defined $rv;
|
||||
}
|
||||
@@ -518,7 +517,7 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- return $self->{process_operation}($self, $operation);
|
||||
+ return $self->{process_operation}->($self, $operation);
|
||||
}
|
||||
}
|
||||
|
|
@ -8,6 +8,8 @@
|
|||
%%SITE_PERL%%/Net/Server/Mail/SMTP.pm
|
||||
@dirrm %%SITE_PERL%%/Net/Server/Mail/ESMTP
|
||||
@dirrm %%SITE_PERL%%/Net/Server/Mail
|
||||
@dirrm %%SITE_PERL%%/Net/Server
|
||||
@unexec rmdir %D/%%SITE_PERL%%/Net/Server 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server/Mail
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Server 2>/dev/null || true
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue