- use installed header files for tcl and tk;

we no longer need the full sources to these

- install the tix header files for the C interface
This commit is contained in:
Thomas Gellekum 1997-01-07 08:17:13 +00:00
parent 2467d44263
commit 830dc3c44a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=5248
3 changed files with 75 additions and 20 deletions

View file

@ -1,9 +1,9 @@
# New ports collection makefile for: tix
# Version required: 1.4b2
# Version required: 4.1b2
# Date created: 22 December 1996
# Whom: Thomas Gellekum <tg@freebsd.org>
#
# $Id: Makefile,v 1.1.1.1 1996/12/30 07:13:50 tg Exp $
# $Id: Makefile,v 1.2 1997/01/02 07:12:33 tg Exp $
#
DISTNAME= Tix4.1b2
@ -17,9 +17,10 @@ LIB_DEPENDS= tk41\\.1\\.:${PORTSDIR}/x11/tk41
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-tk40 --enable-tk41 --enable-tk41-shared \
--with-tcl75_src_dir=/usr/src/contrib/tcl \
--with-tk41_src_dir="${PORTSDIR}/x11/tk41/work/tk4.1" \
--with-tcl75_src_dir=/usr/include/tcl \
--with-tk41_src_dir="${PREFIX}/include/tk" \
--with-extra_ldflags="-L${PREFIX}/lib"
# this should probably be added to bsd.port.mk
CONFIGURE_ENV= PREFIX=${PREFIX}
MAN1= tixwish.1
MANN= BtnBox.n Balloon.n ChkList.n Destroy.n ComboBox.n Control.n \
@ -31,21 +32,17 @@ MANN= BtnBox.n Balloon.n ChkList.n Destroy.n ComboBox.n Control.n \
Select.n StdBBox.n TixIntro.n Tree.n Utils.n Wm.n compound.n \
pixmap.n tix.n
pre-extract:
.if !exists(/usr/src/contrib/tcl)
@echo "Tix wants access to the Tcl source."
@echo "Please install /usr/src/contrib/tcl"
@echo "from the FreeBSD source distribution."
@false
.endif
.if !exists(${PORTSDIR}/x11/tk41/work/tk4.1)
@cd ${PORTSDIR}/x11/tk41; make extract
.endif
post-install:
@${MKDIR} ${PREFIX}/man/man1
@mv ${PREFIX}/man/mann/tixwish.1 ${PREFIX}/man/man1
@ln -sf ${PREFIX}/bin/tixwish4.1.4.1 ${PREFIX}/bin/tixwish
ldconfig -m ${PREFIX}/lib
/sbin/ldconfig -m ${PREFIX}/lib
.for dir in generic unix
@${MKDIR} ${PREFIX}/include/tix/${dir}
${INSTALL_DATA} ${WRKSRC}/${dir}/*.h ${PREFIX}/include/tix/${dir}
.endfor
${RM} ${PREFIX}/include/tix/generic/tix.h
@# These two files are the same
/bin/ln -sf ../../tix.h ${PREFIX}/include/tix/generic
.include <bsd.port.mk>

View file

@ -1,6 +1,18 @@
--- configure.orig Wed Dec 25 06:03:25 1996
+++ configure Tue Dec 31 14:33:35 1996
@@ -2592,11 +2592,11 @@
+++ configure Sun Jan 5 20:14:01 1997
@@ -2583,20 +2583,20 @@
done
fi
- if test ! -r $TCL75_SRC_DIR/unix/tclConfig.sh.in; then
- TCL75_SRC_DIR=""
- fi
+# if test ! -r $TCL75_SRC_DIR/unix/tclConfig.sh.in; then
+# TCL75_SRC_DIR=""
+# fi
if test "$TCL75_SRC_DIR" = ""; then
echo "$ac_t""(not found)" 1>&6
else
echo "$ac_t""$TCL75_SRC_DIR" 1>&6
@ -17,6 +29,35 @@
fi
#
@@ -2614,20 +2614,20 @@
done
fi
- if test ! -r $TK41_SRC_DIR/unix/tkConfig.sh.in; then
- TK41_SRC_DIR=""
- fi
+# if test ! -r $TK41_SRC_DIR/unix/tkConfig.sh.in; then
+# TK41_SRC_DIR=""
+# fi
if test "$TK41_SRC_DIR" = ""; then
echo "$ac_t""(not found)" 1>&6
else
echo "$ac_t""$TK41_SRC_DIR" 1>&6
- if test ! -r "$TK41_SRC_DIR/unix/tkConfig.sh"; then
- echo "warning: $TK41_SRC_DIR/unix/tkConfig.sh missing"
- echo " Please to configure tk 4.1 first."
- TK41_SRC_DIR=""
- fi
+# if test ! -r "$TK41_SRC_DIR/unix/tkConfig.sh"; then
+# echo "warning: $TK41_SRC_DIR/unix/tkConfig.sh missing"
+# echo " Please to configure tk 4.1 first."
+# TK41_SRC_DIR=""
+# fi
fi
#----------------------------------------------------------------------
# MAIN STUFF
@@ -2635,7 +2635,7 @@
if test "$TK41_SRC_DIR" != "" -a "$TCL75_SRC_DIR" != ""; then
# 1. Load the compilation flags for TCL 7.5

View file

@ -1,8 +1,23 @@
lib/libtix4141.so.1.0
@exec ldconfig -m %B
bin/tixwish4.1.4.1
@exec ln -s %D/%F %B/tixwish
@unexec rm %B/tixwish
include/tix.h
include/tix/generic/tix.h
include/tix/generic/tixDef.h
include/tix/generic/tixForm.h
include/tix/generic/tixGrData.h
include/tix/generic/tixGrid.h
include/tix/generic/tixHList.h
include/tix/generic/tixImgXpm.h
include/tix/generic/tixInt.h
include/tix/generic/tixItcl.h
include/tix/generic/tixPatchLevel.h
include/tix/generic/tixPort.h
include/tix/generic/tixTList.h
include/tix/unix/tixUnixInt.h
include/tix/unix/tixUnixPort.h
lib/libtix4141.so.1.0
@exec /sbin/ldconfig -m %B
man/mann/BtnBox.n.gz
man/mann/Balloon.n.gz
man/mann/ChkList.n.gz
@ -80,6 +95,7 @@ share/tix4.1/bitmaps/minus.xpm
share/tix4.1/bitmaps/minusarm.gif
share/tix4.1/bitmaps/minusarm.xbm
share/tix4.1/bitmaps/minusarm.xpm
share/tix4.1/bitmaps/mktransgif.tcl
share/tix4.1/bitmaps/network.xbm
share/tix4.1/bitmaps/no_entry.gif
share/tix4.1/bitmaps/no_entry.xpm
@ -231,6 +247,7 @@ share/tix4.1/FileCmpt.tcl
share/tix4.1/FileDlg.tcl
share/tix4.1/FileEnt.tcl
share/tix4.1/FileUtil.tcl
share/tix4.1/FloatEnt.tcl
share/tix4.1/Grid.tcl
share/tix4.1/HList.tcl
share/tix4.1/HListDD.tcl