Allow concurrent installation
PR: 225532 Submitted by: jhale Approved by: maintainer-timeout (2 weeks)
This commit is contained in:
parent
cbee07ff1c
commit
8314f942a9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461881
2 changed files with 21 additions and 1 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= coverage
|
||||
PORTVERSION= 4.5.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -13,7 +14,7 @@ COMMENT= Code coverage measurement for Python
|
|||
LICENSE= BSD2CLAUSE
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/coverage/tracer.so
|
||||
|
|
19
devel/py-coverage/files/patch-setup.py
Normal file
19
devel/py-coverage/files/patch-setup.py
Normal file
|
@ -0,0 +1,19 @@
|
|||
Allow USE_PYTHON=concurrent to handle script renaming/linking for multiple
|
||||
Python versions.
|
||||
|
||||
--- setup.py.orig 2018-01-29 11:46:04 UTC
|
||||
+++ setup.py
|
||||
@@ -86,12 +86,9 @@ setup_args = dict(
|
||||
},
|
||||
|
||||
entry_points={
|
||||
- # Install a script as "coverage", and as "coverage[23]", and as
|
||||
- # "coverage-2.7" (or whatever).
|
||||
+ # Install a script as "coverage"
|
||||
'console_scripts': [
|
||||
'coverage = coverage.cmdline:main',
|
||||
- 'coverage%d = coverage.cmdline:main' % sys.version_info[:1],
|
||||
- 'coverage-%d.%d = coverage.cmdline:main' % sys.version_info[:2],
|
||||
],
|
||||
},
|
||||
|
Loading…
Reference in a new issue