Import xmdiary port. xmdiary is another calendar, appointment book,
organizer. PR: 4658 Submitted by: Mikhail Teterin <mi@aldan.ziplink.net>
This commit is contained in:
parent
e27319791e
commit
8334376110
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10084
9 changed files with 185 additions and 0 deletions
35
deskutils/xmdiary/Makefile
Normal file
35
deskutils/xmdiary/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: xmdiary
|
||||
# Version required: 3.0.1
|
||||
# Date created: 29 Sep 1997
|
||||
# Whom: mi@aldan.ziplink.net
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= xmdiary-3.0.1
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
|
||||
MASTER_SITE_SUBDIR= office
|
||||
DISTFILES= ${DISTNAME}.tar.gz xmdfix.gz
|
||||
|
||||
MAINTAINER= mi@aldan.ziplink.net
|
||||
|
||||
NO_CDROM= "Don't sell for profit"
|
||||
EXTRACT_ONLY= ${DISTNAME}.tar.gz
|
||||
REQUIRES_MOTIF= yes
|
||||
USE_IMAKE= yes
|
||||
|
||||
pre-patch:
|
||||
for node in `tar tzf ${DISTDIR}/xmdfix.gz` ; \
|
||||
do \
|
||||
test -f $(WRKSRC)/$$node && ${RM} -f $(WRKSRC)/$$node ; \
|
||||
done
|
||||
cd $(WRKSRC) && tar xzpf ${DISTDIR}/xmdfix.gz
|
||||
|
||||
post-patch:
|
||||
@echo removing the "malloc.h" includes
|
||||
${SCRIPTDIR}/nomalloc $(WRKSRC) 2>&1 > /dev/zero
|
||||
@echo removing unneccessary DependTarget from Imakefile-s
|
||||
${SCRIPTDIR}/noextradepend $(WRKSRC) 2>&1 > /dev/zero
|
||||
|
||||
.include <bsd.port.mk>
|
2
deskutils/xmdiary/distinfo
Normal file
2
deskutils/xmdiary/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (xmdiary-3.0.1.tar.gz) = 0873b27a5dc385ce0566c53f25cdffeb
|
||||
MD5 (xmdfix.gz) = 76dc4f4ee6db13f5b4e068a3a8f4ed99
|
13
deskutils/xmdiary/files/patch-aa
Normal file
13
deskutils/xmdiary/files/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- ndbm/xdndbm.c.orig Tue Jun 27 03:55:51 1995
|
||||
+++ ndbm/xdndbm.c Mon Sep 29 01:53:52 1997
|
||||
@@ -50,8 +50,10 @@
|
||||
static int delitem();
|
||||
static int additem();
|
||||
|
||||
+#ifndef __FreeBSD__
|
||||
extern int errno;
|
||||
extern long lseek();
|
||||
+#endif
|
||||
|
||||
#ifdef DEBUG
|
||||
static chkblk(char buf[PBLKSIZ]);
|
29
deskutils/xmdiary/files/patch-ab
Normal file
29
deskutils/xmdiary/files/patch-ab
Normal file
|
@ -0,0 +1,29 @@
|
|||
--- XDiary.tmpl.orig Mon Jun 26 15:57:52 1995
|
||||
+++ XDiary.tmpl Mon Sep 29 12:57:31 1997
|
||||
@@ -100,6 +100,6 @@
|
||||
|
||||
-XDEXEDIR = /usr/local/bin
|
||||
-XDDATADIR = /usr/local/lib/xdiary
|
||||
-XDAPPDIR = /usr/lib/X11/app-defaults
|
||||
-XDMANDIR = /usr/local/man/man1
|
||||
+XDEXEDIR = $(X11BASE)/bin
|
||||
+XDDATADIR = $(X11BASE)/lib/X11/xdiary
|
||||
+XDAPPDIR = $(X11BASE)/lib/X11/app-defaults
|
||||
+XDMANDIR = $(X11BASE)/man/man1
|
||||
|
||||
@@ -128,6 +128,6 @@
|
||||
|
||||
-/* XDXTINC = */
|
||||
-/* XDXTLIB = */
|
||||
-/* XDXMINC = */
|
||||
-/* XDXMLIB = */
|
||||
+XDXTINC = -I/usr/X11R6/include
|
||||
+XDXTLIB = -L/usr/X11R6/lib
|
||||
+XDXMINC = -I/usr/X11R6/include
|
||||
+XDXMLIB = -L/usr/X11R6/lib
|
||||
|
||||
@@ -157,3 +157,3 @@
|
||||
|
||||
-/* XDEXTRALIBS = */
|
||||
+XDEXTRALIBS = -lXext
|
||||
|
1
deskutils/xmdiary/pkg-comment
Normal file
1
deskutils/xmdiary/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Personal and group calendar utility.
|
8
deskutils/xmdiary/pkg-descr
Normal file
8
deskutils/xmdiary/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
From xdiary's man page:
|
||||
|
||||
XDiary is your personal organizer that combines the
|
||||
functions of a desktop calendar, an appointment book and
|
||||
an alarm clock. XDiary will help you keep track of your
|
||||
meetings, appointments and plan your time.
|
||||
|
||||
-mi
|
65
deskutils/xmdiary/pkg-plist
Normal file
65
deskutils/xmdiary/pkg-plist
Normal file
|
@ -0,0 +1,65 @@
|
|||
bin/xdaclunix
|
||||
bin/xdalarm
|
||||
bin/xdcustom
|
||||
bin/xddump
|
||||
bin/xdiary
|
||||
bin/xdinitdb
|
||||
bin/xdlight
|
||||
bin/xdlocation
|
||||
bin/xdnotify
|
||||
bin/xdprformat
|
||||
bin/xdprint
|
||||
bin/xdremind
|
||||
bin/xdremote
|
||||
bin/xdremove
|
||||
bin/xdrestore
|
||||
lib/libTools.a
|
||||
lib/libXdiary.a
|
||||
lib/libXdndbm.a
|
||||
lib/libXtools.a
|
||||
lib/X11/app-defaults/XDiary
|
||||
lib/X11/app-defaults/XDiary.map
|
||||
lib/X11/xdiary/Install.db
|
||||
lib/X11/xdiary/Library.db
|
||||
lib/X11/xdiary/Manual.db
|
||||
lib/X11/xdiary/News.db
|
||||
lib/X11/xdiary/TopicMsgEn_US.cat
|
||||
lib/X11/xdiary/Windows.db
|
||||
lib/X11/xdiary/XDiary.syspr
|
||||
lib/X11/xdiary/XDiary.userpr
|
||||
lib/X11/xdiary/XDiaryMsgEn_US.cat
|
||||
lib/X11/xdiary/XDpsCommon.pro
|
||||
lib/X11/xdiary/XDpsDay.pro
|
||||
lib/X11/xdiary/XDpsList.pro
|
||||
lib/X11/xdiary/XDpsMonth.pro
|
||||
lib/X11/xdiary/XDpsWeek.pro
|
||||
lib/X11/xdiary/auldLang.tune
|
||||
lib/X11/xdiary/dragnet.tune
|
||||
lib/X11/xdiary/forElise.tune
|
||||
lib/X11/xdiary/helan.tune
|
||||
lib/X11/xdiary/highChirp.tune
|
||||
lib/X11/xdiary/holidays1991
|
||||
lib/X11/xdiary/holidays1992
|
||||
lib/X11/xdiary/holidays1993
|
||||
lib/X11/xdiary/holidays1994
|
||||
lib/X11/xdiary/holidays1995
|
||||
lib/X11/xdiary/holidays1996
|
||||
lib/X11/xdiary/holidays1997
|
||||
lib/X11/xdiary/holidays1998
|
||||
lib/X11/xdiary/holidays1999
|
||||
lib/X11/xdiary/mediumChirp.tune
|
||||
lib/X11/xdiary/ohNo.tune
|
||||
lib/X11/xdiary/swedish.tune
|
||||
man/man1/xdaclunix.1.gz
|
||||
man/man1/xdalarm.1.gz
|
||||
man/man1/xdcustom.1.gz
|
||||
man/man1/xddump.1.gz
|
||||
man/man1/xdiary.1.gz
|
||||
man/man1/xdinitdb.1.gz
|
||||
man/man1/xdlight.1.gz
|
||||
man/man1/xdnotify.1.gz
|
||||
man/man1/xdprformat.1.gz
|
||||
man/man1/xdremind.1.gz
|
||||
man/man1/xdremove.1.gz
|
||||
man/man1/xdrestore.1.gz
|
||||
@dirrm lib/X11/xdiary
|
16
deskutils/xmdiary/scripts/noextradepend
Normal file
16
deskutils/xmdiary/scripts/noextradepend
Normal file
|
@ -0,0 +1,16 @@
|
|||
#!/bin/sh
|
||||
|
||||
for f in `find $1 -type f -name Imakefile -print | xargs grep -l Library.tmpl`
|
||||
do
|
||||
|
||||
patch -p << END_OF_PATCH
|
||||
--- $f.orig
|
||||
+++ $f
|
||||
@@ -30,1 +30,1 @@
|
||||
-DependTarget()
|
||||
+/* DependTarget() -- Library.tmpl contains this now */
|
||||
|
||||
END_OF_PATCH
|
||||
|
||||
done
|
||||
|
16
deskutils/xmdiary/scripts/nomalloc
Normal file
16
deskutils/xmdiary/scripts/nomalloc
Normal file
|
@ -0,0 +1,16 @@
|
|||
#!/bin/sh
|
||||
|
||||
for f in `find $1 -type f -name \*.\[ch\] -print | xargs grep -l malloc.h`
|
||||
do
|
||||
|
||||
patch -p << END_OF_PATCH
|
||||
--- $f.orig
|
||||
+++ $f
|
||||
@@ -10,1 +10,1 @@
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
END_OF_PATCH
|
||||
|
||||
done
|
||||
|
Loading…
Reference in a new issue