Enable sendfile support by default for 5.2+ systems, as we now have alc's

improved sendfile and the ability to watch usage via netstat -m.
This commit is contained in:
Mike Silbersack 2004-02-01 04:51:54 +00:00
parent 219db42a9d
commit 833ddce828
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99670
2 changed files with 15 additions and 1 deletions

View file

@ -25,6 +25,8 @@ USE_REINPLACE= yes
MAN1= makeweb.1 htpasswd.1
MAN8= thttpd.8 redirect.8 ssi.8 syslogtocern.8
.include <bsd.port.pre.mk>
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/thttpd ${PREFIX}/sbin/
@${INSTALL_MAN} ${WRKSRC}/thttpd.8 ${PREFIX}/man/man8
@ -73,6 +75,9 @@ post-install:
@${CAT} ${PKGMESSAGE}
post-configure: config-message
.if ${OSVERSION} > 502101
@cd ${WRKSRC} && patch < ${PATCHDIR}/extra-patch-config.h
.endif
post-build: config-message
@ -84,4 +89,4 @@ config-message:
@${ECHO} ""
@${ECHO} "====================================================================="
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -0,0 +1,9 @@
--- config.h.old Sat Jan 31 22:17:25 2004
+++ config.h Sat Jan 31 22:17:38 2004
@@ -380,4 +380,6 @@
*/
#define MIN_WOULDBLOCK_DELAY 100L
+#define USE_SENDFILE
+
#endif /* _CONFIG_H_ */