- Update to 1.0.a4

- Use RC_ORDER

PR:		ports/87732
Submitted by:	Robin Breathe <robin@isometry.net> (maintainer)
This commit is contained in:
Pav Lucistnik 2005-10-20 20:55:00 +00:00
parent 9909d8c4e7
commit 836b3282e4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=145971
10 changed files with 50 additions and 68 deletions

View file

@ -7,7 +7,7 @@
#
PORTNAME= dovecot
DISTVERSION= 1.0.alpha3
DISTVERSION= 1.0.alpha4
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
@ -15,7 +15,6 @@ MAINTAINER= robin@isometry.net
COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
USE_RC_SUBR= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -40,6 +39,12 @@ OPTIONS= SASL2 "SASL2 support" off \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500038
USE_RC_SUBR= dovecot.sh
.else
USE_RCORDER= dovecot.sh
.endif
## SASL2 support
#
# SASL provides authentication support to
@ -85,9 +90,6 @@ CONFIGURE_ARGS+= --with-mysql
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/dovecot-example.conf >${WRKDIR}/dovecot.conf.sample
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%RC_SUBR%%,${RC_SUBR},g' \
${FILESDIR}/dovecot.sh >${WRKDIR}/dovecot.sh
pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@ -109,7 +111,6 @@ do-install:
${WRKSRC}/src/util/dovecotpw \
${PREFIX}/sbin/
${INSTALL_DATA} ${WRKDIR}/dovecot.conf.sample ${PREFIX}/etc/
${INSTALL_SCRIPT} ${WRKDIR}/dovecot.sh ${PREFIX}/etc/rc.d/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}

View file

@ -1,2 +1,2 @@
MD5 (dovecot-1.0.alpha3.tar.gz) = 2006624ce4328dcdef6a71376c3be05d
SIZE (dovecot-1.0.alpha3.tar.gz) = 1193017
MD5 (dovecot-1.0.alpha4.tar.gz) = 65f8e2cd097e80b536a75c31a974b5de
SIZE (dovecot-1.0.alpha4.tar.gz) = 1203714

View file

@ -12,13 +12,13 @@
#
#dovecot_enable="YES"
#
dovecot_enable=${dovecot_enable-"NO"}
. %%RC_SUBR%%
name=dovecot
rcvar=`set_rcvar`
: ${dovecot_enable:="NO"}
command=%%PREFIX%%/sbin/${name}
required_files=%%PREFIX%%/etc/${name}.conf

View file

@ -1,5 +1,5 @@
--- dovecot-example.conf.orig Fri Jul 22 18:40:25 2005
+++ dovecot-example.conf Fri Sep 9 00:02:06 2005
--- dovecot-example.conf.orig Thu Oct 20 15:33:33 2005
+++ dovecot-example.conf Thu Oct 20 15:38:40 2005
@@ -7,7 +7,7 @@
# Default values are shown after each value, it's not required to uncomment
# any of the lines. Exception to this are paths, they're just examples
@ -32,7 +32,7 @@
# IP address. Useful for seeing who are actually using the IMAP processes
# (eg. shared mailboxes or if same uid is used for multiple accounts).
-#verbose_proctitle = no
+verbose_proctitle = no
+verbose_proctitle = yes
# Show protocol level SSL errors.
#verbose_ssl = no
@ -60,16 +60,7 @@
# If you need to set multiple mailbox locations or want to change default
# namespace settings, you can do it by defining namespace sections:
@@ -321,7 +321,7 @@
# know any MUA which would modify mail files directly. IMAP protocol also
# requires that the mails don't change, so it would be problematic in any case.
# If you care about performance, enable it.
-#maildir_copy_with_hardlinks = no
+maildir_copy_with_hardlinks = yes
# Which locking methods to use for locking mbox. There's four available:
# dotlock: Create <mailbox>.lock file. This is the oldest and most NFS-safe
@@ -389,12 +389,12 @@
@@ -391,12 +391,12 @@
protocol imap {
# Login executable location.
@ -85,7 +76,7 @@
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
@@ -403,7 +403,7 @@
@@ -405,7 +405,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@ -94,7 +85,7 @@
# Send IMAP capabilities in greeting message. This makes it unnecessary for
# clients to request it with CAPABILITY command, so it saves one round-trip.
@@ -433,7 +433,7 @@
@@ -435,7 +435,7 @@
# With mbox storage a mailbox can contain either mails or submailboxes,
# but not both. Thunderbird separates these two by forcing server to
# accept '/' suffix in mailbox names in subscriptions list.
@ -103,7 +94,7 @@
}
##
@@ -442,10 +442,10 @@
@@ -444,10 +444,10 @@
protocol pop3 {
# Login executable location.
@ -116,16 +107,16 @@
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
@@ -475,7 +475,7 @@
# Note that Outlook 2003 seems to have problems with %v.%u format which is
# Dovecot's default, so if you're building a new server it would be a good
# idea to change this. %08Xu%08Xv should be pretty fail-safe.
- #pop3_uidl_format = %v.%u
@@ -484,7 +484,7 @@
# installations. %08Xu%08Xv will be the new default, so use it for new
# installations.
#
- #pop3_uidl_format =
+ pop3_uidl_format = %08Xu%08Xv
# POP3 logout format string:
# %t - number of TOP commands
@@ -489,7 +489,7 @@
@@ -498,7 +498,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@ -134,7 +125,7 @@
# Workarounds for various client bugs:
# outlook-no-nuls:
@@ -498,7 +498,7 @@
@@ -507,7 +507,7 @@
# oe-ns-eoh:
# Outlook Express and Netscape Mail breaks if end of headers-line is
# missing. This option simply sends it if it's missing.
@ -143,7 +134,7 @@
}
##
@@ -506,7 +506,7 @@
@@ -515,7 +515,7 @@
##
# Executable location

View file

@ -1,6 +1,5 @@
@comment $FreeBSD$
etc/dovecot.conf.sample
etc/rc.d/dovecot.sh
libexec/dovecot/checkpassword-reply
libexec/dovecot/deliver
libexec/dovecot/dovecot-auth

View file

@ -7,7 +7,7 @@
#
PORTNAME= dovecot
DISTVERSION= 1.0.alpha3
DISTVERSION= 1.0.alpha4
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
@ -15,7 +15,6 @@ MAINTAINER= robin@isometry.net
COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
USE_RC_SUBR= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -40,6 +39,12 @@ OPTIONS= SASL2 "SASL2 support" off \
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500038
USE_RC_SUBR= dovecot.sh
.else
USE_RCORDER= dovecot.sh
.endif
## SASL2 support
#
# SASL provides authentication support to
@ -85,9 +90,6 @@ CONFIGURE_ARGS+= --with-mysql
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/dovecot-example.conf >${WRKDIR}/dovecot.conf.sample
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,%%RC_SUBR%%,${RC_SUBR},g' \
${FILESDIR}/dovecot.sh >${WRKDIR}/dovecot.sh
pre-install:
@${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@ -109,7 +111,6 @@ do-install:
${WRKSRC}/src/util/dovecotpw \
${PREFIX}/sbin/
${INSTALL_DATA} ${WRKDIR}/dovecot.conf.sample ${PREFIX}/etc/
${INSTALL_SCRIPT} ${WRKDIR}/dovecot.sh ${PREFIX}/etc/rc.d/
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}

View file

@ -1,2 +1,2 @@
MD5 (dovecot-1.0.alpha3.tar.gz) = 2006624ce4328dcdef6a71376c3be05d
SIZE (dovecot-1.0.alpha3.tar.gz) = 1193017
MD5 (dovecot-1.0.alpha4.tar.gz) = 65f8e2cd097e80b536a75c31a974b5de
SIZE (dovecot-1.0.alpha4.tar.gz) = 1203714

View file

@ -12,13 +12,13 @@
#
#dovecot_enable="YES"
#
dovecot_enable=${dovecot_enable-"NO"}
. %%RC_SUBR%%
name=dovecot
rcvar=`set_rcvar`
: ${dovecot_enable:="NO"}
command=%%PREFIX%%/sbin/${name}
required_files=%%PREFIX%%/etc/${name}.conf

View file

@ -1,5 +1,5 @@
--- dovecot-example.conf.orig Fri Jul 22 18:40:25 2005
+++ dovecot-example.conf Fri Sep 9 00:02:06 2005
--- dovecot-example.conf.orig Thu Oct 20 15:33:33 2005
+++ dovecot-example.conf Thu Oct 20 15:38:40 2005
@@ -7,7 +7,7 @@
# Default values are shown after each value, it's not required to uncomment
# any of the lines. Exception to this are paths, they're just examples
@ -32,7 +32,7 @@
# IP address. Useful for seeing who are actually using the IMAP processes
# (eg. shared mailboxes or if same uid is used for multiple accounts).
-#verbose_proctitle = no
+verbose_proctitle = no
+verbose_proctitle = yes
# Show protocol level SSL errors.
#verbose_ssl = no
@ -60,16 +60,7 @@
# If you need to set multiple mailbox locations or want to change default
# namespace settings, you can do it by defining namespace sections:
@@ -321,7 +321,7 @@
# know any MUA which would modify mail files directly. IMAP protocol also
# requires that the mails don't change, so it would be problematic in any case.
# If you care about performance, enable it.
-#maildir_copy_with_hardlinks = no
+maildir_copy_with_hardlinks = yes
# Which locking methods to use for locking mbox. There's four available:
# dotlock: Create <mailbox>.lock file. This is the oldest and most NFS-safe
@@ -389,12 +389,12 @@
@@ -391,12 +391,12 @@
protocol imap {
# Login executable location.
@ -85,7 +76,7 @@
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
@@ -403,7 +403,7 @@
@@ -405,7 +405,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@ -94,7 +85,7 @@
# Send IMAP capabilities in greeting message. This makes it unnecessary for
# clients to request it with CAPABILITY command, so it saves one round-trip.
@@ -433,7 +433,7 @@
@@ -435,7 +435,7 @@
# With mbox storage a mailbox can contain either mails or submailboxes,
# but not both. Thunderbird separates these two by forcing server to
# accept '/' suffix in mailbox names in subscriptions list.
@ -103,7 +94,7 @@
}
##
@@ -442,10 +442,10 @@
@@ -444,10 +444,10 @@
protocol pop3 {
# Login executable location.
@ -116,16 +107,16 @@
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
@@ -475,7 +475,7 @@
# Note that Outlook 2003 seems to have problems with %v.%u format which is
# Dovecot's default, so if you're building a new server it would be a good
# idea to change this. %08Xu%08Xv should be pretty fail-safe.
- #pop3_uidl_format = %v.%u
@@ -484,7 +484,7 @@
# installations. %08Xu%08Xv will be the new default, so use it for new
# installations.
#
- #pop3_uidl_format =
+ pop3_uidl_format = %08Xu%08Xv
# POP3 logout format string:
# %t - number of TOP commands
@@ -489,7 +489,7 @@
@@ -498,7 +498,7 @@
# Support for dynamically loadable modules.
#mail_use_modules = no
@ -134,7 +125,7 @@
# Workarounds for various client bugs:
# outlook-no-nuls:
@@ -498,7 +498,7 @@
@@ -507,7 +507,7 @@
# oe-ns-eoh:
# Outlook Express and Netscape Mail breaks if end of headers-line is
# missing. This option simply sends it if it's missing.
@ -143,7 +134,7 @@
}
##
@@ -506,7 +506,7 @@
@@ -515,7 +515,7 @@
##
# Executable location

View file

@ -1,6 +1,5 @@
@comment $FreeBSD$
etc/dovecot.conf.sample
etc/rc.d/dovecot.sh
libexec/dovecot/checkpassword-reply
libexec/dovecot/deliver
libexec/dovecot/dovecot-auth