- Update to 5.4.1
PR: ports/177030 Submitted by: Chris Petrik <c.petrik.sosa@gmail.com> (maintainer)
This commit is contained in:
parent
53520853ce
commit
838d6fe4b4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=317069
5 changed files with 1012 additions and 103 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= twiki
|
||||
PORTVERSION= 4.2.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 5.1.4
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://twiki.org/p/pub/Codev/Release/
|
||||
|
@ -28,9 +27,9 @@ RUN_DEPENDS= \
|
|||
twiki-TWikiUserMappingContrib>=0:${PORTSDIR}/www/twiki-TWikiUserMappingContrib
|
||||
|
||||
USE_PERL5= yes
|
||||
WRKSRC= ${WRKDIR}/twiki
|
||||
|
||||
post-extract:
|
||||
@cd ${WRKDIR}/ && ${INSTALL} -d .t/ && ${MV} * .t/ && ${MV} .t ${WRKSRC}
|
||||
@${RM} -rf ${WRKSRC}/lib/CPAN
|
||||
@${CAT} ${.CURDIR}/../twiki-*/pkg-plist |\
|
||||
${SED} -e 's|%%TWDIR%%|${WRKSRC}|;/^@/d' |\
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (twiki/TWiki-4.2.4.tgz) = 7b4ad6133f8c9a1fee5734ba364746bc955f894503445de03e66ca2e319e0d63
|
||||
SIZE (twiki/TWiki-4.2.4.tgz) = 5549317
|
||||
SHA256 (twiki/TWiki-5.1.4.tgz) = bcd8544c83eb388737e334cdc2c2734e79df63fd0a64610c144addb00bc0d70d
|
||||
SIZE (twiki/TWiki-5.1.4.tgz) = 7890688
|
||||
|
|
|
@ -1,14 +1,13 @@
|
|||
# From: http://dot-and-thing.blogspot.com/2008/03/twiki-utf8.html
|
||||
diff -urE --exclude=data --exclude=pub twiki-4.2/lib/TWiki.pm twiki/lib/TWiki.pm
|
||||
--- lib/TWiki.pm 2008-01-22 06:18:55.000000000 +0300
|
||||
+++ lib/TWiki.pm 2008-03-11 18:28:34.000000000 +0300
|
||||
@@ -2405,7 +2405,8 @@
|
||||
--- lib/TWiki.pm.bak 2013-03-25 12:03:24.000000000 +0000
|
||||
+++ lib/TWiki.pm 2013-03-25 12:04:08.000000000 +0000
|
||||
@@ -2722,8 +2722,8 @@
|
||||
sub urlDecode {
|
||||
my $text = shift;
|
||||
|
||||
- $text =~ s/%([\da-f]{2})/chr(hex($1))/gei;
|
||||
-
|
||||
+ $text =~ s/%u([\da-f]+)/chr(hex($1))/eig;
|
||||
+ $text =~ s/%([\da-f]{2})/chr(hex($1))/gei;
|
||||
|
||||
+ $text =~ s/%([\da-f]{2})/chr(hex($1))/gei;
|
||||
return $text;
|
||||
}
|
||||
|
||||
|
|
|
@ -26,8 +26,8 @@ case $2 in
|
|||
chown -R ${WWWOWN}:${WWWGRP} ${WWWDIR}/
|
||||
chmod -R u+w ${WWWDIR}/
|
||||
cd ${WWWDIR}/
|
||||
chmod o-rwx data lib locale templates test tools working
|
||||
chmod a+x bin/* tools/*
|
||||
chmod o-rwx data lib test tools
|
||||
chmod a+x tools/*
|
||||
|
||||
# let the user know what's going on
|
||||
cat << __EOF__
|
||||
|
|
1089
www/twiki/pkg-plist
1089
www/twiki/pkg-plist
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue