- update to 1.0.1
- add OPTIONS for unit test support - patch setup.py to install the egg uncompressed - use a pkg-plist instead of PLIST_FILES - restore creator to Makefile header and use new convention - fix plist for python >= 3.2 PR: 172592 Submitted by: Kubilay Kocak <koobs.freebsd@gmail.com> Approved by: maintainer timeout (1 month+) Feature safe: yes
This commit is contained in:
parent
3caa05e50c
commit
83cc3b9f8d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=308094
3 changed files with 29 additions and 7 deletions
|
@ -1,8 +1,8 @@
|
|||
# Created by: jessekempf@gmail.com
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mock
|
||||
PORTVERSION= 0.8.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,10 +12,22 @@ COMMENT= Mock unit tests for Python
|
|||
|
||||
LICENSE= BSD
|
||||
|
||||
PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
|
||||
OPTIONS_DEFINE= TESTS
|
||||
TESTS_DESC= Install tox for running unit tests
|
||||
OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
|
||||
|
||||
# Python3 ready
|
||||
USE_PYTHON= yes
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= easy_install
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MTESTS}
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tox>0:${PORTSDIR}/devel/py-tox
|
||||
.endif
|
||||
|
||||
.if ${PYTHON_REL} >= 320
|
||||
.include "${PORTSDIR}/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (mock-0.8.0.tar.gz) = 96fa4def4e80200be827c3f51147dd7b3fa8873b9207e3325d47ba45bf29a5c1
|
||||
SIZE (mock-0.8.0.tar.gz) = 749663
|
||||
SHA256 (mock-1.0.1.tar.gz) = b839dd2d9c117c701430c149956918a423a9863b48b09c90e30a6013e7d2f44f
|
||||
SIZE (mock-1.0.1.tar.gz) = 818644
|
||||
|
|
10
devel/py-mock/files/patch-setup.py
Normal file
10
devel/py-mock/files/patch-setup.py
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ./setup.py.orig 2012-10-09 20:11:41.000000000 +1100
|
||||
+++ ./setup.py 2012-10-09 20:11:26.000000000 +1100
|
||||
@@ -59,6 +59,7 @@
|
||||
keywords=KEYWORDS,
|
||||
url=URL,
|
||||
classifiers=CLASSIFIERS,
|
||||
+ zip_safe=False,
|
||||
)
|
||||
|
||||
try:
|
Loading…
Reference in a new issue