Update to 0.28
Port changes: - build with qmake instean of cmake - update WWW - mark MAKE_JOBS_SAFE PR: based on ports/149145 Submitted by: Oleg Ginzburg <olevole at olevole.ru>
This commit is contained in:
parent
524e6bb50f
commit
83d1d6ed09
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258583
4 changed files with 43 additions and 16 deletions
|
@ -6,10 +6,10 @@
|
|||
#
|
||||
|
||||
PORTNAME= qdevelop
|
||||
PORTVERSION= 0.27.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.28
|
||||
CATEGORIES= devel kde
|
||||
MASTER_SITES= http://qdevelop.org/public/release/
|
||||
MASTER_SITES= http://biord-software.org/downloads/
|
||||
DISTNAME= ${PORTNAME}-v${PORTVERSION}
|
||||
|
||||
MAINTAINER= makc@FreeBSD.org
|
||||
COMMENT= A development environment entirely dedicated to Qt4
|
||||
|
@ -20,8 +20,13 @@ RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
|
|||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= gui sql network xml designer \
|
||||
qmake_build moc_build uic_build rcc_build
|
||||
USE_CMAKE= yes
|
||||
CMAKE_USE_PTHREAD= yes
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
QMAKE_ARGS= -unix -recursive ${QMAKE_PRO}
|
||||
QMAKE_PRO= QDevelop.pro
|
||||
STRIP_FILES= bin/${PORTNAME}
|
||||
|
||||
QT_LRELEASE= ${LOCALBASE}/bin/lrelease-qt4
|
||||
|
||||
DESKTOP_ENTRIES= "QDevelop" \
|
||||
"Qt4 development environment" \
|
||||
|
@ -34,6 +39,7 @@ OPTIONS= TOOLS "Install Qt4 dev. tools (qmake, moc, etc.)" on
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if !defined(WITHOUT_NLS)
|
||||
QT_COMPONENTS+= linguist_build
|
||||
PLIST_SUB+= NLS=""
|
||||
.else
|
||||
PLIST_SUB+= NLS="@comment "
|
||||
|
@ -54,18 +60,30 @@ post-patch:
|
|||
-e "s|\"/usr/bin/make\"|\"${LOCALBASE}/bin/gmake\"|g" \
|
||||
-e "s|\"/usr/bin/ctags\"|\"${LOCALBASE}/bin/exctags\"|g" \
|
||||
${WRKSRC}/src/toolscontrolimpl.cpp
|
||||
${REINPLACE_CMD} -e "/target.path/s|/usr/bin/|${PREFIX}/bin|g" \
|
||||
${WRKSRC}/${QMAKE_PRO}
|
||||
${REINPLACE_CMD} -e "s,lib/qdevelop/translations,${DATADIR_REL}/translations,g" \
|
||||
${WRKSRC}/src/main.cpp \
|
||||
${WRKSRC}/plugins/tools-regexp-planner/replugin.cpp \
|
||||
${WRKSRC}/plugins/formatting-astyle/astyleplugin.cpp
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/qdevelop ${PREFIX}/bin/
|
||||
@${INSTALL_DATA} ${WRKSRC}/resources/images/logo.png ${PREFIX}/share/pixmaps/qdevelop.png
|
||||
do-configure:
|
||||
.if !defined(WITHOUT_NLS)
|
||||
@${MKDIR} ${DATADIR}
|
||||
(cd ${WRKSRC}/resources/translations/ && ${COPYTREE_SHARE} '*.qm' ${DATADIR}/translations)
|
||||
cd ${WRKSRC} && ${QT_LRELEASE} ${QMAKE_PRO}
|
||||
.endif
|
||||
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
|
||||
${INSTALL_DATA} ${WRKSRC}/resources/images/logo.png ${PREFIX}/share/pixmaps/qdevelop.png
|
||||
.if !defined(WITHOUT_NLS)
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC}/resources/translations/ && ${COPYTREE_SHARE} '*.qm' ${DATADIR}/translations
|
||||
.endif
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${MKDIR} ${DOCSDIR}
|
||||
.for doc in ChangeLog.txt README.txt
|
||||
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (qdevelop-0.27.4.tar.gz) = 0ea8b3b2ed15bfa275d5c03f40cb871b
|
||||
SHA256 (qdevelop-0.27.4.tar.gz) = e2b17413ff62043e680b73b644e0d974d5894521e0d3265e3760877ab08ff4e6
|
||||
SIZE (qdevelop-0.27.4.tar.gz) = 1052957
|
||||
MD5 (qdevelop-v0.28.tar.gz) = 24e64bd80dd7407a885acd639b59a740
|
||||
SHA256 (qdevelop-v0.28.tar.gz) = d9772358078f62edb6591d3d7ca7515c52f256eb6becf82cc5fcde4228ac7d9e
|
||||
SIZE (qdevelop-v0.28.tar.gz) = 1660363
|
||||
|
|
9
devel/qdevelop/files/patch-QDevelop.pro
Normal file
9
devel/qdevelop/files/patch-QDevelop.pro
Normal file
|
@ -0,0 +1,9 @@
|
|||
--- ./QDevelop.pro.orig 2010-04-17 11:24:40.000000000 +0400
|
||||
+++ ./QDevelop.pro 2010-08-01 18:22:09.489810565 +0400
|
||||
@@ -146,6 +146,3 @@
|
||||
OBJECTS_DIR += build/o/win32
|
||||
CONFIG -= debug_and_release
|
||||
}
|
||||
-!exists(resources/translations/QDevelop_Russian.qm) {
|
||||
- error(Please run \"lrelease QDevelop.pro\" before building the project)
|
||||
-}
|
|
@ -4,4 +4,4 @@ to Qt and is totally independent of KDevelop. Less complete, but faster,
|
|||
light and especially multi-platforms. QDevelop and KDevelop have different
|
||||
code sources.
|
||||
|
||||
WWW: http://qdevelop.org/
|
||||
WWW: http://biord-software.org/qdevelop/
|
||||
|
|
Loading…
Reference in a new issue