Fix build with gcc47

maintainer timeout

PR:		ports/184574
Submitted by:	Christoph Moench-Tegeder
This commit is contained in:
Mathieu Arnold 2014-01-07 22:55:35 +00:00
parent 5350471612
commit 842abb4a59
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=339045
2 changed files with 13 additions and 8 deletions

View file

@ -26,7 +26,6 @@ USE_FORTRAN= yes
NO_STAGE= yes
post-patch:
@cd ${WRKSRC} ; ${PATCH} --quiet < testw.patch
@${REINPLACE_CMD} -e 's|%%F77%%|${F77}|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ratfor77 ${PREFIX}/bin

View file

@ -1,16 +1,22 @@
--- Makefile~ Sat Jan 13 18:13:44 2007
+++ Makefile Sat Jan 13 18:14:35 2007
@@ -28,11 +28,11 @@
--- Makefile.orig 2013-11-16 17:28:28.000000000 +0100
+++ Makefile 2013-11-16 17:27:51.000000000 +0100
@@ -26,13 +26,15 @@
clean:
rm -f *.o *~ ratfor ratfor77 a.out test testw test.f testw.f
test: ratfor
-test: ratfor
+test: test.f
+
+test.f: ratfor
./ratfor -o test.f test.r
- f77 -o test test.f
+ %%F77%% -o test test.f
testw: ratfor
-testw: ratfor
+testw: testw.f
+
+testw.f: ratfor
./ratfor -o testw.f testw.r
- f77 -o testw testw.f
+ %%F77%% -o testw testw.f
tests: test testw
./test