Fix under 10-STABLE and 11-CURRENT.
This commit is contained in:
parent
45dcb54cba
commit
842c5cdcb5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=332109
4 changed files with 40 additions and 1 deletions
|
@ -54,11 +54,16 @@ DISTFILES+= X430src-1.tgz:x \
|
|||
X430src-2.tgz:x \
|
||||
X430src-3.tgz:x
|
||||
|
||||
.if ${OSVERSION} > 1000000
|
||||
USE_GCC= 4.6+
|
||||
MAKE_ENV= IMAKECPP="${CPP}"
|
||||
MAKE_ARGS= AR='ar rc'
|
||||
.endif
|
||||
|
||||
RUN_DEPENDS+= xauth:${PORTSDIR}/x11/xauth \
|
||||
${PREFIX}/lib/X11/fonts/misc/6x13-ISO8859-1.pcf.gz:${PORTSDIR}/x11-fonts/xorg-fonts-miscbitmaps \
|
||||
${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias
|
||||
|
||||
|
||||
EXTRA_PATCHES+= ${WRKSRC}/xc.patch \
|
||||
${PATCHDIR}/vnc.def-patch \
|
||||
${PATCHDIR}/FreeBSD.cf-patch \
|
||||
|
@ -92,9 +97,13 @@ post-patch:
|
|||
post-build:
|
||||
.if ! ${PORT_OPTIONS:MSERVER}
|
||||
@${ECHO_MSG} "Skipping build of VNC server."
|
||||
.else
|
||||
.if ${OSVERSION} > 1000000
|
||||
cd ${WRKSRC}/xc && ${MAKE_ENV} make CC=${CC} CXX=${CXX} ${MAKE_ARGS} World
|
||||
.else
|
||||
cd ${WRKSRC}/xc && make CC=${CC} CXX=${CXX} World
|
||||
.endif
|
||||
.endif
|
||||
|
||||
pre-install:
|
||||
@${CP} ${PKGDIR}/pkg-plist ${PLIST}
|
||||
|
|
10
net/vnc/files/patch-common-network-TcpSocket.cxx
Normal file
10
net/vnc/files/patch-common-network-TcpSocket.cxx
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- ../common/network/TcpSocket.cxx.orig 2008-10-16 08:16:20.000000000 -0700
|
||||
+++ ../common/network/TcpSocket.cxx 2013-10-29 09:29:55.935208477 -0700
|
||||
@@ -35,6 +35,7 @@
|
||||
#include <string.h>
|
||||
#include <signal.h>
|
||||
#include <fcntl.h>
|
||||
+#include <stdlib.h>
|
||||
#endif
|
||||
|
||||
#include <network/TcpSocket.h>
|
10
net/vnc/files/patch-unix-tx-TXImage.cxx
Normal file
10
net/vnc/files/patch-unix-tx-TXImage.cxx
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- tx/TXImage.cxx.orig 2008-10-16 08:16:21.000000000 -0700
|
||||
+++ tx/TXImage.cxx 2013-10-29 09:32:04.015562191 -0700
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <strings.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ipc.h>
|
10
net/vnc/files/patch-unix-x0vncserver-Image.cxx
Normal file
10
net/vnc/files/patch-unix-x0vncserver-Image.cxx
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- x0vncserver/Image.cxx.orig 2008-10-16 08:16:21.000000000 -0700
|
||||
+++ x0vncserver/Image.cxx 2013-10-29 09:34:58.346041892 -0700
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/ipc.h>
|
||||
#include <sys/shm.h>
|
Loading…
Reference in a new issue