graphics/openjph: Update to 0.10.5

- Update LICENSE_FILE
- Use USES=pathfix to fix .pc installation

Changes:	https://github.com/aous72/OpenJPH/releases
This commit is contained in:
Po-Chuan Hsieh 2024-02-21 22:26:20 +08:00
parent 9647e85c18
commit 845e86d26f
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
4 changed files with 10 additions and 47 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= openjph
PORTVERSION= 0.9.0
PORTVERSION= 0.10.5
CATEGORIES= graphics
MAINTAINER= sunpoet@FreeBSD.org
@ -7,9 +7,9 @@ COMMENT= Open-source implementation of JPEG2000 Part-15
WWW= https://github.com/aous72/OpenJPH
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake compiler:c++11-lang # pathfix
USES= cmake compiler:c++11-lang pathfix
CMAKE_ON= BUILD_SHARED_LIBS
USE_LDCONFIG= yes
@ -26,4 +26,7 @@ USE_GITHUB= yes
CMAKE_ON+= OJPH_DISABLE_INTEL_SIMD
.endif
post-install:
${LN} -s libopenjph.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libopenjph.so.0
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1653925886
SHA256 (aous72-OpenJPH-0.9.0_GH0.tar.gz) = 6970b14e73babb7a2e466be115e45fc55e9e02104248938257dd5bac5c67d41a
SIZE (aous72-OpenJPH-0.9.0_GH0.tar.gz) = 375685
TIMESTAMP = 1708448928
SHA256 (aous72-OpenJPH-0.10.5_GH0.tar.gz) = fc1e43fb1e8a097f883f5fe98794327eb96c4bdf2c53cb633537b061af4c99f3
SIZE (aous72-OpenJPH-0.10.5_GH0.tar.gz) = 358992

View File

@ -1,41 +0,0 @@
--- CMakeLists.txt.orig 2022-05-25 12:38:19 UTC
+++ CMakeLists.txt
@@ -59,9 +59,6 @@ if (OJPH_CODE_COVERAGE AND NOT MSVC)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --coverage")
endif()
-set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/../bin)
-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/../bin)
-
include_directories(src/core/common)
include_directories(src/apps/common)
@@ -96,7 +93,7 @@ source_group("transform" FILES ${TRANSFORM})
configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/src/pkg-config.pc.cmake"
- "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/${PROJECT_NAME}.pc"
+ "${CMAKE_BINARY_DIR}/${PROJECT_NAME}.pc"
)
if(EMSCRIPTEN)
@@ -133,7 +130,7 @@ if (OPENJPH_VERSION)
else()
set_target_properties(openjph
PROPERTIES
- SOVERSION "${OPENJPH_VERSION_MAJOR}.${OPENJPH_VERSION_MINOR}"
+ SOVERSION "${OPENJPH_VERSION_MAJOR}"
VERSION "${OPENJPH_VERSION}")
endif()
else()
@@ -243,8 +240,8 @@ install (DIRECTORY src/core/common/
FILES_MATCHING
PATTERN "*.h")
-install(FILES "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/${PROJECT_NAME}.pc"
- DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+install(FILES "${CMAKE_BINARY_DIR}/${PROJECT_NAME}.pc"
+ DESTINATION libdata/pkgconfig)
################################################################################################
# Testing (OJPH_BUILD_TEST)

View File

@ -12,5 +12,6 @@ include/openjph/ojph_params.h
include/openjph/ojph_version.h
lib/libopenjph.so
lib/libopenjph.so.0
lib/libopenjph.so.0.10
lib/libopenjph.so.%%PORTVERSION%%
libdata/pkgconfig/openjph.pc