. Use ${PTHREAD_LIBS} rather than -pthread.
Suggested by: mi
This commit is contained in:
parent
38e03fb03a
commit
846f8c04ea
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90578
2 changed files with 30 additions and 1 deletions
|
@ -85,6 +85,7 @@ PLIST_SUB+= DEBUG:=""
|
|||
.if defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT)
|
||||
PLIST_SUB+= NATIVE:=""
|
||||
MAKE_ARGS+= HPIS="green native"
|
||||
USE_REINPLACE= yes
|
||||
.else
|
||||
PLIST_SUB+= NATIVE:="@comment "
|
||||
.endif
|
||||
|
@ -97,7 +98,6 @@ PLIST_SUB+= PLUGIN:=""
|
|||
|
||||
.if defined(WITH_HOTSPOT)
|
||||
PLIST_SUB+= HOTSPOT:=""
|
||||
USE_REINPLACE= yes
|
||||
.if defined(NODEBUG)
|
||||
HOTSPOT_TARGETS=product1 product
|
||||
.else
|
||||
|
@ -121,6 +121,17 @@ BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/diablo-jdk13
|
|||
.endif
|
||||
.endif
|
||||
|
||||
.if defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT)
|
||||
PTHREAD_FILES= common/Defs.gmk \
|
||||
common/Program.gmk \
|
||||
java/hpi/native/Makefile \
|
||||
sun/cmm/Makefile \
|
||||
../ext/plugin/build/solaris/GNUmakefile \
|
||||
../../hotspot1.3.1/build/linux/platform_i486 \
|
||||
../../hotspot1.3.1/build/bsd/makefiles/gcc.make \
|
||||
../../hotspot1.3.1/build/linux/makefiles/vm.make
|
||||
.endif
|
||||
|
||||
.if defined(WITH_HOTSPOT) && ${OSVERSION} < 500039
|
||||
USE_GCC= 3.2
|
||||
BUILD_DEPENDS+= gcc32:${PORTSDIR}/lang/gcc32
|
||||
|
@ -195,6 +206,11 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e "s:PATH[)]gcc:PATH)gcc32:g ; s:PATH[)]g\+\+:PATH)g\+\+32:g" ${WRKSRC}/common/Defs-bsd.gmk
|
||||
.endif
|
||||
.endif
|
||||
.if defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT)
|
||||
@for file in ${PTHREAD_FILES}; do \
|
||||
${REINPLACE_CMD} -e "s:-pthread:${PTHREAD_LIBS}:g" ${WRKSRC}/$${file}; \
|
||||
done
|
||||
.endif
|
||||
|
||||
pre-build:
|
||||
.if defined(WITH_LINUX_BOOTSTRAP)
|
||||
|
|
13
java/jdk13/files/patch-vm.make
Normal file
13
java/jdk13/files/patch-vm.make
Normal file
|
@ -0,0 +1,13 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- ../../hotspot1.3.1/build/linux/makefiles/vm.make.orig Tue Oct 7 16:47:45 2003
|
||||
+++ ../../hotspot1.3.1/build/linux/makefiles/vm.make Tue Oct 7 16:47:57 2003
|
||||
@@ -115,7 +115,7 @@
|
||||
|
||||
#--billh
|
||||
#LIBS += -lnsl -lm -ldl -lpthread
|
||||
-LIBS = -lm -lc_r
|
||||
+LIBS = -lm -pthread
|
||||
|
||||
JVM = jvm$(G_SUFFIX)
|
||||
LIBJVM = lib$(JVM).so
|
Loading…
Reference in a new issue