Enable SAE/escript function, which allows creation of standalone Erlang

scripts.
This commit is contained in:
Jimmy Olgeni 2004-06-27 09:38:01 +00:00
parent 0ce877c848
commit 849d2ece7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112354
10 changed files with 94 additions and 8 deletions

View file

@ -7,6 +7,7 @@
PORTNAME= erlang
PORTVERSION= r9c2
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.erlang.org/pub/download/ \
@ -36,6 +37,7 @@ ERLANG_DOCS= otp_html_R9C-2.tar.gz
USE_GMAKE= yes
USE_PERL5= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386
@ -102,6 +104,14 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
@for SCRIPT in ecc elink ear escript; do \
${REINPLACE_CMD} -e "s@ERLANG_EARS=.*@ERLANG_EARS=${LOCALBASE}/lib/erlang/erts-${ERTS_VSN}@" ${LOCALBASE}/bin/$${SCRIPT}; \
done
@for SCRIPT in ecc elink; do \
${REINPLACE_CMD} -e "s@exec .*beam_evm@exec beam_evm@" ${LOCALBASE}/bin/$${SCRIPT}; \
done
@${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang

View file

@ -1,5 +1,6 @@
# $FreeBSD$
ERTS_VSN= 5.3.6.3
OTP_LIBS= appmon-2.1.2 \
asn1-1.4.4.2 \
compiler-4.2.3 \

View file

@ -1,21 +1,32 @@
$FreeBSD$
--- Makefile.in.orig Sat Jan 24 21:18:56 2004
+++ Makefile.in Sat Jan 24 21:19:22 2004
@@ -505,14 +505,9 @@
--- Makefile.in.orig Fri Dec 19 13:55:58 2003
+++ Makefile.in Sat Jun 26 20:25:23 2004
@@ -534,14 +534,20 @@
# Erlang base public files
#
install.bin:
- rm -f $(BINDIR)/erl $(BINDIR)/erlc \
- $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/ear $(BINDIR)/escript
+ rm -f $(BINDIR)/erl $(BINDIR)/erlc
+ rm -f $(BINDIR)/erl $(BINDIR)/erlc $(BINDIR)/run_erl \
+ $(BINDIR)/to_erl $(BINDIR)/beam_evm $(BINDIR)/ear \
+ $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/erlexec \
+ $(BINDIR)/escript
${LN_S} $(ERLANG_BINDIR)/erl $(BINDIR)/erl
${LN_S} $(ERLANG_BINDIR)/erlc $(BINDIR)/erlc
- ${LN_S} $(ERLANG_BINDIR)/ecc $(BINDIR)/ecc
- ${LN_S} $(ERLANG_BINDIR)/elink $(BINDIR)/elink
- ${LN_S} $(ERLANG_BINDIR)/ear $(BINDIR)/ear
- ${LN_S} $(ERLANG_BINDIR)/escript $(BINDIR)/escript
+ ${LN_S} $(ERLANG_BINDIR)/run_erl $(BINDIR)/run_erl
+ ${LN_S} $(ERLANG_BINDIR)/to_erl $(BINDIR)/to_erl
+ ${LN_S} $(ERLANG_ERTSBINDIR)/beam_evm $(BINDIR)/beam_evm
+ ${LN_S} $(ERLANG_ERTSBINDIR)/ear $(BINDIR)/ear
+ ${LN_S} $(ERLANG_ERTSBINDIR)/ecc $(BINDIR)/ecc
+ ${LN_S} $(ERLANG_ERTSBINDIR)/elink $(BINDIR)/elink
+ ${LN_S} $(ERLANG_ERTSBINDIR)/erlexec $(BINDIR)/erlexec
+ ${LN_S} $(ERLANG_ERTSBINDIR)/escript $(BINDIR)/escript
#
# Directories needed before we can install

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- erts/emulator/Makefile.in.orig Sat Jun 26 13:57:01 2004
+++ erts/emulator/Makefile.in Sat Jun 26 13:57:39 2004
@@ -220,6 +220,7 @@
$(INSTALL_DATA) $(RELEASE_INCLUDES) $(RELSYSDIR)/src
$(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE) $(RELSYSDIR)/bin
ifeq ($(ERLANG_OSTYPE), unix)
+ $(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_SAE) $(RELSYSDIR)/bin
$(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_ELIB) $(RELSYSDIR)/bin
$(INSTALL_PROGRAM) $(BINDIR)/$(CS_EXECUTABLE) $(RELSYSDIR)/bin
endif

View file

@ -1,6 +1,14 @@
bin/beam_evm
bin/ear
bin/ecc
bin/elink
bin/erl
bin/erl_call
bin/erlc
bin/erlexec
bin/escript
bin/run_erl
bin/to_erl
@comment Insert PLIST.lib-erlang here
@comment -=[ begin PLIST.lib-erlang ]=-
@comment -=[ end PLIST.lib-erlang ]=-

View file

@ -7,6 +7,7 @@
PORTNAME= erlang
PORTVERSION= r9c2
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.erlang.org/pub/download/ \
@ -36,6 +37,7 @@ ERLANG_DOCS= otp_html_R9C-2.tar.gz
USE_GMAKE= yes
USE_PERL5= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386
@ -102,6 +104,14 @@ pre-configure:
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
post-install:
@for SCRIPT in ecc elink ear escript; do \
${REINPLACE_CMD} -e "s@ERLANG_EARS=.*@ERLANG_EARS=${LOCALBASE}/lib/erlang/erts-${ERTS_VSN}@" ${LOCALBASE}/bin/$${SCRIPT}; \
done
@for SCRIPT in ecc elink; do \
${REINPLACE_CMD} -e "s@exec .*beam_evm@exec beam_evm@" ${LOCALBASE}/bin/$${SCRIPT}; \
done
@${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
-C ${PREFIX}/lib/erlang

View file

@ -1,5 +1,6 @@
# $FreeBSD$
ERTS_VSN= 5.3.6.3
OTP_LIBS= appmon-2.1.2 \
asn1-1.4.4.2 \
compiler-4.2.3 \

View file

@ -1,21 +1,32 @@
$FreeBSD$
--- Makefile.in.orig Sat Jan 24 21:18:56 2004
+++ Makefile.in Sat Jan 24 21:19:22 2004
@@ -505,14 +505,9 @@
--- Makefile.in.orig Fri Dec 19 13:55:58 2003
+++ Makefile.in Sat Jun 26 20:25:23 2004
@@ -534,14 +534,20 @@
# Erlang base public files
#
install.bin:
- rm -f $(BINDIR)/erl $(BINDIR)/erlc \
- $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/ear $(BINDIR)/escript
+ rm -f $(BINDIR)/erl $(BINDIR)/erlc
+ rm -f $(BINDIR)/erl $(BINDIR)/erlc $(BINDIR)/run_erl \
+ $(BINDIR)/to_erl $(BINDIR)/beam_evm $(BINDIR)/ear \
+ $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/erlexec \
+ $(BINDIR)/escript
${LN_S} $(ERLANG_BINDIR)/erl $(BINDIR)/erl
${LN_S} $(ERLANG_BINDIR)/erlc $(BINDIR)/erlc
- ${LN_S} $(ERLANG_BINDIR)/ecc $(BINDIR)/ecc
- ${LN_S} $(ERLANG_BINDIR)/elink $(BINDIR)/elink
- ${LN_S} $(ERLANG_BINDIR)/ear $(BINDIR)/ear
- ${LN_S} $(ERLANG_BINDIR)/escript $(BINDIR)/escript
+ ${LN_S} $(ERLANG_BINDIR)/run_erl $(BINDIR)/run_erl
+ ${LN_S} $(ERLANG_BINDIR)/to_erl $(BINDIR)/to_erl
+ ${LN_S} $(ERLANG_ERTSBINDIR)/beam_evm $(BINDIR)/beam_evm
+ ${LN_S} $(ERLANG_ERTSBINDIR)/ear $(BINDIR)/ear
+ ${LN_S} $(ERLANG_ERTSBINDIR)/ecc $(BINDIR)/ecc
+ ${LN_S} $(ERLANG_ERTSBINDIR)/elink $(BINDIR)/elink
+ ${LN_S} $(ERLANG_ERTSBINDIR)/erlexec $(BINDIR)/erlexec
+ ${LN_S} $(ERLANG_ERTSBINDIR)/escript $(BINDIR)/escript
#
# Directories needed before we can install

View file

@ -0,0 +1,13 @@
$FreeBSD$
--- erts/emulator/Makefile.in.orig Sat Jun 26 13:57:01 2004
+++ erts/emulator/Makefile.in Sat Jun 26 13:57:39 2004
@@ -220,6 +220,7 @@
$(INSTALL_DATA) $(RELEASE_INCLUDES) $(RELSYSDIR)/src
$(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE) $(RELSYSDIR)/bin
ifeq ($(ERLANG_OSTYPE), unix)
+ $(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_SAE) $(RELSYSDIR)/bin
$(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_ELIB) $(RELSYSDIR)/bin
$(INSTALL_PROGRAM) $(BINDIR)/$(CS_EXECUTABLE) $(RELSYSDIR)/bin
endif

View file

@ -1,6 +1,14 @@
bin/beam_evm
bin/ear
bin/ecc
bin/elink
bin/erl
bin/erl_call
bin/erlc
bin/erlexec
bin/escript
bin/run_erl
bin/to_erl
@comment Insert PLIST.lib-erlang here
@comment -=[ begin PLIST.lib-erlang ]=-
@comment -=[ end PLIST.lib-erlang ]=-