eXosip2 (3.0.1)

* add Windows CE support with Visual Studio 2005
          (WM5.0,PocketPC 2003/2005, Smartphone)
        * Update to osip2-3.0.1
        * Add SRV record capabilities.
        * add new OPTIONS: do not send 101, remove pre-route set from message.

It is now depending on net/libosip instead of net/libosip2

PR:		105166
Submitted by:	Yi-Huan Chan <yhchan@csie.nctu.edu.tw>
Approved by:	maintainer, tmclaugh (implicit)
This commit is contained in:
Soeren Straarup 2006-12-10 19:36:50 +00:00
parent 7693cfc733
commit 84b5e611d2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179407
5 changed files with 12 additions and 42 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= libeXosip2
PORTVERSION= 2.2.3
PORTVERSION= 3.0.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= exosip
@ -14,24 +14,12 @@ MASTER_SITE_SUBDIR= exosip
MAINTAINER= bd_subzero@yahoo.com
COMMENT= GPL library that extends the capability of the oSIP library
LIB_DEPENDS= osip2:${PORTSDIR}/net/libosip2
LIB_DEPENDS= osip2:${PORTSDIR}/net/libosip
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-tools
INSTALLS_SHLIB= yes
CONFIGURE_ARGS+= --disable-tools --disable-debug --disable-trace
USE_LDCONFIG= yes
OPTIONS= UCL "Use uclmmbase IP multicast library " off
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if defined(WITH_UCL)
LIB_DEPENDS+= uclmmbase:${PORTSDIR}/devel/uclmmbase
CONFIGURE_ARGS+= --enable-ucl
CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include
PLIST_SUB+= JOSUA=""
.else
CONFIGURE_ARGS+= --disable-josua
PLIST_SUB+= JOSUA="@comment "
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
MD5 (libeXosip2-2.2.3.tar.gz) = 837a35f085890eac3328ac402b24383b
SHA256 (libeXosip2-2.2.3.tar.gz) = a09e97847f3983431c5453bf2f3de1629e629c1b4ea9ddc5e3aa6caaf7417b05
SIZE (libeXosip2-2.2.3.tar.gz) = 499517
MD5 (libeXosip2-3.0.1.tar.gz) = bd52d81c83306c5ba260939537d69577
SHA256 (libeXosip2-3.0.1.tar.gz) = 04e2256773c16c57174a4a2492514a4002a5753507e3d319c2469d0ae80d348d
SIZE (libeXosip2-3.0.1.tar.gz) = 450738

View file

@ -1,11 +0,0 @@
--- josua/Makefile.in Mon Jun 12 14:51:52 2006
+++ josua/Makefile.in Mon Jun 12 14:53:10 2006
@@ -267,7 +267,7 @@
@MEDIASTREAMER_SUPPORT_TRUE@@ORTP_SUPPORT_FALSE@@UCL_SUPPORT_FALSE@MORE_INCLUDES = -I$(includedir)/mediastreamer -I$(includedir)/ortp
@ORTP_SUPPORT_TRUE@@UCL_SUPPORT_FALSE@MORE_INCLUDES = -I$(includedir)/ortp
@UCL_SUPPORT_TRUE@MORE_INCLUDES = -I/ucl
-josua_LDADD = $(top_builddir)/src/libeXosip2.la libjosua.la $(libdir)/libosip2.la $(libdir)/libosipparser2.la -lrt $(MORE_MYADD)
+josua_LDADD = $(top_builddir)/src/libeXosip2.la libjosua.la $(libdir)/libosip2.la $(libdir)/libosipparser2.la $(MORE_MYADD)
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/include -I$(includedir) $(MORE_INCLUDES)
libjosua_la_LIBADD = $(top_builddir)/src/libeXosip2.la $(libdir)/libosip2.la $(libdir)/libosipparser2.la $(MORE_MYADD)
all: all-am

View file

@ -1,6 +1,6 @@
eXosip is a GPL library that extend the capability of the oSIP library.
It aims to implement a simple high layer API to control the SIP for sessions
establishements and common extensions. Once completed, this eXtended library
establishments and common extensions. Once completed, this eXtended library
should provide an API for call management, messaging and presence features.
eXosip2 has support for:
@ -8,7 +8,7 @@ eXosip2 has support for:
* call initiation and modification. (INVITE, re-INVITE)
* other methods within calls (INFO, OPTIONS, UPDATE)
* call transfer. (REFER)
* reliability for provisionnal response. (PRACK)
* reliability for provisional response. (PRACK)
* sip event package. (SUBSCRIBE/NOTIFY)
* event state publication. (PUBLISH)
* instant messaging. (MESSAGE)

View file

@ -1,4 +1,3 @@
%%JOSUA%%bin/josua
include/eXosip2/eX_call.h
include/eXosip2/eX_message.h
include/eXosip2/eX_options.h
@ -8,14 +7,8 @@ include/eXosip2/eX_register.h
include/eXosip2/eX_setup.h
include/eXosip2/eX_subscribe.h
include/eXosip2/eXosip.h
include/josua/jmainconfig.h
lib/libeXosip2.a
lib/libeXosip2.la
lib/libeXosip2.so
lib/libeXosip2.so.5
%%JOSUA%%lib/libjosua.a
%%JOSUA%%lib/libjosua.la
%%JOSUA%%lib/libjosua.so
%%JOSUA%%lib/libjosua.so.0
lib/libeXosip2.so.6
@dirrm include/eXosip2
@dirrm include/josua