new port of showkey
This commit is contained in:
parent
f7f81e5b9d
commit
84e27e4737
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=92004
5 changed files with 52 additions and 0 deletions
|
@ -56,6 +56,7 @@
|
||||||
SUBDIR += ruby-dump.rb
|
SUBDIR += ruby-dump.rb
|
||||||
SUBDIR += ruby-iconv
|
SUBDIR += ruby-iconv
|
||||||
SUBDIR += ruby-lv
|
SUBDIR += ruby-lv
|
||||||
|
SUBDIR += showkey
|
||||||
SUBDIR += siconv
|
SUBDIR += siconv
|
||||||
SUBDIR += tnef
|
SUBDIR += tnef
|
||||||
SUBDIR += trans
|
SUBDIR += trans
|
||||||
|
|
27
converters/showkey/Makefile
Normal file
27
converters/showkey/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
# New ports collection makefile for: showkey
|
||||||
|
# Date created: 2003-10-24
|
||||||
|
# Whom: trevor
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= showkey
|
||||||
|
PORTVERSION= 1.3
|
||||||
|
CATEGORIES= converters
|
||||||
|
MASTER_SITES= http://catb.org/~esr/showkey/
|
||||||
|
|
||||||
|
MAINTAINER= trevor@FreeBSD.org
|
||||||
|
COMMENT= Prints its input, with escapes such as "<NUL>"
|
||||||
|
|
||||||
|
ALL_TARGET= showkey
|
||||||
|
MAN1= showkey.1
|
||||||
|
PLIST= ${WRKDIR}/pkg-plist
|
||||||
|
|
||||||
|
pre-install:
|
||||||
|
${ECHO_CMD} bin/showkey > ${PLIST}
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/showkey ${PREFIX}/bin
|
||||||
|
${INSTALL_MAN} ${WRKSRC}/showkey.1 ${MANPREFIX}/man/man1
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
converters/showkey/distinfo
Normal file
1
converters/showkey/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (showkey-1.3.tar.gz) = 5727fd241bd0cf5e4e27694bdb2d3bb3
|
13
converters/showkey/files/patch-showkey.c
Normal file
13
converters/showkey/files/patch-showkey.c
Normal file
|
@ -0,0 +1,13 @@
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- showkey.c.orig Tue Aug 27 03:12:48 2002
|
||||||
|
+++ showkey.c Fri Oct 24 01:02:04 2003
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
unsigned char c;
|
||||||
|
unsigned int i, timeouts;
|
||||||
|
|
||||||
|
- for (i = SIGHUP; i <= SIGPOLL; i++)
|
||||||
|
+ for (i = SIGHUP; i <= SIGIO; i++)
|
||||||
|
(void) signal(c, catcher);
|
||||||
|
|
||||||
|
// Get the state of the tty
|
10
converters/showkey/pkg-descr
Normal file
10
converters/showkey/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
from the man page:
|
||||||
|
|
||||||
|
This program puts your terminal in raw mode, eats keystrokes, and
|
||||||
|
prints them back it you in a recognizable printed form (using <>-sur-
|
||||||
|
rounded ASCII mnemonics for non-printables).
|
||||||
|
|
||||||
|
This may be useful, for example, if you're not certain what your key-
|
||||||
|
board keys are sending.
|
||||||
|
|
||||||
|
WWW: http://catb.org/~esr/showkey/
|
Loading…
Reference in a new issue