- Fix build on 4.X
- Respect CFLAGS etc. (me) PR: ports/75169 Submitted by: maintainer
This commit is contained in:
parent
8af14debab
commit
8541d9ee32
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=124587
6 changed files with 52 additions and 6 deletions
|
@ -22,9 +22,6 @@ USE_GETOPT_LONG= yes
|
|||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
USE_LIBTOOL_VER= 15
|
||||
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.ifndef(WITHOUT_GTKSPELL)
|
||||
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
|
||||
CONFIGURE_ARGS+= --enable-gtkspell
|
||||
|
|
13
net-im/kf/files/patch-src-Makefile.in
Normal file
13
net-im/kf/files/patch-src-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/Makefile.in.orig Mon Dec 20 13:36:48 2004
|
||||
+++ src/Makefile.in Mon Dec 20 13:37:29 2004
|
||||
@@ -90,8 +90,8 @@
|
||||
|
||||
|
||||
#kf_LDADD = @PACKAGE_LIBS@ $(INTLLIBS)
|
||||
-CFLAGS = -Wall -Wmissing-declarations
|
||||
-LDFLAGS = -g
|
||||
+CFLAGS = @CFLAGS@ -Wall -Wmissing-declarations
|
||||
+LDFLAGS = @LDFLAGS@ -g
|
||||
kf_LDADD = @PACKAGE_LIBS@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
13
net-im/kf/files/patch-src-emoticons.c
Normal file
13
net-im/kf/files/patch-src-emoticons.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/emoticons.c.orig Thu Dec 16 22:50:31 2004
|
||||
+++ src/emoticons.c Thu Dec 16 22:51:27 2004
|
||||
@@ -347,9 +347,9 @@
|
||||
gchar *caption; /* Should be enough... */
|
||||
|
||||
if (kf_preferences_get_int ("chatShowStamps")) {
|
||||
+ gchar *sstamp;
|
||||
struct tm *stime;
|
||||
stime = localtime ((time_t *) &stamp);
|
||||
- gchar *sstamp;
|
||||
|
||||
gtk_text_buffer_get_end_iter (buffer, &iter);
|
||||
if (stamp < time (NULL) - 3600 * 24) {
|
|
@ -22,9 +22,6 @@ USE_GETOPT_LONG= yes
|
|||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
USE_LIBTOOL_VER= 15
|
||||
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.ifndef(WITHOUT_GTKSPELL)
|
||||
LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
|
||||
CONFIGURE_ARGS+= --enable-gtkspell
|
||||
|
|
13
net/kf/files/patch-src-Makefile.in
Normal file
13
net/kf/files/patch-src-Makefile.in
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/Makefile.in.orig Mon Dec 20 13:36:48 2004
|
||||
+++ src/Makefile.in Mon Dec 20 13:37:29 2004
|
||||
@@ -90,8 +90,8 @@
|
||||
|
||||
|
||||
#kf_LDADD = @PACKAGE_LIBS@ $(INTLLIBS)
|
||||
-CFLAGS = -Wall -Wmissing-declarations
|
||||
-LDFLAGS = -g
|
||||
+CFLAGS = @CFLAGS@ -Wall -Wmissing-declarations
|
||||
+LDFLAGS = @LDFLAGS@ -g
|
||||
kf_LDADD = @PACKAGE_LIBS@
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
||||
CONFIG_HEADER = ../config.h
|
13
net/kf/files/patch-src-emoticons.c
Normal file
13
net/kf/files/patch-src-emoticons.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/emoticons.c.orig Thu Dec 16 22:50:31 2004
|
||||
+++ src/emoticons.c Thu Dec 16 22:51:27 2004
|
||||
@@ -347,9 +347,9 @@
|
||||
gchar *caption; /* Should be enough... */
|
||||
|
||||
if (kf_preferences_get_int ("chatShowStamps")) {
|
||||
+ gchar *sstamp;
|
||||
struct tm *stime;
|
||||
stime = localtime ((time_t *) &stamp);
|
||||
- gchar *sstamp;
|
||||
|
||||
gtk_text_buffer_get_end_iter (buffer, &iter);
|
||||
if (stamp < time (NULL) - 3600 * 24) {
|
Loading…
Reference in a new issue