Add liblug 1.0.6, a very clean graphic library which can handle gif, pcx, targa,
rgb, tiff, pix, ppm, pgm, pbm, raw, rayshade's heightfield, jpeg and do the following functions: resampling, blur, sharpening, cut, paste, median filter, histogram equalization, and so on. PR: 23889 Submitted by: George Reid <greid@ukug.uk.freebsd.org>
This commit is contained in:
parent
0544709853
commit
8552800cb9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=36451
8 changed files with 145 additions and 0 deletions
|
@ -104,6 +104,7 @@
|
|||
SUBDIR += libflash
|
||||
SUBDIR += libggi
|
||||
SUBDIR += libimg
|
||||
SUBDIR += liblug
|
||||
SUBDIR += libmng
|
||||
SUBDIR += libmorph
|
||||
SUBDIR += libungif
|
||||
|
|
22
graphics/liblug/Makefile
Normal file
22
graphics/liblug/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: liblug
|
||||
# Date created: 27 December 2000
|
||||
# Whom: George Reid <greid@ukug.uk.freebsd.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= liblug
|
||||
PORTVERSION= 1.0.6
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SUNSITE}
|
||||
MASTER_SITE_SUBDIR= libs/graphics
|
||||
|
||||
MAINTAINER= greid@ukug.uk.freebsd.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/lug
|
||||
|
||||
MAKEFILE= Makefile.linux
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/liblug/distinfo
Normal file
1
graphics/liblug/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (liblug-1.0.6.tar.gz) = a94c49bdadd7b510c4089b25621c3395
|
102
graphics/liblug/files/patch-aa
Normal file
102
graphics/liblug/files/patch-aa
Normal file
|
@ -0,0 +1,102 @@
|
|||
--- Makefile.linux Fri Dec 29 20:49:53 2000
|
||||
+++ Makefile.linux.new Fri Dec 29 20:50:36 2000
|
||||
@@ -24,12 +24,12 @@
|
||||
#
|
||||
# Uncomment next line if you are using other compiler (e.g. gcc)
|
||||
#
|
||||
-CC = gcc
|
||||
+CC?= gcc
|
||||
|
||||
#
|
||||
# Compiler options ( only C-O-M-P-I-L-E-R, not LUG options ).
|
||||
#
|
||||
-COPTS = -O2
|
||||
+COPTS = ${CFLAGS}
|
||||
|
||||
#
|
||||
# Location of LUG header files.
|
||||
@@ -40,7 +40,7 @@
|
||||
#
|
||||
# Where lug library will live
|
||||
#
|
||||
-LIBLUGDEST = /usr/local/lib
|
||||
+LIBLUGDEST = ${PREFIX}/lib
|
||||
|
||||
#
|
||||
# If you have installed the Utah Raster Toolkit library define
|
||||
@@ -52,10 +52,10 @@
|
||||
#
|
||||
# , or leave undefined if you don't have it.
|
||||
#
|
||||
-URTINC = -I/usr/local/include/urt
|
||||
-URTLIB = /usr/local/lib/librle.a
|
||||
+#URTINC = -I/usr/local/include/urt
|
||||
+#URTLIB = /usr/local/lib/librle.a
|
||||
#URTLIB = -L/usr/local/lib -lrle
|
||||
-URTDEF = -DiRLE
|
||||
+#URTDEF = -DiRLE
|
||||
|
||||
#
|
||||
# If you have installed the Sam Leffler's TIFF library define
|
||||
@@ -67,9 +67,9 @@
|
||||
#
|
||||
# , or leave undefined if you don't have it.
|
||||
#
|
||||
-TIFFINC = -I/usr/local/include/tiff
|
||||
-TIFFLIB = /usr/local/lib/libtiff.a
|
||||
-#TIFFLIB = -L/usr/local/lib -ltiff
|
||||
+#TIFFINC = -I/usr/local/include/tiff
|
||||
+#TIFFLIB = /usr/local/lib/libtiff.a
|
||||
+TIFFLIB = -L${PREFIX}/lib -ltiff
|
||||
TIFFDEF = -DiTIFF
|
||||
|
||||
#
|
||||
@@ -87,9 +87,9 @@
|
||||
#
|
||||
# , or leave undefined if you don't have it.
|
||||
#
|
||||
-JPEGINC = -I/usr/local/include/jpeg
|
||||
-JPEGLIB = /usr/local/lib/libjpeg.a
|
||||
-#JPEGLIB = -L/usr/local/lib -ljpeg
|
||||
+JPEGINC = -I${PREFIX}/include
|
||||
+#JPEGLIB = /usr/local/lib/libjpeg.a
|
||||
+JPEGLIB = -L${PREFIX}/lib -ljpeg
|
||||
JPEGDEF = -DiJPEGNEW
|
||||
|
||||
#
|
||||
@@ -127,15 +127,15 @@
|
||||
# VIEWLIB = -lgl_s -lvfr
|
||||
# VIEWINC = -I/usr/include/gl -I/usr/video/vfr/src/inc
|
||||
#
|
||||
-VIEWINC = -I/usr/X11/include
|
||||
-VIEWLIB = -L/usr/X11/lib -lX11
|
||||
+VIEWINC = -I${X11BASE}/include
|
||||
+VIEWLIB = -L${X11BASE}/lib -lX11
|
||||
VIEWDEF = -DiX11 -DiLINUX
|
||||
|
||||
#
|
||||
# Final includes ( don't touch this ! ).
|
||||
#
|
||||
INCS = $(LUGINC) $(URTINC) $(TIFFINC) $(JPEGINC) $(SGIINC) $(VIEWINC)
|
||||
-LIBS = $(LUGLIB) $(URTLIB) $(TIFFLIB) $(JPEGLIB) $(VIEWLIB) -lm
|
||||
+LIBS = $(LUGLIB) $(URTLIB) $(TIFFLIB) $(JPEGLIB) $(VIEWLIB) -lm -lcompat
|
||||
DEFS = $(URTDEF) $(TIFFDEF) $(JPEGDEF) $(SGIDEF) $(VIEWDEF)
|
||||
|
||||
#
|
||||
@@ -166,15 +166,7 @@
|
||||
( cd examples; $(MAKE) clean )
|
||||
|
||||
install: liblug.a
|
||||
- @echo "Installing library..."
|
||||
- @if [ ! -d $(LIBLUGDEST) ]; \
|
||||
- then \
|
||||
- mkdir $(LIBLUGDEST); \
|
||||
- chmod a+rx $(LIBLUGDEST); \
|
||||
- fi; \
|
||||
- cp liblug.a $(LIBLUGDEST); \
|
||||
- chmod 644 $(LIBLUGDEST)/liblug.a; \
|
||||
- @echo "OK."
|
||||
+ /usr/bin/install -c -o root -g wheel -m 444 liblug.a $(LIBLUGDEST)
|
||||
|
||||
archive:; ( cd .. ; tar cvf lug-1.0.tar lug ; compress lug-1.0.tar )
|
||||
|
10
graphics/liblug/files/patch-ab
Normal file
10
graphics/liblug/files/patch-ab
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- convert/rla.c.orig Mon Jul 12 08:36:48 1993
|
||||
+++ convert/rla.c Wed Dec 27 18:18:42 2000
|
||||
@@ -26,6 +26,7 @@
|
||||
*
|
||||
*/
|
||||
|
||||
+#include <stdio.h>
|
||||
#include <lug.h>
|
||||
#include <lugfnts.h>
|
||||
|
1
graphics/liblug/pkg-comment
Normal file
1
graphics/liblug/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A multi-format graphics manipulation library
|
7
graphics/liblug/pkg-descr
Normal file
7
graphics/liblug/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
A very clean graphic library which can handle gif, pcx, targa,
|
||||
rgb, tiff, pix, ppm, pgm, pbm, raw, rayshade's heightfield, jpeg
|
||||
and do the following function: resampling, blur, sharpening, cut,
|
||||
paste, median filter, histogram equalization and so on...
|
||||
|
||||
- George Reid
|
||||
greid@ukug.uk.freebsd.org
|
1
graphics/liblug/pkg-plist
Normal file
1
graphics/liblug/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
lib/liblug.a
|
Loading…
Reference in a new issue