www/py-django-star-ratings: Fix wayward test files installing

* Prevent installing the test suite into the top level of Python's
  site-lib directory to avoid conflicting files.

* Bump PORTREVISION due package change.

PR:		262759 [1], 262798
Reported by:	se [1]
This commit is contained in:
Kevin Golding 2022-03-30 12:18:08 +02:00 committed by Kai Knoblich
parent ff62c11974
commit 855b1b0a36
2 changed files with 12 additions and 0 deletions
www/py-django-star-ratings

View file

@ -2,6 +2,7 @@
PORTNAME= django-star-ratings
PORTVERSION= 0.9.2
PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -0,0 +1,11 @@
--- setup.py.orig 2022-03-25 15:45:28 UTC
+++ setup.py
@@ -41,7 +41,7 @@ if sys.argv[-1] == 'publish':
setup(
name='django-star-ratings',
version=version,
- packages=find_packages(),
+ packages=find_packages(exclude=['tests*']),
include_package_data=True,
package_data={
'star_ratings/static': ['*'],