comms/quisk: Update 4.1.26 -> 4.1.39

This commit is contained in:
Yuri Victorovich 2019-05-23 06:13:47 +00:00
parent ac84c21261
commit 855e858450
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=502312
7 changed files with 29 additions and 46 deletions

View file

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quisk
PORTVERSION= 4.1.26
PORTREVISION= 2
DISTVERSION= 4.1.39
CATEGORIES= comms hamradio
MASTER_SITES= CHEESESHOP
@ -24,11 +23,14 @@ USE_WX= 3.0+
WX_COMPS= python
post-extract:
${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so \
@${RM} ${WRKSRC}/_quisk.so ${WRKSRC}/sdriqpkg/sdriq.so \
${WRKSRC}/freedvpkg/libcodec2_32.so \
${WRKSRC}/freedvpkg/libcodec2_64.so
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/setup.py
post-stage:
@${FIND} ${STAGEDIR}${PREFIX} -name "*.so" | ${XARGS} ${STRIP_CMD}
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1555665888
SHA256 (quisk-4.1.26.tar.gz) = 6df5ac3adb43fa4daeafec4cef2a19ade33f6d561053302b761f944d98fc1890
SIZE (quisk-4.1.26.tar.gz) = 3236756
TIMESTAMP = 1558585840
SHA256 (quisk-4.1.39.tar.gz) = 6e6a780309bf3f97d8ff8f3179e35c6c60b06df6fea838d493626f7066716018
SIZE (quisk-4.1.39.tar.gz) = 3033628

View file

@ -0,0 +1,10 @@
--- afedrinet/afedrinet_io.c.orig 2019-05-23 04:31:28 UTC
+++ afedrinet/afedrinet_io.c
@@ -15,6 +15,7 @@
#include <errno.h>
#include <stdlib.h>
#include <unistd.h>
+#include <netinet/in.h>
#endif
#ifdef MS_WINDOWS

View file

@ -1,6 +1,6 @@
--- microphone.c.orig 2018-11-21 19:08:22 UTC
--- microphone.c.orig 2019-05-09 20:49:44 UTC
+++ microphone.c
@@ -58,7 +58,7 @@ static int timeVOX = 2000; // VOX han
@@ -76,7 +76,7 @@ static int reverse_tx_sideband;
static int doTxCorrect = 0; // Corrections for UDP sample transmit
static double TxCorrectLevel;

View file

@ -1,6 +1,6 @@
--- quisk.c.orig 2019-04-19 15:39:19 UTC
--- quisk.c.orig 2019-05-09 20:50:36 UTC
+++ quisk.c
@@ -4065,7 +4065,7 @@ static PyObject * get_bandscope(void) //
@@ -4352,7 +4352,7 @@ static PyObject * get_bandscope(void) // Called by the
j2 = floor(d2);
sample = (j1 + 1 - d1) * bandscopeAverage[j1];
for (j = j1 + 1; j < j2; j++)

View file

@ -1,29 +0,0 @@
--- quisk.py.orig 2018-11-23 17:50:38 UTC
+++ quisk.py
@@ -21,6 +21,13 @@ os.chdir(os.path.normpath(os.path.dirnam
if sys.path[0] != "'.'": # Make sure the current working directory is on path
sys.path.insert(0, '.')
+# Hack to ensure unicode is available.
+import locale
+locale.setlocale(locale.LC_ALL, '')
+cloc = locale.getdefaultlocale()
+if locale.nl_langinfo(locale.CODESET) != 'UTF-8':
+ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))
+
import wx, wx.html, wx.lib.buttons, wx.lib.stattext, wx.lib.colourdb, wx.grid, wx.richtext
import math, cmath, time, traceback, string, select, subprocess
import threading, pickle, webbrowser
@@ -3609,9 +3616,9 @@ class App(wx.App):
self.file_play_timer = 0
self.file_play_source = 0 # 10 == play audio file, 11 == play I/Q sample file, 12 == play CQ message
# get the screen size - thanks to Lucian Langa
- x1, y1, x2, y2 = wx.Display().GetGeometry()
- self.screen_width = x2 - x1
- self.screen_height = y2 - y1
+ dispGeo = wx.Display().GetGeometry()
+ self.screen_width = dispGeo.width
+ self.screen_height = dispGeo.height
self.Bind(wx.EVT_IDLE, self.OnIdle)
self.Bind(wx.EVT_QUERY_END_SESSION, self.OnEndSession)
# Restore persistent program state

View file

@ -1,6 +1,6 @@
--- setup.py.orig 2018-11-22 14:56:57 UTC
--- setup.py.orig 2019-04-18 17:28:40 UTC
+++ setup.py
@@ -13,23 +13,23 @@ fp.close()
@@ -17,23 +17,23 @@ is_64bit = sys.maxint > 2**32
if sys.platform != "win32":
missing = False
@ -41,16 +41,16 @@
if missing:
ans = raw_input("Do you want to continue (y, N): ")
ans = ans.strip()
@@ -37,6 +37,8 @@ if sys.platform != "win32":
@@ -41,6 +41,8 @@ if sys.platform != "win32":
sys.exit(1)
module1 = Extension ('quisk._quisk',
+ include_dirs = ['%%LOCALBASE%%/include'],
+ library_dirs = ['%%LOCALBASE%%/lib'],
+ include_dirs = ['/usr/local/include'],
+ library_dirs = ['/usr/local/lib'],
libraries = ['asound', 'portaudio', 'pulse', 'fftw3', 'm'],
sources = ['quisk.c', 'sound.c', 'sound_alsa.c', 'sound_portaudio.c', 'sound_pulseaudio.c',
'is_key_down.c', 'microphone.c', 'utility.c',
@@ -69,8 +71,6 @@ modulew2 = Extension ('quisk.sdriqpkg.sd
@@ -94,8 +96,6 @@ modulew4 = Extension ('quisk.soapypkg.soapy',
# Changes for MacOS support thanks to Mario, DL3LSM.
modulem1 = Extension ('quisk._quisk',