Approved by:	portmgr@ (blanket approval)
This commit is contained in:
Vanilla I. Shu 2014-06-30 15:42:24 +00:00
parent 82d49f7eb2
commit 8599e9c93f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359868
2 changed files with 16 additions and 16 deletions

View file

@ -21,14 +21,13 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN3= pcrs.3
PLIST_FILES= bin/pcrsed \
lib/libpcrs.a \
lib/libpcrs.so \
lib/libpcrs.so.0
lib/libpcrs.so.0 \
man/man3/pcrs.3.gz
NO_STAGE= yes
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/pcrsed ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/pcrsed ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

View file

@ -1,6 +1,6 @@
--- Makefile.in.orig Mon Mar 11 08:56:16 2002
+++ Makefile.in Sun Nov 27 00:07:10 2005
@@ -19,6 +19,7 @@
--- Makefile.in.orig 2002-03-11 05:56:16.000000000 +0800
+++ Makefile.in 2014-06-30 23:39:01.951429627 +0800
@@ -19,6 +19,7 @@ exec_prefix = @exec_prefix@
BINDIR = @bindir@
LIBDIR = @libdir@
@ -8,7 +8,7 @@
MANDIR = @mandir@/man3
@@ -47,6 +48,7 @@
@@ -47,6 +48,7 @@ LIBS = @LIBS@
#############################################################################
CFLAGS = @CFLAGS@ -Wall -Wstrict-prototypes -Wshadow -Wconversion -pedantic \
@ -16,7 +16,7 @@
@PARANOID_FU@ -Wunreachable-code -Wmissing-prototypes \
-Waggregate-return -W -Wfloat-equal -Wsign-compare \
-Wwrite-strings
@@ -66,29 +68,25 @@
@@ -66,29 +68,25 @@ pcrsed@EXEEXT@: pcrs.@OBJEXT@
$(CC) $(CFLAGS) pcrsed.c pcrs.@OBJEXT@ -o pcrsed@EXEEXT@ $(LIBS)
shared: pcrs.@OBJEXT@
@ -31,15 +31,16 @@
- $(INSTALL) -m 755 libpcrs.so.$(VERSION) $(LIBDIR)
- $(LN_S) -f libpcrs.so.$(VERSION) $(LIBDIR)/libpcrs.so
- $(INSTALL) -m 644 libpcrs.a $(LIBDIR)
+ $(INSTALL) -m 755 libpcrs.so.$(VERSION_MAJOR) $(prefix)/lib
+ $(LN_S) -f libpcrs.so.$(VERSION_MAJOR) $(prefix)/lib/libpcrs.so
+ $(INSTALL) -m 644 libpcrs.a $(prefix)/lib
$(INSTALL) -m 644 pcrs.3 $(MANDIR)
- $(INSTALL) -m 644 pcrs.3 $(MANDIR)
-
- if test "$(HAVE_GZIP)" = "yes"; then \
- gzip -f $(MANDIR)/pcrs.3; \
- fi
-
+ $(INSTALL) -m 755 libpcrs.so.$(VERSION_MAJOR) $(DESTDIR)$(prefix)/lib
+ $(LN_S) -f libpcrs.so.$(VERSION_MAJOR) $(DESTDIR)$(prefix)/lib/libpcrs.so
+ $(INSTALL) -m 644 libpcrs.a $(DESTDIR)$(prefix)/lib
+ $(INSTALL) -m 644 pcrs.3 $(DESTDIR)$(MANDIR)
@echo -e " ***************************************************\n" \
- "** Libraries have been installed in $(LIBDIR). \n" \
+ "** Libraries have been installed in $(prefix)/lib. \n" \
@ -49,7 +50,7 @@
@if test -f pcrsed@EXEEXT@; then\
echo -e "\nRebuilding pcrsed to use the installed shared library"; \
- $(CC) $(CFLAGS) -L$(LIBDIR) pcrsed.c -o pcrsed@EXEEXT@ $(LIBS) -lpcrs; \
+ $(CC) $(CFLAGS) -L$(prefix)/lib pcrsed.c -o pcrsed@EXEEXT@ $(LIBS) -lpcrs; \
+ $(CC) $(CFLAGS) -L$(DESTDIR)$(prefix)/lib pcrsed.c -o pcrsed@EXEEXT@ $(LIBS) -lpcrs; \
fi
clean: