games/julius: update to 1.1.0, change maintainer, add USES=sdl, remove patches, update pkg-descr

Approved by:	linimon (mentor)
Differential Revision:	https://reviews.freebsd.org/D20424
This commit is contained in:
Piotr Kubaj 2019-05-30 07:55:53 +00:00
parent 44083cc319
commit 865003b87f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=503052
5 changed files with 20 additions and 26 deletions

View file

@ -2,18 +2,18 @@
# $FreeBSD$
PORTNAME= julius
PORTVERSION= 1.0.0
PORTVERSION= 1.1.0
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= games
PKGNAMESUFFIX= -caesariii
MAINTAINER= pkubaj@anongoth.pl
MAINTAINER= pkubaj@FreeBSD.org
COMMENT= Open source re-implementation of Caesar III
LICENSE= GPLv3
USES= cmake
USES= cmake sdl
USE_GITHUB= yes
GH_ACCOUNT= bvschaik
@ -22,6 +22,7 @@ USE_SDL= mixer2 sdl2
SUB_FILES= pkg-message
LDFLAGS+= -lexecinfo
PLIST_FILES= bin/${PORTNAME}
do-install:

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1541893414
SHA256 (bvschaik-julius-v1.0.0_GH0.tar.gz) = 145670dc185a627de547e3c3fe45d2bb2b40bdec2929888cd19c56814f21ebc5
SIZE (bvschaik-julius-v1.0.0_GH0.tar.gz) = 2665014
TIMESTAMP = 1558945825
SHA256 (bvschaik-julius-v1.1.0_GH0.tar.gz) = d558a13645508bf3a1055698a201d7d089a78b150362d861e57a07686cb82a9a
SIZE (bvschaik-julius-v1.1.0_GH0.tar.gz) = 4402895

View file

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2018-05-09 19:46:16 UTC
+++ CMakeLists.txt
@@ -343,7 +343,7 @@ if(MSVC)
include_directories(ext/dirent)
endif()
-target_link_libraries (julius ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARY})
+target_link_libraries (julius ${SDL2_LIBRARY} ${SDL2_MIXER_LIBRARY} execinfo)
install(TARGETS julius RUNTIME DESTINATION bin)

View file

@ -1,8 +0,0 @@
--- test/CMakeLists.txt.orig 2018-05-09 19:53:39 UTC
+++ test/CMakeLists.txt
@@ -82,3 +82,5 @@ add_integration_test(sav_routing_full ro
# God curses
add_integration_test(sav_curses curses.sav curses-done.sav 13350)
+
+target_link_libraries (autopilot execinfo)

View file

@ -1,3 +1,15 @@
An open source re-implementation of Caesar III
Julius is an open source re-implementation of Caesar III.
The aim of this project is to create an open-source version of Caesar 3,
with the same logic as the original, but with some UI enhancements,
that is able to be played on multiple platforms. The same logic means that
the saved games are 100% compatible, and any gameplay bugs present in
the original Caesar 3 game will also be present in Julius.
UI enhancements include:
* Support for widescreen resolutions
* Windowed mode support for 32-bit desktops
* Julius requires the original assets (graphics, sounds, etc)
from Caesar 3 to run.
WWW: https://github.com/bvschaik/julius