devel/py-google-crc32c: Update to 1.1.5
Changes: https://github.com/googleapis/python-crc32c/releases
This commit is contained in:
parent
bf928fbf39
commit
8655290edd
4 changed files with 15 additions and 15 deletions
|
@ -1,7 +1,7 @@
|
||||||
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
|
||||||
|
|
||||||
PORTNAME= google-crc32c
|
PORTNAME= google-crc32c
|
||||||
PORTVERSION= 1.1.2
|
PORTVERSION= 1.1.5
|
||||||
CATEGORIES= devel python
|
CATEGORIES= devel python
|
||||||
MASTER_SITES= CHEESESHOP
|
MASTER_SITES= CHEESESHOP
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -19,6 +19,6 @@ USES= localbase python:3.6+
|
||||||
USE_PYTHON= autoplist concurrent distutils
|
USE_PYTHON= autoplist concurrent distutils
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/google_crc32c/_crc32c_cffi*.so
|
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1611856548
|
TIMESTAMP = 1632037074
|
||||||
SHA256 (google-crc32c-1.1.2.tar.gz) = dff5bd1236737f66950999d25de7a78144548ebac7788d30ada8c1b6ead60b27
|
SHA256 (google-crc32c-1.1.5.tar.gz) = 0d58387206b44fc820ac9cddb367addaa51ae706694f7d15c43abc55bf6a09c1
|
||||||
SIZE (google-crc32c-1.1.2.tar.gz) = 12265
|
SIZE (google-crc32c-1.1.5.tar.gz) = 12097
|
||||||
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- setup.py.orig 2020-03-21 00:48:10 UTC
|
|
||||||
+++ setup.py
|
|
||||||
@@ -54,7 +54,6 @@ def main(build_cffi=True):
|
|
||||||
setuptools.setup(
|
|
||||||
packages=["google_crc32c"],
|
|
||||||
package_dir={"": "src"},
|
|
||||||
- package_data={"google_crc32c": [os.path.join(_EXTRA_DLL, _DLL_FILENAME)]},
|
|
||||||
setup_requires=[cffi_dep] if build_cffi else [],
|
|
||||||
cffi_modules=[builder] if build_cffi else [],
|
|
||||||
install_requires=[cffi_dep] if build_cffi else [],
|
|
10
devel/py-google-crc32c/patch-setup.py
Normal file
10
devel/py-google-crc32c/patch-setup.py
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- setup.py.orig 2021-09-07 21:17:59 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -70,7 +70,6 @@ def build_c_extension():
|
||||||
|
packages=["google_crc32c"],
|
||||||
|
package_dir={"": "src"},
|
||||||
|
ext_modules=[module],
|
||||||
|
- cmdclass={"build_ext": BuildExtWithDLL},
|
||||||
|
)
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue