Garden of coloured lights is an old school 2D vertical shoot-em-up

with some innovative elements. Innovative graphics, soundtrack and
game concept. The game itself is very challenging and as you progress,
you will understand that you are dealing with a true piece of art...

WWW: http://garden.sourceforge.net/
This commit is contained in:
Dmitry Marakasov 2016-09-19 11:24:49 +00:00
parent 052f912ec0
commit 8678610565
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=422426
7 changed files with 88 additions and 0 deletions

View file

@ -309,6 +309,7 @@
SUBDIR += funnyboat
SUBDIR += galaxis
SUBDIR += galaxyhack
SUBDIR += garden-of-coloured-lights
SUBDIR += garith
SUBDIR += gbottler
SUBDIR += gbrainy

View file

@ -0,0 +1,35 @@
# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
PORTNAME= garden-of-coloured-lights
PORTVERSION= 1.0.9
CATEGORIES= games
MASTER_SITES= SF/garden/garden/${PORTVERSION}/
DISTNAME= garden-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Old school 2D vertical shoot-em-up with some innovative elements
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liballeg.so:devel/allegro
GNU_CONFIGURE= yes
USES= desktop-file-utils localbase
INSTALLS_ICONS= yes
DATADIR= ${PREFIX}/share/garden
PORTDOCS= AUTHORS ChangeLog NEWS README
PORTDATA= *
OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1474068270
SHA256 (garden-1.0.9.tar.gz) = daf8732c229a4cc04f460514bff1ba05171faada9e19575c72a50a914f2352e3
SIZE (garden-1.0.9.tar.gz) = 2714783

View file

@ -0,0 +1,26 @@
--- src/stuff.c.orig 2015-01-19 21:17:42 UTC
+++ src/stuff.c
@@ -52,7 +52,7 @@ float decoy_table[ANGLE_1]; // not used
float cos_table[ANGLE_1];
float sin_table[ANGLE_1];
-inline int xpart (int angle, int length);
+int xpart (int angle, int length);
void init_trig (void)
{
@@ -67,12 +67,12 @@ void init_trig (void)
}
-inline int xpart (int angle, int length)
+int xpart (int angle, int length)
{
return (cos_table[angle & 1023] * length);
}
-inline int ypart (int angle, int length)
+int ypart (int angle, int length)
{
return (sin_table[angle & 1023] * length);
}

View file

@ -0,0 +1,13 @@
--- src/stuff.h.orig 2015-01-19 20:19:08 UTC
+++ src/stuff.h
@@ -24,8 +24,8 @@ int grand (int number);
int crandom (int number);
int turn_towards_angle (int angle, int tangle, int turning);
int turn_towards_xy (int x1, int y1, int x2, int y2, int angle, int turning);
-inline int xpart (int angle, int length);
-inline int ypart (int angle, int length);
+int xpart (int angle, int length);
+int ypart (int angle, int length);
int pulsate (int speed, int amount, int county);
int angle_difference (int a1, int a2);

View file

@ -0,0 +1,6 @@
Garden of coloured lights is an old school 2D vertical shoot-em-up
with some innovative elements. Innovative graphics, soundtrack and
game concept. The game itself is very challenging and as you progress,
you will understand that you are dealing with a true piece of art...
WWW: http://garden.sourceforge.net/

View file

@ -0,0 +1,4 @@
bin/garden
share/appdata/garden.appdata.xml
share/applications/garden.desktop
share/icons/hicolor/scalable/apps/garden.svg