Update ElasticSearch5 to 5.6.8
Notable changes: - automate pkg-plists - Kibana: data dir is now correctly writable by www user Differential Revision: https://reviews.freebsd.org/D14474
This commit is contained in:
parent
777dbe563d
commit
86cfe07013
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462830
22 changed files with 131 additions and 39832 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= logstash
|
||||
PORTVERSION= 5.3.0
|
||||
PORTVERSION= 5.6.8
|
||||
CATEGORIES= sysutils java
|
||||
MASTER_SITES= http://artifacts.elastic.co/downloads/logstash/
|
||||
PKGNAMESUFFIX= 5
|
||||
|
@ -29,10 +29,8 @@ LOGSTASH_DIR= ${PREFIX}/${PORTNAME}
|
|||
USE_RC_SUBR= logstash
|
||||
|
||||
LOGSTASH_HOME?= ${PREFIX}/${PORTNAME}
|
||||
LOGSTASH_RUN?= /var/run/${PORTNAME}
|
||||
LOGSTASH_DATA_DIR?= /var/db/${PORTNAME}
|
||||
|
||||
SUB_LIST= LOGSTASH_DATA_DIR=${LOGSTASH_DATA_DIR} JAVA_HOME=${JAVA_HOME} \
|
||||
SUB_LIST= JAVA_HOME=${JAVA_HOME} \
|
||||
LOGSTASH_HOME=${LOGSTASH_HOME}
|
||||
|
||||
LOGSTASH_BIN_FILES= logstash
|
||||
|
@ -43,8 +41,6 @@ LOGSTASH_JRUBY_BIN_FILES= ast irb jirb jruby jruby.sh rdoc testrb gem \
|
|||
do-install:
|
||||
@${FIND} ${WRKSRC} -name '*.bat' -delete
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR}
|
||||
${MKDIR} ${STAGEDIR}${LOGSTASH_RUN}
|
||||
${MKDIR} ${STAGEDIR}${LOGSTASH_DATA_DIR}
|
||||
@(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${LOGSTASH_DIR})
|
||||
${INSTALL_DATA} ${FILESDIR}/logstash.conf.sample ${STAGEDIR}${ETCDIR}
|
||||
.for x in ${LOGSTASH_BIN_FILES}
|
||||
|
@ -54,4 +50,20 @@ do-install:
|
|||
@${CHMOD} ${BINMODE} ${STAGEDIR}${LOGSTASH_DIR}/${LOGSTASH_JRUBY_SUBDIR}/${x}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
${ECHO} "@sample ${ETCDIR}/logstash.conf.sample" >> ${TMPPLIST}
|
||||
${FIND} -s ${STAGEDIR}${PREFIX}/logstash -not -type d | ${SORT} | \
|
||||
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/data" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/build_info" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/cache" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/doc" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/extensions" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/gems/manticore-0.6.1-java/spec/ssl" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/1.9/gems/redis-3.3.5/test/db" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/2.3.0/build_info" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/2.3.0/cache" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/2.3.0/doc" >> ${TMPPLIST}
|
||||
${ECHO} "@dir logstash/vendor/bundle/jruby/2.3.0/extensions" >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491433602
|
||||
SHA256 (logstash-5.3.0.tar.gz) = 4227d08ef62b55d5dfb4933690f26723f45900bd67bc5b4dbe99371839e7b13e
|
||||
SIZE (logstash-5.3.0.tar.gz) = 94087323
|
||||
TIMESTAMP = 1519337199
|
||||
SHA256 (logstash-5.6.8.tar.gz) = d9620d64894cb25ee365e66e3a0197f3780a08d8e711689716cf61fb9c2c4cf5
|
||||
SIZE (logstash-5.6.8.tar.gz) = 102819618
|
||||
|
|
|
@ -99,7 +99,9 @@ PATH=/usr/local/bin:$PATH
|
|||
|
||||
logstash_precmd()
|
||||
{
|
||||
/usr/bin/install -d -o root -g wheel -m 750 ${logstash_log_dir}
|
||||
/usr/bin/install -d -o root -g wheel -m 755 ${logstash_log_dir}
|
||||
/usr/bin/install -d -o root -g wheel -m 755 /var/db/logstash
|
||||
/usr/bin/install -d -o root -g wheel -m 755 /var/run/logstash
|
||||
}
|
||||
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= x-pack
|
||||
PORTVERSION= 5.3.0
|
||||
PORTVERSION= 5.6.8
|
||||
CATEGORIES= textproc java
|
||||
MASTER_SITES= https://artifacts.elastic.co/downloads/packs/x-pack/
|
||||
PKGNAMEPREFIX= elasticsearch5-
|
||||
|
@ -10,7 +10,7 @@ PKGNAMEPREFIX= elasticsearch5-
|
|||
MAINTAINER= tj@FreeBSD.org
|
||||
COMMENT= Elasticsearch X-Pack plugins
|
||||
|
||||
RUN_DEPENDS:= elasticsearch5>=5.3.0:textproc/elasticsearch5
|
||||
RUN_DEPENDS:= elasticsearch5>=5.6.8:textproc/elasticsearch5
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
|
@ -24,4 +24,8 @@ do-extract:
|
|||
do-install:
|
||||
@cd ${WRKSRC}/elasticsearch && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/x-pack
|
||||
|
||||
post-install:
|
||||
@${FIND} -s ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/x-pack -not -type d | ${SORT} | \
|
||||
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491441977
|
||||
SHA256 (x-pack-5.3.0.zip) = 5580d907774e558a8ee23680962c26e745979202974cab12a3b445b31dc37fd4
|
||||
SIZE (x-pack-5.3.0.zip) = 126084986
|
||||
TIMESTAMP = 1519322034
|
||||
SHA256 (x-pack-5.6.8.zip) = 5aa106af78bf5f37e574415aeba62bb93afcc2d9faffb60a883ce233ac4bc426
|
||||
SIZE (x-pack-5.6.8.zip) = 160447245
|
||||
|
|
|
@ -1,48 +0,0 @@
|
|||
lib/elasticsearch/plugins/x-pack/LICENSE.txt
|
||||
lib/elasticsearch/plugins/x-pack/NOTICE.txt
|
||||
lib/elasticsearch/plugins/x-pack/activation-1.1.jar
|
||||
lib/elasticsearch/plugins/x-pack/bcpkix-jdk15on-1.55.jar
|
||||
lib/elasticsearch/plugins/x-pack/bcprov-jdk15on-1.55.jar
|
||||
lib/elasticsearch/plugins/x-pack/bin/.in.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/certgen
|
||||
lib/elasticsearch/plugins/x-pack/bin/certgen.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/croneval
|
||||
lib/elasticsearch/plugins/x-pack/bin/croneval.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/extension
|
||||
lib/elasticsearch/plugins/x-pack/bin/extension.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/migrate
|
||||
lib/elasticsearch/plugins/x-pack/bin/migrate.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/syskeygen
|
||||
lib/elasticsearch/plugins/x-pack/bin/syskeygen.bat
|
||||
lib/elasticsearch/plugins/x-pack/bin/users
|
||||
lib/elasticsearch/plugins/x-pack/bin/users.bat
|
||||
lib/elasticsearch/plugins/x-pack/commons-codec-1.10.jar
|
||||
lib/elasticsearch/plugins/x-pack/commons-logging-1.1.3.jar
|
||||
lib/elasticsearch/plugins/x-pack/config/log4j2.properties
|
||||
lib/elasticsearch/plugins/x-pack/config/role_mapping.yml
|
||||
lib/elasticsearch/plugins/x-pack/config/roles.yml
|
||||
lib/elasticsearch/plugins/x-pack/config/users
|
||||
lib/elasticsearch/plugins/x-pack/config/users_roles
|
||||
lib/elasticsearch/plugins/x-pack/guava-16.0.1.jar
|
||||
lib/elasticsearch/plugins/x-pack/httpasyncclient-4.1.2.jar
|
||||
lib/elasticsearch/plugins/x-pack/httpclient-4.5.2.jar
|
||||
lib/elasticsearch/plugins/x-pack/httpcore-4.4.5.jar
|
||||
lib/elasticsearch/plugins/x-pack/httpcore-nio-4.4.5.jar
|
||||
lib/elasticsearch/plugins/x-pack/javax.mail-1.5.3.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-3.10.6.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-buffer-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-codec-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-codec-http-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-common-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-handler-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-resolver-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/netty-transport-4.1.7.Final.jar
|
||||
lib/elasticsearch/plugins/x-pack/owasp-java-html-sanitizer-r239.jar
|
||||
lib/elasticsearch/plugins/x-pack/plugin-descriptor.properties
|
||||
lib/elasticsearch/plugins/x-pack/plugin-security.policy
|
||||
lib/elasticsearch/plugins/x-pack/rest-5.3.0.jar
|
||||
lib/elasticsearch/plugins/x-pack/sniffer-5.3.0.jar
|
||||
lib/elasticsearch/plugins/x-pack/transport-netty3-5.3.0.jar
|
||||
lib/elasticsearch/plugins/x-pack/transport-netty4-5.3.0.jar
|
||||
lib/elasticsearch/plugins/x-pack/unboundid-ldapsdk-3.2.0.jar
|
||||
lib/elasticsearch/plugins/x-pack/x-pack-5.3.0.jar
|
|
@ -2,8 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= elasticsearch
|
||||
PORTVERSION= 5.3.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 5.6.8
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= textproc java devel
|
||||
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
|
||||
http://mirrors.rit.edu/zi/
|
||||
|
@ -31,13 +31,12 @@ OPTIONS_DEFINE= DOCS
|
|||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
LUCENEVER= 6.4.1
|
||||
CONFIG_FILES= elasticsearch.yml log4j2.properties jvm.options
|
||||
BINS= elasticsearch.in.sh \
|
||||
elasticsearch \
|
||||
elasticsearch-plugin
|
||||
|
||||
DOCS= LICENSE.txt \
|
||||
PORTDOCS= LICENSE.txt \
|
||||
NOTICE.txt \
|
||||
README.textile
|
||||
|
||||
|
@ -46,20 +45,9 @@ SEARCHUSER?= elasticsearch
|
|||
SEARCHGROUP?= ${SEARCHUSER}
|
||||
USERS= ${SEARCHUSER}
|
||||
GROUPS= ${SEARCHGROUP}
|
||||
ELASTIC_DBDIR= /var/db/elasticsearch
|
||||
ELASTIC_LOGDIR= /var/log/elasticsearch
|
||||
|
||||
SUB_LIST= SEARCHUSER=${SEARCHUSER} \
|
||||
SEARCHGROUP=${SEARCHGROUP} \
|
||||
PORTVERSION=${PORTVERSION} \
|
||||
JAVA=${JAVA}
|
||||
SUB_LIST= ETCDIR=${ETCDIR} JAVA=${JAVA}
|
||||
SUB_FILES= pkg-message
|
||||
PLIST_SUB+= SEARCHUSER=${SEARCHUSER} \
|
||||
SEARCHGROUP=${SEARCHGROUP} \
|
||||
LUCENEVER=${LUCENEVER} \
|
||||
PORTVERSION=${PORTVERSION} \
|
||||
ELASTIC_DBDIR=${ELASTIC_DBDIR} \
|
||||
ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
|
||||
|
@ -67,28 +55,37 @@ post-patch:
|
|||
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
|
||||
.for f in ${CONFIG_FILES}
|
||||
${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
|
||||
${INSTALL} ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
|
||||
.endfor
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
|
||||
.for f in ${BINS}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
|
||||
.endfor
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
|
||||
(cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/ "-name *\.jar")
|
||||
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules
|
||||
(cd ${WRKSRC}/modules && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules/)
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
|
||||
@${MKDIR} ${STAGEDIR}${ELASTIC_DBDIR} ${STAGEDIR}${ELASTIC_LOGDIR}
|
||||
cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin elasticsearch-plugin
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
|
||||
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${DOCS}
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${PORTDOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
${ECHO} "@sample ${ETCDIR}/elasticsearch.yml.sample" >> ${TMPPLIST}
|
||||
${ECHO} "@sample ${ETCDIR}/log4j2.properties.sample" >> ${TMPPLIST}
|
||||
${ECHO} "@sample ${ETCDIR}/jvm.options.sample" >> ${TMPPLIST}
|
||||
${ECHO} "bin/elasticsearch-plugin" >> ${TMPPLIST}
|
||||
${FIND} -s ${STAGEDIR}${PREFIX}/lib/elasticsearch -not -type d | ${SORT} | \
|
||||
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
|
||||
${ECHO} "@dir lib/elasticsearch/plugins" >> ${TMPPLIST}
|
||||
${ECHO} "@dir libexec/elasticsearch" >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491415113
|
||||
SHA256 (elasticsearch-5.3.0.tar.gz) = effd922973e9f4fe25565e0a194a4b534c08b22849f03cb9fea13c311401e21b
|
||||
SIZE (elasticsearch-5.3.0.tar.gz) = 33696963
|
||||
TIMESTAMP = 1519308932
|
||||
SHA256 (elasticsearch-5.6.8.tar.gz) = 898d09deaea284e769dc49b6f90473472cab9795a9d37d51c407ce376b63d90c
|
||||
SIZE (elasticsearch-5.6.8.tar.gz) = 33781024
|
||||
|
|
|
@ -75,6 +75,7 @@ if [ -n "$2" ]; then
|
|||
export ES_JVM_OPTIONS=${elasticsearch_config}/jvm.options
|
||||
fi
|
||||
command_args="-d --pidfile=${pidfile} -Epath.conf=${elasticsearch_config}"
|
||||
echo "===> elasticsearch profile: ${profile}"
|
||||
else
|
||||
echo "$0: extra argument ignored"
|
||||
fi
|
||||
|
@ -101,7 +102,6 @@ else
|
|||
continue
|
||||
;;
|
||||
esac
|
||||
echo "===> elasticsearch profile: ${profile}"
|
||||
%%PREFIX%%/etc/rc.d/elasticsearch $1 ${profile}
|
||||
retcode="$?"
|
||||
if [ "0${retcode}" -ne 0 ]; then
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- bin/elasticsearch.orig 2016-12-02 11:42:56 UTC
|
||||
--- bin/elasticsearch.orig 2018-02-22 23:11:44 UTC
|
||||
+++ bin/elasticsearch
|
||||
@@ -112,7 +112,7 @@ ES_HOME=`cd "$ES_HOME"; pwd`
|
||||
|
||||
if [ -z "$ES_JVM_OPTIONS" ]; then
|
||||
for jvm_options in "$ES_HOME"/config/jvm.options \
|
||||
- /etc/elasticsearch/jvm.options; do
|
||||
+ %%PREFIX%%/etc/elasticsearch/jvm.options; do
|
||||
+ /usr/local/etc/elasticsearch/jvm.options; do
|
||||
if [ -r "$jvm_options" ]; then
|
||||
ES_JVM_OPTIONS=$jvm_options
|
||||
break
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- config/elasticsearch.yml.orig 2016-11-24 10:05:27 UTC
|
||||
--- config/elasticsearch.yml.orig 2018-02-16 16:43:35 UTC
|
||||
+++ config/elasticsearch.yml
|
||||
@@ -31,10 +31,15 @@
|
||||
# Path to directory where to store the data (separate multiple locations by comma):
|
||||
|
@ -16,3 +16,10 @@
|
|||
#
|
||||
# ----------------------------------- Memory -----------------------------------
|
||||
#
|
||||
@@ -86,3 +91,6 @@
|
||||
# Require explicit names when deleting indices:
|
||||
#
|
||||
#action.destructive_requires_name: true
|
||||
+
|
||||
+# Required on non-Linux platforms
|
||||
+bootstrap.system_call_filter: false
|
||||
|
|
|
@ -3,4 +3,22 @@
|
|||
Please see %%ETCDIR%% for sample versions of
|
||||
elasticsearch.yml and logging.yml.
|
||||
|
||||
ElasticSearch requires memory locking of large amounts of RAM.
|
||||
You will either need to set:
|
||||
|
||||
sysrc elasticsearch_login_class="root"
|
||||
|
||||
or
|
||||
|
||||
sysctl security.bsd.unprivileged_mlock=1
|
||||
|
||||
to prevent the process from failing the bootstrap.
|
||||
|
||||
Do note that you need to set
|
||||
|
||||
bootstrap.system_call_filter: false
|
||||
|
||||
in your elasticsearch.yml file to successfully bootstrap on non-Linux
|
||||
OSes now.
|
||||
|
||||
======================================================================
|
||||
|
|
|
@ -1,108 +0,0 @@
|
|||
@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/elasticsearch.yml.sample
|
||||
@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/log4j2.properties.sample
|
||||
@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/jvm.options.sample
|
||||
@unexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
|
||||
@unexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
|
||||
bin/elasticsearch-plugin
|
||||
lib/elasticsearch/lib/HdrHistogram-2.1.6.jar
|
||||
lib/elasticsearch/lib/elasticsearch-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/lib/hppc-0.7.1.jar
|
||||
lib/elasticsearch/lib/jackson-core-2.8.6.jar
|
||||
lib/elasticsearch/lib/jackson-dataformat-cbor-2.8.6.jar
|
||||
lib/elasticsearch/lib/jackson-dataformat-smile-2.8.6.jar
|
||||
lib/elasticsearch/lib/jackson-dataformat-yaml-2.8.6.jar
|
||||
lib/elasticsearch/lib/java-version-checker-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/lib/jna-4.2.2.jar
|
||||
lib/elasticsearch/lib/joda-time-2.9.5.jar
|
||||
lib/elasticsearch/lib/jopt-simple-5.0.2.jar
|
||||
lib/elasticsearch/lib/jts-1.13.jar
|
||||
lib/elasticsearch/lib/log4j-1.2-api-2.7.jar
|
||||
lib/elasticsearch/lib/log4j-api-2.7.jar
|
||||
lib/elasticsearch/lib/log4j-core-2.7.jar
|
||||
lib/elasticsearch/lib/lucene-analyzers-common-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-backward-codecs-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-core-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-grouping-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-highlighter-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-join-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-memory-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-misc-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-queries-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-queryparser-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-sandbox-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-spatial-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-spatial-extras-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-spatial3d-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/lucene-suggest-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/lib/securesm-1.1.jar
|
||||
lib/elasticsearch/lib/snakeyaml-1.15.jar
|
||||
lib/elasticsearch/lib/spatial4j-0.6.jar
|
||||
lib/elasticsearch/lib/t-digest-3.0.jar
|
||||
lib/elasticsearch/bin/elasticsearch.in.sh
|
||||
lib/elasticsearch/bin/elasticsearch
|
||||
lib/elasticsearch/bin/elasticsearch-plugin
|
||||
lib/elasticsearch/modules/aggs-matrix-stats/aggs-matrix-stats-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/aggs-matrix-stats/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/ingest-common/ingest-common-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/ingest-common/jcodings-1.0.12.jar
|
||||
lib/elasticsearch/modules/ingest-common/joni-2.1.6.jar
|
||||
lib/elasticsearch/modules/ingest-common/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/lang-expression/antlr4-runtime-4.5.1-1.jar
|
||||
lib/elasticsearch/modules/lang-expression/asm-5.0.4.jar
|
||||
lib/elasticsearch/modules/lang-expression/asm-commons-5.0.4.jar
|
||||
lib/elasticsearch/modules/lang-expression/asm-tree-5.0.4.jar
|
||||
lib/elasticsearch/modules/lang-expression/lang-expression-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/lang-expression/lucene-expressions-%%LUCENEVER%%.jar
|
||||
lib/elasticsearch/modules/lang-expression/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/lang-expression/plugin-security.policy
|
||||
lib/elasticsearch/modules/lang-groovy/groovy-2.4.6-indy.jar
|
||||
lib/elasticsearch/modules/lang-groovy/lang-groovy-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/lang-groovy/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/lang-groovy/plugin-security.policy
|
||||
lib/elasticsearch/modules/lang-mustache/compiler-0.9.3.jar
|
||||
lib/elasticsearch/modules/lang-mustache/lang-mustache-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/lang-mustache/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/lang-mustache/plugin-security.policy
|
||||
lib/elasticsearch/modules/lang-painless/antlr4-runtime-4.5.1-1.jar
|
||||
lib/elasticsearch/modules/lang-painless/asm-debug-all-5.1.jar
|
||||
lib/elasticsearch/modules/lang-painless/lang-painless-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/lang-painless/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/lang-painless/plugin-security.policy
|
||||
lib/elasticsearch/modules/percolator/percolator-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/percolator/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/reindex/commons-codec-1.10.jar
|
||||
lib/elasticsearch/modules/reindex/commons-logging-1.1.3.jar
|
||||
lib/elasticsearch/modules/reindex/httpasyncclient-4.1.2.jar
|
||||
lib/elasticsearch/modules/reindex/httpclient-4.5.2.jar
|
||||
lib/elasticsearch/modules/reindex/httpcore-4.4.5.jar
|
||||
lib/elasticsearch/modules/reindex/httpcore-nio-4.4.5.jar
|
||||
lib/elasticsearch/modules/reindex/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/reindex/reindex-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/reindex/rest-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/transport-netty3/netty-3.10.6.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty3/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/transport-netty3/plugin-security.policy
|
||||
lib/elasticsearch/modules/transport-netty3/transport-netty3-%%PORTVERSION%%.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-buffer-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-codec-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-codec-http-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-common-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-handler-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-resolver-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/netty-transport-4.1.7.Final.jar
|
||||
lib/elasticsearch/modules/transport-netty4/plugin-descriptor.properties
|
||||
lib/elasticsearch/modules/transport-netty4/plugin-security.policy
|
||||
lib/elasticsearch/modules/transport-netty4/transport-netty4-%%PORTVERSION%%.jar
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.textile
|
||||
@dir lib/elasticsearch/lib
|
||||
@dir lib/elasticsearch/bin
|
||||
@dir lib/elasticsearch/modules
|
||||
@dir lib/elasticsearch/plugins
|
||||
@dir lib/elasticsearch
|
||||
@dir libexec/elasticsearch
|
||||
@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_LOGDIR%%
|
||||
@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_DBDIR%%
|
||||
@postunexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
|
||||
@postunexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi
|
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= x-pack
|
||||
PORTVERSION= 5.3.0
|
||||
PORTVERSION= 5.6.8
|
||||
CATEGORIES= textproc java
|
||||
MASTER_SITES= https://artifacts.elastic.co/downloads/packs/x-pack/
|
||||
PKGNAMEPREFIX= kibana5-
|
||||
|
@ -10,18 +10,22 @@ PKGNAMEPREFIX= kibana5-
|
|||
MAINTAINER= tj@FreeBSD.org
|
||||
COMMENT= Kibana 5.0 X-Pack plugins
|
||||
|
||||
RUN_DEPENDS:= kibana5>=5.3.0:textproc/kibana5
|
||||
RUN_DEPENDS:= kibana5>=5.6.8:textproc/kibana5
|
||||
|
||||
NO_BUILD= yes
|
||||
|
||||
USES+= zip
|
||||
|
||||
do-extract:
|
||||
@${MKDIR} ${WRKSRC}
|
||||
${MKDIR} ${WRKSRC}
|
||||
( cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} -d ${PORTNAME}-${PORTVERSION} \
|
||||
${_DISTDIR}${DISTFILES} )
|
||||
|
||||
do-install:
|
||||
@cd ${WRKSRC}/kibana && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/www/kibana5/plugins
|
||||
cd ${WRKSRC}/kibana && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/www/kibana5/plugins
|
||||
|
||||
post-install:
|
||||
@${FIND} -s ${STAGEDIR}${PREFIX}/www/kibana5/plugins/x-pack -not -type d | ${SORT} | \
|
||||
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491441074
|
||||
SHA256 (x-pack-5.3.0.zip) = 5580d907774e558a8ee23680962c26e745979202974cab12a3b445b31dc37fd4
|
||||
SIZE (x-pack-5.3.0.zip) = 126084986
|
||||
TIMESTAMP = 1519316123
|
||||
SHA256 (x-pack-5.6.8.zip) = 5aa106af78bf5f37e574415aeba62bb93afcc2d9faffb60a883ce233ac4bc426
|
||||
SIZE (x-pack-5.6.8.zip) = 160447245
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -2,9 +2,9 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= kibana
|
||||
PORTVERSION= 5.3.0
|
||||
PORTVERSION= 5.6.8
|
||||
DISTVERSIONSUFFIX= -linux-x86
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= textproc www
|
||||
MASTER_SITES= https://artifacts.elastic.co/downloads/kibana/ \
|
||||
http://artifacts.elastic.co/downloads/kibana/
|
||||
|
@ -24,12 +24,22 @@ NO_ARCH= yes
|
|||
WWWDIR= ${PREFIX}/www/${PORTNAME}${PKGNAMESUFFIX}
|
||||
USE_RC_SUBR= ${PORTNAME}
|
||||
|
||||
SUB_FILES= pkg-deinstall
|
||||
|
||||
do-install:
|
||||
${CP} ${WRKSRC}/config/kibana.yml ${STAGEDIR}${PREFIX}/etc/kibana.yml.sample
|
||||
${MKDIR} ${STAGEDIR}${WWWDIR}
|
||||
${MKDIR} ${STAGEDIR}${WWWDIR} ${STAGEDIR}${WWWDIR}/optimize
|
||||
cd ${WRKSRC} && \
|
||||
${RM} -r bin config node && \
|
||||
${RM} -r optimize/* && \
|
||||
${RM} -r optimize && \
|
||||
${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
|
||||
|
||||
post-install:
|
||||
${ECHO} "@sample etc/kibana.yml.sample" >> ${TMPPLIST}
|
||||
${FIND} -s ${STAGEDIR}${WWWDIR} -not -type d | ${SORT} | \
|
||||
${SED} -e 's#^${STAGEDIR}${PREFIX}/##' >> ${TMPPLIST}
|
||||
${ECHO} "@dir(www,www) ${WWWDIR}/data" >> ${TMPPLIST}
|
||||
${ECHO} "@dir ${WWWDIR}/plugins" >> ${TMPPLIST}
|
||||
${ECHO} "@dir ${WWWDIR}/src/ui/public/factories" >> ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1491436040
|
||||
SHA256 (kibana-5.3.0-linux-x86.tar.gz) = eddc77334032ed30f98289715781d01e7677d598cf4a3ad5595618cc057a8bfc
|
||||
SIZE (kibana-5.3.0-linux-x86.tar.gz) = 38354255
|
||||
TIMESTAMP = 1519315963
|
||||
SHA256 (kibana-5.6.8-linux-x86.tar.gz) = 5bc64ceb2c94f0494dac94db954b478b83d7944a93423a9db783f62f9106f0e8
|
||||
SIZE (kibana-5.6.8-linux-x86.tar.gz) = 51412784
|
||||
|
|
|
@ -30,13 +30,16 @@ command_args="-f -p ${pidfile} env BABEL_DISABLE_CACHE=1 ${procname} %%WWWDIR%%/
|
|||
kibana_precmd()
|
||||
{
|
||||
if [ ! -d $(dirname ${pidfile}) ]; then
|
||||
mkdir $(dirname ${pidfile})
|
||||
chown ${kibana_user}:${kibana_group} $(dirname ${pidfile})
|
||||
install -d -o ${kibana_user} -g ${kibana_group} $(dirname ${pidfile})
|
||||
fi
|
||||
|
||||
if [ ! -f ${kibana_log} ]; then
|
||||
install -o ${kibana_user} -g ${kibana_group} -m 640 /dev/null ${kibana_log}
|
||||
fi
|
||||
|
||||
if [ ! -d %%WWWDIR%%/optimize ]; then
|
||||
install -d -o ${kibana_user} -g ${kibana_group} %%WWWDIR%%/optimize
|
||||
fi
|
||||
}
|
||||
|
||||
run_rc_command "$1"
|
||||
|
|
9
textproc/kibana5/files/pkg-deinstall.in
Normal file
9
textproc/kibana5/files/pkg-deinstall.in
Normal file
|
@ -0,0 +1,9 @@
|
|||
#!/bin/sh
|
||||
|
||||
case "$2" in
|
||||
POST-DEINSTALL)
|
||||
if [ -d %%WWWDIR%%/optimize ]; then
|
||||
/usr/bin/find %%WWWDIR%%/optimize/ -delete
|
||||
fi
|
||||
;;
|
||||
esac
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue