textproc/py-wstools: update to 0.4.4
This commit is contained in:
parent
90ee58e55a
commit
8717b0418e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420557
3 changed files with 32 additions and 7 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= wstools
|
||||
PORTVERSION= 0.4.3
|
||||
PORTVERSION= 0.4.4
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -12,11 +12,10 @@ COMMENT= WSDL parsing services for Python
|
|||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/docs/license.txt
|
||||
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
|
||||
|
||||
NO_ARCH= yes
|
||||
USES= python:2
|
||||
USES= python:2.7+
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e "s|'docutils'||g" ${WRKSRC}/setup.py
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,3 @@
|
|||
SHA256 (wstools-0.4.3.tar.gz) = 578b53e98bc8dadf5a55dfd1f559fd9b37a594609f1883f23e8646d2d30336f8
|
||||
SIZE (wstools-0.4.3.tar.gz) = 148878
|
||||
TIMESTAMP = 1469274489
|
||||
SHA256 (wstools-0.4.4.tar.gz) = 000cca12538e30547d4655ce84ef4977dabfc65a7b27d28e319695b78aa40126
|
||||
SIZE (wstools-0.4.4.tar.gz) = 53813
|
||||
|
|
25
textproc/py-wstools/files/patch-setup.py
Normal file
25
textproc/py-wstools/files/patch-setup.py
Normal file
|
@ -0,0 +1,25 @@
|
|||
To be upstreamed: remove dependencies, not actually required to
|
||||
use the library.
|
||||
|
||||
--- setup.py.orig 2016-07-22 12:01:01 UTC
|
||||
+++ setup.py
|
||||
@@ -129,7 +129,8 @@ class PreRelease(Command):
|
||||
raise RuntimeError(
|
||||
"Current version of the package is equal or lower than the already published ones (PyPi). Increse version to be able to pass prerelease stage.")
|
||||
|
||||
-requires = ['autopep8', 'six', 'pep8', 'pytest-cov', 'pytest-pep8', 'setuptools', 'pytest', 'pytest-timeout']
|
||||
+requires = ['six', 'setuptools']
|
||||
+tests_requires = ['autopep8', 'six', 'pep8', 'pytest-cov', 'pytest-pep8', 'setuptools', 'pytest', 'pytest-timeout']
|
||||
|
||||
setup(
|
||||
name=NAME,
|
||||
@@ -137,8 +138,7 @@ setup(
|
||||
cmdclass={'test': PyTest, 'release': Release, 'prerelease': PreRelease},
|
||||
packages=find_packages(exclude=['tests']),
|
||||
include_package_data=True,
|
||||
- tests_require=requires,
|
||||
- setup_requires=requires,
|
||||
+ tests_require=tests_requires,
|
||||
install_requires=requires,
|
||||
|
||||
license='BSD',
|
Loading…
Reference in a new issue