update to 1.59, temporarily switching to the bundled tinyxml2
Feature safe: yes
This commit is contained in:
parent
8ad807efb3
commit
874fe272e3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=316027
3 changed files with 8 additions and 19 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cppcheck
|
||||
PORTVERSION= 1.58
|
||||
PORTVERSION= 1.59
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
|
||||
|
||||
|
@ -11,14 +11,14 @@ COMMENT= Static analysis of C/C++ code
|
|||
|
||||
LICENSE= GPLv3
|
||||
|
||||
LIB_DEPENDS= tinyxml:${PORTSDIR}/textproc/tinyxml
|
||||
#LIB_DEPENDS= tinyxml:${PORTSDIR}/textproc/tinyxml
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
ALL_TARGET= cppcheck
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
MAKE_ENV+= TINYXML=-ltinyxml
|
||||
#MAKE_ENV+= TINYXML=-ltinyxml
|
||||
|
||||
OPTIONS_DEFINE= MATCHCOMPILER RULES
|
||||
OPTIONS_DEFAULT= MATCHCOMPILER RULES
|
||||
|
@ -53,9 +53,9 @@ MAKE_ENV+= HAVE_RULES=yes
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|-Iexternals/tinyxml|-I${LOCALBASE}/include|' \
|
||||
${WRKSRC}/Makefile
|
||||
# @${REINPLACE_CMD} \
|
||||
# -e 's|-Iexternals/tinyxml|-I${LOCALBASE}/include|' \
|
||||
# ${WRKSRC}/Makefile
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
@${REINPLACE_CMD} -e '\|DB2MAN=|d' \
|
||||
${WRKSRC}/Makefile
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (cppcheck-1.58.tar.bz2) = d82e98f83ad9fa963d8f9f72d73b409abe13a35aaf302a86a0114a161715b19b
|
||||
SIZE (cppcheck-1.58.tar.bz2) = 1230439
|
||||
SHA256 (cppcheck-1.59.tar.bz2) = 6be40d8422c545959d1cc44ce3f80be9f6d3d18f70d65b8d2e1b65284aa38f6e
|
||||
SIZE (cppcheck-1.59.tar.bz2) = 1243616
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- cli/cmdlineparser.cpp.orig 2011-12-10 07:00:45.000000000 -0500
|
||||
+++ cli/cmdlineparser.cpp 2011-12-10 22:32:04.000000000 -0500
|
||||
@@ -557,7 +557,7 @@
|
||||
TiXmlDocument doc;
|
||||
if (doc.LoadFile(12+argv[i])) {
|
||||
TiXmlElement *node = doc.FirstChildElement();
|
||||
- for (; node && node->ValueStr() == "rule"; node = node->NextSiblingElement()) {
|
||||
+ for (; node && node->Value() == "rule"; node = node->NextSiblingElement()) {
|
||||
Settings::Rule rule;
|
||||
|
||||
TiXmlElement *pattern = node->FirstChildElement("pattern");
|
Loading…
Reference in a new issue