devel/py-pytest-timeout: Update to 1.3.2
Changelog:
fe7aed2520
- Update PORTVERSION and distinfo checksum to 1.3.2
- Remove patch-setup.py, it has been merged into 1.3.2
- Pet portlint
Reviewed by: koobs
Approved by: koobs (mentor)
Differential Revision: https://reviews.freebsd.org/D17188
This commit is contained in:
parent
dfdd382061
commit
877de53329
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=479934
3 changed files with 6 additions and 23 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pytest-timeout
|
||||
PORTVERSION= 1.3.1
|
||||
PORTVERSION= 1.3.2
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -17,11 +17,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.6.0:devel/py-pytest@${PY_FLAVOR}
|
|||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.6.0:devel/py-pytest@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR}
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
USES= python
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
NO_ARCH= yes
|
||||
|
||||
TEST_ENV+= PYTHONPATH=${TEST_WRKSRC}
|
||||
do-test:
|
||||
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1533178931
|
||||
SHA256 (pytest-timeout-1.3.1.tar.gz) = 4b261bec5782b603c98b4bb803484bc96bf1cdcb5480dae0999d21c7e0423a23
|
||||
SIZE (pytest-timeout-1.3.1.tar.gz) = 11412
|
||||
TIMESTAMP = 1537024791
|
||||
SHA256 (pytest-timeout-1.3.2.tar.gz) = 1117fc0536e1638862917efbdc0895e6b62fa61e6cf4f39bb655686af7af9627
|
||||
SIZE (pytest-timeout-1.3.2.tar.gz) = 11494
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
https://bitbucket.org/pytest-dev/pytest-timeout/pull-requests/15/use-utf-8-encoding-to-open-the-readme-file/
|
||||
|
||||
--- setup.py.orig 2018-08-02 04:04:34 UTC
|
||||
+++ setup.py
|
||||
@@ -1,10 +1,11 @@
|
||||
from setuptools import setup
|
||||
+import io
|
||||
|
||||
|
||||
setup(
|
||||
name='pytest-timeout',
|
||||
description='py.test plugin to abort hanging tests',
|
||||
- long_description=open("README").read(),
|
||||
+ long_description=io.open('README', encoding='utf-8').read(),
|
||||
version='1.3.1',
|
||||
author='Floris Bruynooghe',
|
||||
author_email='flub@devork.be',
|
Loading…
Reference in a new issue