New port: x11-wm/wmconfig, X window manager menu generation tool
This is the port of Wmconfig, a X window manager menu generation tool. PR: ports/55672 Submitted by: Tommy Scheunemann <net@arrishq.org>
This commit is contained in:
parent
f6a904c04f
commit
8787572f90
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=97179
6 changed files with 67 additions and 0 deletions
|
@ -98,6 +98,7 @@
|
||||||
SUBDIR += wmDeskGuide
|
SUBDIR += wmDeskGuide
|
||||||
SUBDIR += wmakerconf
|
SUBDIR += wmakerconf
|
||||||
SUBDIR += wmanager
|
SUBDIR += wmanager
|
||||||
|
SUBDIR += wmconfig
|
||||||
SUBDIR += wmg
|
SUBDIR += wmg
|
||||||
SUBDIR += wmthemeinstall
|
SUBDIR += wmthemeinstall
|
||||||
SUBDIR += wmx
|
SUBDIR += wmx
|
||||||
|
|
38
x11-wm/wmconfig/Makefile
Normal file
38
x11-wm/wmconfig/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
# New ports collection makefile for: wmconfig
|
||||||
|
# Whom: Tommy Scheunemann <net@arrishq.org>
|
||||||
|
# Date created: 17 August 2003
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= wmconfig
|
||||||
|
PORTVERSION= 1.0
|
||||||
|
CATEGORIES= x11-wm
|
||||||
|
MASTER_SITES= http://www.arrishq.org/downloads/
|
||||||
|
|
||||||
|
MAINTAINER= net@arrishq.org
|
||||||
|
COMMENT= Menu generation tool for X window managers
|
||||||
|
|
||||||
|
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||||
|
HAS_CONFIGURE= yes
|
||||||
|
|
||||||
|
CONFIGURE_ARGS= --prefix=${LOCALBASE} --sysconfdir=${LOCALBASE}/etc --mandir=${LOCALBASE}/man
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||||
|
@${INSTALL_MAN} ${WRKSRC}/wmconfig.1x ${PREFIX}/man/man1
|
||||||
|
@${MKDIR} ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/xterm ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/xmms ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/xearth ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/vim ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/sylpheed ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/rxvt ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/pine ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/mozilla ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/lynx ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/gv ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/gimp ${PREFIX}/etc/wmconfig
|
||||||
|
@${INSTALL_DATA} ${WRKSRC}/samples/eterm ${PREFIX}/etc/wmconfig
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
1
x11-wm/wmconfig/distinfo
Normal file
1
x11-wm/wmconfig/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (wmconfig-1.0.tar.gz) = 1b9848578c92bc1451d95f0d663aa8f0
|
5
x11-wm/wmconfig/files/patch-wmconfig.h
Normal file
5
x11-wm/wmconfig/files/patch-wmconfig.h
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
--- wmconfig.h.orig Sat Aug 17 16:42:47 2003
|
||||||
|
+++ wmconfig.h Sun Aug 18 16:59:38 2003
|
||||||
|
@@ -30 +30 @@
|
||||||
|
-#define DEFAULT_SYS_CONFDIR "/etc/X11/wmconfig"
|
||||||
|
+#define DEFAULT_SYS_CONFDIR "/usr/local/etc/wmconfig"
|
7
x11-wm/wmconfig/pkg-descr
Normal file
7
x11-wm/wmconfig/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
||||||
|
Wmconfig is a free menu generation tool for various X window managers.
|
||||||
|
It is easy-to-use and uses a simple configuration file layout.
|
||||||
|
|
||||||
|
WWW: http://www.arrishq.org
|
||||||
|
|
||||||
|
- Tommy Scheunemann
|
||||||
|
net@arrishq.org
|
15
x11-wm/wmconfig/pkg-plist
Normal file
15
x11-wm/wmconfig/pkg-plist
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
man/man1/wmconfig.1x
|
||||||
|
bin/wmconfig
|
||||||
|
etc/wmconfig/xterm
|
||||||
|
etc/wmconfig/xmms
|
||||||
|
etc/wmconfig/xearth
|
||||||
|
etc/wmconfig/vim
|
||||||
|
etc/wmconfig/sylpheed
|
||||||
|
etc/wmconfig/rxvt
|
||||||
|
etc/wmconfig/pine
|
||||||
|
etc/wmconfig/mozilla
|
||||||
|
etc/wmconfig/lynx
|
||||||
|
etc/wmconfig/gv
|
||||||
|
etc/wmconfig/gimp
|
||||||
|
etc/wmconfig/eterm
|
||||||
|
@dirrm etc/wmconfig
|
Loading…
Reference in a new issue