- Unbreak this port
- Support STAGEDIR - Remove unnecessary WRKSRC - Update GRASS_INST_DIR - Bump PORTREVISION - Cosmetic change
This commit is contained in:
parent
24f090fbbc
commit
8789ba43f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=360548
2 changed files with 30 additions and 24 deletions
|
@ -3,40 +3,32 @@
|
|||
|
||||
PORTNAME= gdal-grass
|
||||
PORTVERSION= 1.4.3
|
||||
PORTREVISION= 13
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://download.osgeo.org/gdal/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= GDAL drivers for GRASS raster and vector files
|
||||
|
||||
BROKEN= Fails to configure
|
||||
LICENSE= MIT
|
||||
|
||||
BUILD_DEPENDS= grass>6:${PORTSDIR}/databases/grass
|
||||
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
|
||||
RUN_DEPENDS= grass>6:${PORTSDIR}/databases/grass
|
||||
BUILD_DEPENDS= grass>=6:${PORTSDIR}/databases/grass
|
||||
LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal \
|
||||
libgrass_gis.so:${PORTSDIR}/databases/grass
|
||||
RUN_DEPENDS= grass>=6:${PORTSDIR}/databases/grass
|
||||
|
||||
GRASS_INST_DIR= grass-6.4.2
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
USES= gmake
|
||||
ALL_TARGET= # empty
|
||||
CONFIGURE_ARGS= --with-autoload=${PREFIX}/lib/gdalplugins \
|
||||
--with-gdal=${LOCALBASE}/bin/gdal-config \
|
||||
--with-grass=${LOCALBASE}/${GRASS_INST_DIR}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-gdal=${LOCALBASE}/bin/gdal-config \
|
||||
--with-grass=${LOCALBASE}/${GRASS_INST_DIR} \
|
||||
--with-autoload=${GDAL_AUTOLOAD_DIR}
|
||||
ALL_TARGET=
|
||||
NO_STAGE= yes
|
||||
USE_GCC= yes # from databases/grass
|
||||
USES= gmake
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
GRASS_INST_DIR!=${MAKE} -C ${.CURDIR}/../../databases/grass/ -V GRASS_INST_DIR
|
||||
|
||||
pre-install:
|
||||
${MKDIR} ${PREFIX}/share/gdal
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gdalplugins/
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/share/gdal/
|
||||
|
||||
.if !defined(GDAL_AUTOLOAD_DIR)
|
||||
GDAL_AUTOLOAD_DIR=${PREFIX}/lib/gdalplugins
|
||||
.endif
|
||||
|
||||
.if !defined (GRASS_INST_DIR)
|
||||
GRASS_INST_DIR= grass
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
14
graphics/gdal-grass/files/patch-Makefile.in
Normal file
14
graphics/gdal-grass/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- Makefile.in.orig 2007-08-06 05:54:24.000000000 +0800
|
||||
+++ Makefile.in 2014-07-04 10:44:22.506228799 +0800
|
||||
@@ -13,9 +13,9 @@
|
||||
|
||||
LIBS = @LIBS@
|
||||
|
||||
-GRASSTABLES_DIR = @prefix@/share/gdal/grass
|
||||
+GRASSTABLES_DIR = $(DESTDIR)@prefix@/share/gdal/grass
|
||||
|
||||
-AUTOLOAD_DIR = @AUTOLOAD_DIR@
|
||||
+AUTOLOAD_DIR = $(DESTDIR)@AUTOLOAD_DIR@
|
||||
|
||||
GLIBNAME = gdal_GRASS.so
|
||||
OLIBNAME = ogr_GRASS.so
|
Loading…
Reference in a new issue