diff --git a/devel/libdbusmenu/Makefile b/devel/libdbusmenu/Makefile
index e708dc4f7999..2136233d58c1 100644
--- a/devel/libdbusmenu/Makefile
+++ b/devel/libdbusmenu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libdbusmenu
PORTVERSION= 16.04.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= https://launchpadlibrarian.net/243440794/ \
https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
diff --git a/devel/libdbusmenu/files/patch-docs_libdbusmenu-glib_reference_libdbusmenu-glib-docs.sgml b/devel/libdbusmenu/files/patch-docs_libdbusmenu-glib_reference_libdbusmenu-glib-docs.sgml
new file mode 100644
index 000000000000..6b0cc4f857e4
--- /dev/null
+++ b/devel/libdbusmenu/files/patch-docs_libdbusmenu-glib_reference_libdbusmenu-glib-docs.sgml
@@ -0,0 +1,13 @@
+--- docs/libdbusmenu-glib/reference/libdbusmenu-glib-docs.sgml.orig 2016-02-27 18:58:43 UTC
++++ docs/libdbusmenu-glib/reference/libdbusmenu-glib-docs.sgml
+@@ -18,10 +18,6 @@
+
+
+
+-
+- Object Hierarchy
+-
+-
+
+ API Index
+
diff --git a/devel/libdbusmenu/files/patch-docs_libdbusmenu-gtk_reference_libdbusmenu-gtk-docs.sgml b/devel/libdbusmenu/files/patch-docs_libdbusmenu-gtk_reference_libdbusmenu-gtk-docs.sgml
new file mode 100644
index 000000000000..f2b9d4df7f1f
--- /dev/null
+++ b/devel/libdbusmenu/files/patch-docs_libdbusmenu-gtk_reference_libdbusmenu-gtk-docs.sgml
@@ -0,0 +1,13 @@
+--- docs/libdbusmenu-gtk/reference/libdbusmenu-gtk-docs.sgml.orig 2016-02-27 18:58:43 UTC
++++ docs/libdbusmenu-gtk/reference/libdbusmenu-gtk-docs.sgml
+@@ -17,10 +17,6 @@
+
+
+
+-
+- Object Hierarchy
+-
+-
+
+ API Index
+
diff --git a/devel/libdbusmenu/pkg-plist b/devel/libdbusmenu/pkg-plist
index 8b143915642d..141a4aabb128 100644
--- a/devel/libdbusmenu/pkg-plist
+++ b/devel/libdbusmenu/pkg-plist
@@ -38,7 +38,6 @@ share/gir-1.0/DbusmenuGtk3-%%VERSION%%.gir
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/libdbusmenu-glib-DbusmenuServer.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/libdbusmenu-glib-Types.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/libdbusmenu-glib.devhelp2
-%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/object-tree.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/right-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/right.png
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-glib/style.css
@@ -57,7 +56,6 @@ share/gir-1.0/DbusmenuGtk3-%%VERSION%%.gir
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/libdbusmenu-gtk-menuitem.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/libdbusmenu-gtk-parser.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/libdbusmenu-gtk.devhelp2
-%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/object-tree.html
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/right-insensitive.png
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/right.png
%%PORTDOCS%%%%DOCSDIR%%libdbusmenu-gtk/style.css
diff --git a/textproc/gtk-doc/Makefile b/textproc/gtk-doc/Makefile
index d1ec1b913f6d..dd52c83db73e 100644
--- a/textproc/gtk-doc/Makefile
+++ b/textproc/gtk-doc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gtk-doc
-PORTVERSION= 1.29
-PORTREVISION= 1
+DISTVERSION= 1.33.1
CATEGORIES= textproc
MASTER_SITES= GNOME
@@ -13,22 +12,21 @@ COMMENT= Code documentation system, originally for GTK+
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= itstool:textproc/itstool \
- highlight:textproc/highlight \
+BUILD_DEPENDS= ${PY_PYGMENTS} \
+ docbook-xml>0:textproc/docbook-xml \
+ ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl \
+ itstool:textproc/itstool \
+ yelp-tools>=0:textproc/yelp-tools
+RUN_DEPENDS= ${PY_PYGMENTS} \
docbook-xml>0:textproc/docbook-xml \
${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl
-RUN_DEPENDS= docbook-xml>0:textproc/docbook-xml \
- highlight:textproc/highlight \
- ${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl
-USES= gettext-tools gmake gnome pathfix perl5 pkgconfig \
- python:3.4+ tar:xz
-USE_GNOME= gnomeprefix libxslt
+USES= gettext-tools gnome meson python:3.6+ pkgconfig tar:xz
+USE_GNOME= libxml2 libxslt
-DOCBOOK_VERSION= 4.1.2
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-highlight=highlight \
- --with-xml-catalog=${LOCALBASE}/share/xml/catalog.ports
+MESON_ARGS= -Dtests=false
+
+NO_ARCH= yes
post-install:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
diff --git a/textproc/gtk-doc/distinfo b/textproc/gtk-doc/distinfo
index b762d62d0a01..b22573c7df17 100644
--- a/textproc/gtk-doc/distinfo
+++ b/textproc/gtk-doc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539028527
-SHA256 (gtk-doc-1.29.tar.xz) = 14578e002496567276d310a62c9ffd6c56ee8806ce5079ffb0b81c4111f586b1
-SIZE (gtk-doc-1.29.tar.xz) = 732376
+TIMESTAMP = 1610870812
+SHA256 (gtk-doc-1.33.1.tar.xz) = a5cfed2a0b73a09b796fff80ad6d8f040ab2b2655bdc941ac207ffe6d9c10f10
+SIZE (gtk-doc-1.33.1.tar.xz) = 768896
diff --git a/textproc/gtk-doc/files/patch-help_manual_LINGUAS b/textproc/gtk-doc/files/patch-help_manual_LINGUAS
new file mode 100644
index 000000000000..c87b1069949c
--- /dev/null
+++ b/textproc/gtk-doc/files/patch-help_manual_LINGUAS
@@ -0,0 +1,21 @@
+--- help/manual/LINGUAS.orig 2021-01-17 17:54:00 UTC
++++ help/manual/LINGUAS
+@@ -0,0 +1,17 @@
++# Please keep this list sorted alphabetically.
++#
++bn_IN
++cs
++de
++el
++en_GB
++es
++fr
++gl
++gu
++pt_BR
++sl
++sv
++ta
++te
++zh_CN
+\ No newline at end of file
diff --git a/textproc/gtk-doc/files/patch-meson.build b/textproc/gtk-doc/files/patch-meson.build
new file mode 100644
index 000000000000..f9f92a6a8e19
--- /dev/null
+++ b/textproc/gtk-doc/files/patch-meson.build
@@ -0,0 +1,20 @@
+--- meson.build.orig 2020-11-17 13:56:44 UTC
++++ meson.build
+@@ -7,7 +7,7 @@ project('gtk-doc', 'c',
+ gnome = import('gnome')
+ python = import('python') # Meson new Python module https://mesonbuild.com/Python-module.html
+
+-python3 = python.find_installation('python3')
++python3 = python.find_installation()
+
+ version = meson.project_version()
+ package_name = meson.project_name()
+@@ -163,7 +163,7 @@ configure_file(
+ output: 'gtk-doc.pc',
+ configuration: gtkdoc_pc,
+ install: true,
+- install_dir: pkgconfigdir,
++ install_dir: join_paths(libdir, 'pkgconfig'),
+ )
+
+ subdir('help')
diff --git a/textproc/gtk-doc/pkg-plist b/textproc/gtk-doc/pkg-plist
index c1af4029e1e9..4bcaf8b8934a 100644
--- a/textproc/gtk-doc/pkg-plist
+++ b/textproc/gtk-doc/pkg-plist
@@ -19,6 +19,8 @@ share/aclocal/gtk-doc.m4
%%DATADIR%%/data/devhelp2.xsl
%%DATADIR%%/data/gtk-doc.flat.make
%%DATADIR%%/data/gtk-doc.make
+%%DATADIR%%/data/gtk-doc.no-xslt-flat.make
+%%DATADIR%%/data/gtk-doc.no-xslt.make
%%DATADIR%%/data/gtk-doc.xsl
%%DATADIR%%/data/home.png
%%DATADIR%%/data/left-insensitive.png
@@ -38,8 +40,12 @@ share/aclocal/gtk-doc.m4
%%DATADIR%%/python/gtkdoc/__pycache__/common.cpython-%%PYTHON_SUFFIX%%.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/config.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/config.cpython-%%PYTHON_SUFFIX%%.pyc
+%%DATADIR%%/python/gtkdoc/__pycache__/config_data.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%DATADIR%%/python/gtkdoc/__pycache__/config_data.cpython-%%PYTHON_SUFFIX%%.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/fixxref.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/fixxref.cpython-%%PYTHON_SUFFIX%%.pyc
+%%DATADIR%%/python/gtkdoc/__pycache__/highlight.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%DATADIR%%/python/gtkdoc/__pycache__/highlight.cpython-%%PYTHON_SUFFIX%%.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/md_to_db.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/md_to_db.cpython-%%PYTHON_SUFFIX%%.pyc
%%DATADIR%%/python/gtkdoc/__pycache__/mkdb.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
@@ -61,7 +67,9 @@ share/aclocal/gtk-doc.m4
%%DATADIR%%/python/gtkdoc/check.py
%%DATADIR%%/python/gtkdoc/common.py
%%DATADIR%%/python/gtkdoc/config.py
+%%DATADIR%%/python/gtkdoc/config_data.py
%%DATADIR%%/python/gtkdoc/fixxref.py
+%%DATADIR%%/python/gtkdoc/highlight.py
%%DATADIR%%/python/gtkdoc/md_to_db.py
%%DATADIR%%/python/gtkdoc/mkdb.py
%%DATADIR%%/python/gtkdoc/mkhtml.py
diff --git a/x11/cinnamon/Makefile b/x11/cinnamon/Makefile
index d45b1aa00549..aa1a841cc71c 100644
--- a/x11/cinnamon/Makefile
+++ b/x11/cinnamon/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cinnamon
PORTVERSION= 4.8.4
+PORTREVISION= 1
CATEGORIES= x11 gnome
DIST_SUBDIR= gnome
diff --git a/x11/cinnamon/pkg-plist b/x11/cinnamon/pkg-plist
index 1cf5a1ba992a..c53004e3294d 100644
--- a/x11/cinnamon/pkg-plist
+++ b/x11/cinnamon/pkg-plist
@@ -593,14 +593,14 @@ share/desktop-directories/cinnamon-utility.directory
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StScrollable.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StTable.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StTextureCache.html
+%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StTheme.html
+%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StThemeContext.html
+%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StThemeNode.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StWidget.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/StWidgetAccessible.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/annotation-glossary.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/api-index-full.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/base.html
-%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/cinnamon-st-st-theme-context.html
-%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/cinnamon-st-st-theme-node.html
-%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/cinnamon-st-st-theme.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/cinnamon-st.devhelp2
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/containers.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon-st/deprecated-api-index.html
@@ -647,6 +647,7 @@ share/desktop-directories/cinnamon-utility.directory
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonGenericContainer.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonGlobal.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonGtkEmbed.html
+%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonRecorder.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonSlicer.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonStack.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/CinnamonTrayIcon.html
@@ -661,7 +662,6 @@ share/desktop-directories/cinnamon-utility.directory
%%PORTDOCS%%share/gtk-doc/html/cinnamon/ch04.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/ch05.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/ch06.html
-%%PORTDOCS%%share/gtk-doc/html/cinnamon/cinnamon-cinnamon-recorder.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/cinnamon-cinnamon-util.html
%%PORTDOCS%%share/gtk-doc/html/cinnamon/cinnamon.devhelp2
%%PORTDOCS%%share/gtk-doc/html/cinnamon/deprecated-api-index.html
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index cdb3145dbc72..2af9fc635af7 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -2,7 +2,7 @@
PORTNAME= keybinder
PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTREVISION= 5
DISTVERSIONPREFIX= v
CATEGORIES= x11
diff --git a/x11/keybinder/files/patch-docs_keybinder-docs.sgml b/x11/keybinder/files/patch-docs_keybinder-docs.sgml
new file mode 100644
index 000000000000..9d0db8baeae8
--- /dev/null
+++ b/x11/keybinder/files/patch-docs_keybinder-docs.sgml
@@ -0,0 +1,13 @@
+--- docs/keybinder-docs.sgml.orig 2015-11-06 15:08:46 UTC
++++ docs/keybinder-docs.sgml
+@@ -21,10 +21,6 @@
+
+
+
+-
+- Object Hierarchy
+-
+-
+
+ API Index
+
diff --git a/x11/keybinder/pkg-plist b/x11/keybinder/pkg-plist
index 1e5a9036a046..5fdaa7d6f514 100644
--- a/x11/keybinder/pkg-plist
+++ b/x11/keybinder/pkg-plist
@@ -25,7 +25,6 @@ share/gir-1.0/Keybinder-0.0.gir
%%PORTDOCS%%share/gtk-doc/html/keybinder/keybinder.devhelp2
%%PORTDOCS%%share/gtk-doc/html/keybinder/left-insensitive.png
%%PORTDOCS%%share/gtk-doc/html/keybinder/left.png
-%%PORTDOCS%%share/gtk-doc/html/keybinder/object-tree.html
%%PORTDOCS%%share/gtk-doc/html/keybinder/right-insensitive.png
%%PORTDOCS%%share/gtk-doc/html/keybinder/right.png
%%PORTDOCS%%share/gtk-doc/html/keybinder/style.css