- Fix build in C++11 mode [1]
- Convert to new LIB_DEPENDS format - Convert to OPTIONSng (DOCS) - STAGE-clean PR: 182949 [1] Submitted by: dt71@gmx.com [1]
This commit is contained in:
parent
2d82f32afc
commit
87cd41d3f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=330371
3 changed files with 25 additions and 6 deletions
|
@ -12,8 +12,10 @@ COMMENT= Cross-platform C++ graphical user interface toolkit
|
|||
|
||||
LICENSE= LGPL20
|
||||
|
||||
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
|
||||
jpeg.11:${PORTSDIR}/graphics/jpeg
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
|
||||
libjpeg.so:${PORTSDIR}/graphics/jpeg
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USE_XORG= xft
|
||||
|
@ -31,16 +33,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
|||
|
||||
PORTDOCS= *
|
||||
|
||||
MAN1= fltk-config.1 fluid.1
|
||||
MAN3= fltk.3
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
prefix="${PREFIX}" ; plength=$$(($${#prefix}+10)) ; \
|
||||
${REINPLACE_CMD} -e "\|/etc/fltk|{s||${PREFIX}&|;s|10|$${plength}|;}" \
|
||||
${WRKSRC}/src/Fl_Preferences.cxx
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
post-install:
|
||||
cd ${WRKSRC}/documentation && ${MAKE} docinstall
|
||||
cd ${WRKSRC}/test && ${MAKE} install
|
||||
|
|
16
x11-toolkits/fltk/files/patch-fluid_Fl_Type.h
Normal file
16
x11-toolkits/fltk/files/patch-fluid_Fl_Type.h
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- fluid/Fl_Type.h.orig 2013-10-15 09:58:05.000000000 +0200
|
||||
+++ fluid/Fl_Type.h 2013-10-15 10:01:26.000000000 +0200
|
||||
@@ -33,10 +33,12 @@
|
||||
|
||||
void set_modflag(int mf);
|
||||
|
||||
+Fl_Widget *make_type_browser(int,int,int,int,const char *l=0);
|
||||
+
|
||||
class Fl_Type {
|
||||
|
||||
friend class Widget_Browser;
|
||||
- friend Fl_Widget *make_type_browser(int,int,int,int,const char *l=0);
|
||||
+ friend Fl_Widget *make_type_browser(int,int,int,int,const char *l);
|
||||
friend class Fl_Window_Type;
|
||||
virtual void setlabel(const char *); // virtual part of label(char*)
|
||||
|
|
@ -158,4 +158,7 @@ lib/libfltk_images.a
|
|||
lib/libfltk_images.so
|
||||
lib/libfltk_images.so.1
|
||||
lib/libfltk_images.so.1.3
|
||||
man/man1/fltk-config.1.gz
|
||||
man/man1/fluid.1.gz
|
||||
man/man3/fltk.3.gz
|
||||
@dirrm include/FL
|
||||
|
|
Loading…
Reference in a new issue