Update to 3.9.0
While here, regenerate patches. With hat: puppet
This commit is contained in:
parent
a7b4d44654
commit
884cd543bb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450361
7 changed files with 18 additions and 18 deletions
|
@ -1,8 +1,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= facter
|
||||
PORTVERSION= 3.8.0
|
||||
PORTREVISION?= 2
|
||||
PORTVERSION= 3.9.0
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= sysutils
|
||||
MASTER_SITES= http://downloads.puppetlabs.com/facter/
|
||||
|
||||
|
@ -40,7 +40,7 @@ post-patch:
|
|||
|
||||
test: build
|
||||
cd ${WRKSRC}/lib && bundle install --path vendor
|
||||
cd ${WRKSRC} && ninja test
|
||||
cd ${WRKSRC} && ${MAKE_CMD} test
|
||||
|
||||
.elif ${PKGNAMEPREFIX} == java-
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1503037047
|
||||
SHA256 (facter-3.8.0.tar.gz) = a53f1646614f774cc150e7edcca40ef2512650e1cbafdcaf0f2739969c6b59c6
|
||||
SIZE (facter-3.8.0.tar.gz) = 334042
|
||||
TIMESTAMP = 1505384928
|
||||
SHA256 (facter-3.9.0.tar.gz) = 5c80cae72e7d9457b8a0d28dfc3c030d7dbe5dc38c5418aa8f237928290ac9f7
|
||||
SIZE (facter-3.9.0.tar.gz) = 335644
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- cmake/FindCPPHOCON.cmake.orig 2017-06-27 17:42:22 UTC
|
||||
--- cmake/FindCPPHOCON.cmake.orig 2017-09-12 21:43:10 UTC
|
||||
+++ cmake/FindCPPHOCON.cmake
|
||||
@@ -1,5 +1,5 @@
|
||||
include(FindDependency)
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
--- lib/CMakeLists.txt.orig 2017-07-18 18:49:09 UTC
|
||||
--- lib/CMakeLists.txt.orig 2017-09-12 21:43:10 UTC
|
||||
+++ lib/CMakeLists.txt
|
||||
@@ -203,6 +203,11 @@ elseif ("${CMAKE_SYSTEM_NAME}" MATCHES "
|
||||
"src/facts/freebsd/dmi_resolver.cc"
|
||||
"src/facts/freebsd/networking_resolver.cc"
|
||||
@@ -189,6 +189,11 @@ elseif ("${CMAKE_SYSTEM_NAME}" MATCHES "
|
||||
"src/facts/linux/processor_resolver.cc"
|
||||
"src/facts/linux/virtualization_resolver.cc"
|
||||
"src/util/bsd/scoped_ifaddrs.cc"
|
||||
+ "src/facts/freebsd/virtualization_resolver.cc"
|
||||
+ "src/facts/freebsd/memory_resolver.cc"
|
||||
|
@ -10,5 +10,5 @@
|
|||
+ "src/facts/freebsd/zpool_resolver.cc"
|
||||
+ "src/facts/freebsd/operating_system_resolver.cc"
|
||||
)
|
||||
elseif ("${CMAKE_SYSTEM_NAME}" MATCHES "OpenBSD")
|
||||
set(LIBFACTER_PLATFORM_SOURCES
|
||||
set(LIBFACTER_PLATFORM_LIBRARIES
|
||||
${BLKID_LIBRARIES}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- lib/src/facts/posix/cache.cc.orig
|
||||
--- lib/src/facts/posix/cache.cc.orig 2017-09-12 21:43:10 UTC
|
||||
+++ lib/src/facts/posix/cache.cc
|
||||
@@ -3,7 +3,7 @@
|
||||
namespace facter { namespace facts { namespace cache {
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- lib/src/facts/posix/collection.cc.orig
|
||||
--- lib/src/facts/posix/collection.cc.orig 2017-09-12 21:43:10 UTC
|
||||
+++ lib/src/facts/posix/collection.cc
|
||||
@@ -29,6 +29,8 @@
|
||||
@@ -29,6 +29,8 @@ namespace facter { namespace facts {
|
||||
directories.emplace_back("/opt/puppetlabs/facter/facts.d");
|
||||
directories.emplace_back("/etc/facter/facts.d");
|
||||
directories.emplace_back("/etc/puppetlabs/facter/facts.d");
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- lib/src/util/config/posix/config.cc.orig
|
||||
--- lib/src/util/config/posix/config.cc.orig 2017-09-12 21:43:10 UTC
|
||||
+++ lib/src/util/config/posix/config.cc
|
||||
@@ -7,6 +7,6 @@
|
||||
@@ -7,6 +7,6 @@ namespace facter { namespace util { name
|
||||
}
|
||||
|
||||
std::string default_config_location() {
|
||||
|
|
Loading…
Reference in a new issue