multimedia/cx88: update to 1.5.4

--Fix build on -current after removal of iic_devclass
--Fix typos in help strings
--Incorporate ports tree patches since 2019
--Modernize port makefile and switch MASTER_SITES to https

PR:		264381
Approved by:	diizzy
This commit is contained in:
Jason A. Harmening 2022-06-09 22:26:32 -05:00
parent 8a0125c76e
commit 88aef5f532
11 changed files with 25 additions and 112 deletions

View file

@ -1,46 +1,45 @@
# Created by: Jason Harmening <jason.harmening@gmail.com>
PORTNAME= cx88
PORTVERSION= 1.5.3
PORTREVISION= 2
DISTVERSION= 1.5.4
CATEGORIES= multimedia
MASTER_SITES= ftp://corona.homeunix.net/ports/cx88/
MASTER_SITES= https://corona.homeunix.net/distfiles/ports/cx88/
MAINTAINER= jah@FreeBSD.org
COMMENT= Drivers for Conexant CX23880/1/2/3/5/7/8-based TV/radio capture cards
COMMENT= Drivers for Conexant CX23880x-based PCI(e) TV/radio capture cards
LICENSE= BSD2CLAUSE
LIB_DEPENDS= libjson-c.so:devel/json-c
BUILD_DEPENDS= ${LOCALBASE}/lib/libezxml.a:textproc/ezxml \
libtuner>=1.1.4:multimedia/libtuner
libtuner>=1.1.5:multimedia/libtuner
# XXX static libraries with PIE are currently unsupported
MAKE_ARGS+= WITHOUT_PIE=true
MAKE_ARGS+= LIBTUNER_LIB=${LOCALBASE}/lib/libtuner LIBTUNER_HEADER=${LOCALBASE}/include/libtuner KMODDIR=${KMODDIR} PREFIX=${STAGEDIR}${PREFIX}
MAKE_ARGS+= LIBTUNER_LIB=${LOCALBASE}/lib/libtuner \
LIBTUNER_HEADER=${LOCALBASE}/include/libtuner \
KMODDIR=${KMODDIR} \
PREFIX=${STAGEDIR}${PREFIX} \
-D CX88_USE_IIC \
DEFAULT_XML_CONFIG="${EXAMPLESDIR}/cx88.xml.sample"
MAKE_JOBS_UNSAFE= yes
USES= kmod libedit pkgconfig uidfix
USE_RC_SUBR= cx88d
OPTIONS_DEFINE= DEBUG LINUX_COMPAT
OPTIONS_DEFINE= DEBUG LINUXCOMPAT VERBOSE
OPTIONS_DEFAULT= LINUXCOMPAT
DEBUG_DESC= Enable debugging and verbose driver output
LINUX_COMPAT_DESC= Support for Linux DVB and radio API
VERBOSE_DESC= Enable verbose output
LINUXCOMPAT_DESC= Support for Linux DVB and radio API
OPTIONS_DEFAULT= LINUX_COMPAT
DEBUG_IMPLIES= VERBOSE
DEBUG_MAKE_ARGS+= -DDEBUG
.include <bsd.port.options.mk>
VERBOSE_MAKE_ARGS+= DIAGNOSTIC=0x7f
.if ${PORT_OPTIONS:MDEBUG}
MAKE_ARGS+= DIAGNOSTIC=0x7f -DDEBUG
.endif
.if ${PORT_OPTIONS:MLINUX_COMPAT}
BUILD_DEPENDS+= v4l_compat>=1.0.20100321:multimedia/v4l_compat
MAKE_ARGS+= -D WITH_LINUX_COMPAT
.endif
MAKE_ARGS+= -D CX88_USE_IIC
MAKE_ARGS+= DEFAULT_XML_CONFIG="${EXAMPLESDIR}/cx88.xml.sample"
LINUXCOMPAT_BUILD_DEPENDS+= v4l_compat>=1.0.20100321:multimedia/v4l_compat
LINUXCOMPAT_MAKE_ARGS+= -D WITH_LINUX_COMPAT
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1555662085
SHA256 (cx88-1.5.3.tar.gz) = 5c33fac5b035844298a09d5e3092c926e54ce52a96340cfc755fbef589d1c5dd
SIZE (cx88-1.5.3.tar.gz) = 196468
TIMESTAMP = 1654378634
SHA256 (cx88-1.5.4.tar.gz) = 36f1e33fbc9a74af9d074aea090a66c0c586bb8302e284921877e98044bb2dbc
SIZE (cx88-1.5.4.tar.gz) = 197655

0
multimedia/cx88/files/cx88d.in Normal file → Executable file
View file

View file

@ -1,20 +0,0 @@
--- client/Makefile.orig 2016-10-30 22:50:26 UTC
+++ client/Makefile
@@ -21,7 +21,7 @@ STRIPFLAGS :=
CXXFLAGS+= -DCX88_USE_IIC
.endif
-NO_MAN=
+MAN=
LDADD = -L$(LIBTUNER_LIB) -ltuner_static -lezxml -lpthread -ledit
@@ -32,7 +32,7 @@ LDADD += $(JSON_LDFLAGS)
.if defined(WITH_LINUX_COMPAT)
CXXFLAGS += -D_WITH_LINUX_COMPAT
-LDADD += -L$(LOCALBASE)/lib -lcuse4bsd
+LDADD += -L$(LOCALBASE)/lib -lcuse
.if defined(WITH_HAL)
CXXFLAGS += -D_WITH_HAL

View file

@ -1,11 +0,0 @@
--- client/dvb/cx88_dvb_buffer.cpp.orig 2012-10-04 22:36:01 UTC
+++ client/dvb/cx88_dvb_buffer.cpp
@@ -30,7 +30,7 @@
#include <new>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "cx88_dvb_buffer.h"

View file

@ -1,11 +0,0 @@
--- client/dvb/cx88_dvb_capture.h.orig 2014-11-15 03:08:05 UTC
+++ client/dvb/cx88_dvb_capture.h
@@ -32,7 +32,7 @@
#include <list>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "tuner_config.h"
#include "cx88_capture.h"

View file

@ -1,11 +0,0 @@
--- client/dvb/cx88_dvb_demux.cpp.orig 2012-12-05 17:23:14 UTC
+++ client/dvb/cx88_dvb_demux.cpp
@@ -28,7 +28,7 @@
#include <sys/types.h>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "../cx88_debug.h"
#include "cx88_dvb_demux.h"

View file

@ -1,11 +0,0 @@
--- client/dvb/cx88_dvb_demux_feed.cpp.orig 2011-09-20 17:20:20 UTC
+++ client/dvb/cx88_dvb_demux_feed.cpp
@@ -1,7 +1,7 @@
#include <sys/types.h>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "cx88_dvb_demux_feed.h"

View file

@ -1,11 +0,0 @@
--- client/dvb/cx88_dvb_frontend.cpp.orig 2014-11-15 03:08:05 UTC
+++ client/dvb/cx88_dvb_frontend.cpp
@@ -31,7 +31,7 @@
#include <new>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "../cx88_debug.h"
#include "cx88_dvb_frontend.h"

View file

@ -1,11 +0,0 @@
--- client/v4l/cx88_radio_capture.h.orig 2019-11-30 20:23:39 UTC
+++ client/v4l/cx88_radio_capture.h
@@ -32,7 +32,7 @@
#include <linux/videodev2.h>
extern "C"
{
- #include <cuse4bsd.h>
+ #include <cuse.h>
}
#include "cx88_capture.h"
#include "tuner_config.h"

View file

@ -3,4 +3,4 @@ Conexant CX23880/1/2/3 and CX23885/7/8 chip families. This port includes the
cx88 kernel drivers as well as a simple app for TV capture. It requires
multimedia/libtuner for channel selection and peripheral configuration.
WWW: http://corona.homeunix.net/cx88wiki
WWW: https://corona.homeunix.net/cx88wiki