- Update devel/libtool and devel/libltdl to version 2.4.2.418

- Patch libtool so it uses the same library version specification as on
  Darwin, Linux and other systems.  Given the version current:revision:age
  a library will be given the extension .so.major.age.revision with major
  equal to current-age.  Before libtool would use .so.current on FreeBSD.
- Patch libtoolize to remove two cases of umask 0 that caused libltdl
  files to be copied world writable (--ltdl option)
- Let USES=libtool patch this new version correctly
- Adjust all ports with USES=libtool:build and bump PORTREVISION on their
  dependent ports if a library version changed

PR:		194068
Exp-run by:	antoine
Approved by:	portmgr (antoine)
This commit is contained in:
Tijl Coosemans 2014-10-05 18:01:19 +00:00
parent 5fc9848533
commit 88c67cd38c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=370099
50 changed files with 280 additions and 241 deletions

View file

@ -40,7 +40,9 @@ patch-libtool:
@${FIND} ${WRKDIR} -type f -name ltmain.sh | \
${XARGS} ${REINPLACE_CMD} \
-e '/if.*linkmode.*prog.*mode.*!= relink/s/if.*;/if :;/'\
-e '/if.*prog.*linkmode.*relink !=.*mode/s/if.*;/if :;/'\
-e '/if.*linkmode.*prog.*mode.* = relink/s/||.*;/;/' \
-e '/if.*prog.*linkmode.*relink = .*mode/s/||.*;/;/' \
-e 's/|-p|-pg|/|-B*|-p|-pg|/'
.if ! ${libtool_ARGS:Moldver}

View file

@ -4,7 +4,7 @@
PORTNAME= tardy
PORTVERSION= 1.28
DISTVERSIONSUFFIX= .D001.orig
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= archivers
MASTER_SITES= SF/tardy/${PORTVERSION}/
DISTNAME= ${PORTNAME}_${PORTVERSION}${DISTVERSIONSUFFIX}

View file

@ -3,7 +3,7 @@
PORTNAME= libnoise
DISTVERSION= 1.0.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20sources/${PORTVERSION}
DISTNAME= ${PORTNAME}src-${DISTVERSION}

View file

@ -45,6 +45,7 @@ include/noise/vectortable.h
lib/libnoise.a
lib/libnoise.so
lib/libnoise.so.0
lib/libnoise.so.0.0.0
@dirrm include/noise/model
@dirrm include/noise/module
@dirrm include/noise

View file

@ -3,7 +3,7 @@
PORTNAME= bglibs
PORTVERSION= 1.106
PORTREVISION= 5
PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://untroubled.org/${PORTNAME}/archive/ \

View file

@ -100,11 +100,13 @@ lib/bglibs/libbg-path.a
lib/bglibs/libbg-str.a
lib/bglibs/libbg-sysdeps.a
lib/bglibs/libbg-sysdeps.so
lib/bglibs/libbg-sysdeps.so.2
lib/bglibs/libbg-sysdeps.so.1
lib/bglibs/libbg-sysdeps.so.1.1.1
lib/bglibs/libbg-unix.a
lib/bglibs/libbg.a
lib/bglibs/libbg.so
lib/bglibs/libbg.so.2
lib/bglibs/libbg.so.1
lib/bglibs/libbg.so.1.1.1
lib/bglibs/libinstaller.a
lib/bglibs/libinstcheck.a
lib/bglibs/libinstshow.a

View file

@ -2,6 +2,7 @@
PORTNAME= cdialog
PORTVERSION= 1.2.20140219
PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/${PORTNAME:S|^c||}/

View file

@ -7,6 +7,7 @@ include/cdialog/dlg_keys.h
lib/libcdialog.a
lib/libcdialog.so
lib/libcdialog.so.11
lib/libcdialog.so.11.1.0
man/man1/cdialog.1.gz
man/man3/cdialog.3.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README

View file

@ -4,7 +4,7 @@
PORTNAME= fhist
PORTVERSION= 1.21
DISTVERSIONSUFFIX= .D001
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}

View file

@ -3,7 +3,7 @@
PORTNAME= libdsp
PORTVERSION= 5.0.2
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-stable-src/${PORTVERSION} \
http://mirror.mcx2.org/

View file

@ -27,5 +27,6 @@ include/dsp/dspop.h
include/dsp/dsptypes.h
lib/libdsp.a
lib/libdsp.so
lib/libdsp.so.10
lib/libdsp.so.2
lib/libdsp.so.2.8.1
@dirrm include/dsp

View file

@ -3,7 +3,7 @@
PORTNAME= libexplain
PORTVERSION= 1.3.${PATCHLEVEL}
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}

View file

@ -240,7 +240,8 @@ include/libexplain/write.h
include/libexplain/writev.h
lib/libexplain.a
lib/libexplain.so
lib/libexplain.so.55
lib/libexplain.so.51
lib/libexplain.so.51.4.0
libdata/pkgconfig/libexplain.pc
man/man1/explain.1.gz
man/man1/explain_lca2010.1.gz

View file

@ -2,21 +2,20 @@
# $FreeBSD$
PORTNAME= libltdl
MASTERDIR= ${.CURDIR}/../../devel/libtool
PORTREVISION= 0
COMMENT= System independent dlopen wrapper
.include "${.CURDIR}/../libtool/Makefile.common"
LICENSE= LGPL21
USE_LDCONFIG= yes
USES= libtool:keepla
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-ltdl-install
CONFIGURE_WRKSRC=${WRKSRC}/libltdl
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
INFO= # empty
INSTALL_TARGET= install-strip
USES+= libtool:keepla # .la file used in ltdl.m4
USE_LDCONFIG= yes
WRKSRC_SUBDIR= libltdl
.include "${MASTERDIR}/Makefile"
.include <bsd.port.mk>

View file

@ -6,5 +6,4 @@ lib/libltdl.a
lib/libltdl.la
lib/libltdl.so
lib/libltdl.so.7
lib/libltdl.so.7.3.0
@dirrm include/libltdl
lib/libltdl.so.7.3.1

View file

@ -3,7 +3,7 @@
PORTNAME= libmaa
PORTVERSION= 1.3.2
PORTREVISION= 1
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF/dict/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@ -27,7 +27,8 @@ DOCS= README doc/libmaa.600dpi.ps
PLIST_FILES= include/maa.h \
lib/libmaa.a \
lib/libmaa.so \
lib/libmaa.so.3
lib/libmaa.so.3 \
lib/libmaa.so.3.0.0
PORTDOCS= ${DOCS:T}
post-install:

View file

@ -1,36 +1,30 @@
# Created by: Motoyuki Kasahara <m-kasahr@sra.co.jp>
# $FreeBSD$
PORTNAME?= libtool
PORTVERSION= 2.4.2
PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
DISTNAME= libtool-${PORTVERSION}
PORTNAME= libtool
PORTREVISION= 0
MAINTAINER= autotools@FreeBSD.org
COMMENT?= Generic shared library support script
COMMENT= Generic shared library support script
LICENSE?= GPLv2
.include "${.CURDIR}/../libtool/Makefile.common"
CONFLICTS= libtool-fixed-[0-9]*
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
USES+= makeinfo
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
INFO?= libtool
CONFIGURE_ARGS= --disable-ltdl-install
MAKE_ARGS= MAKEINFOFLAGS=--no-split
USES+= makeinfo
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
INFO= libtool
post-patch:
@${REINPLACE_CMD} -e 's|sed gsed|sed|g' \
-e 's|CC=cc|CC=${CC}|g' \
${WRKSRC}/configure ${WRKSRC}/libltdl/configure
post-configure:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
@${RM} -f ${WRKSRC}/doc/*.info*
.for f in build-aux/ltmain.sh configure libtoolize.in m4/libtool.m4
@${TOUCH} -mr ${WRKSRC}/${f}.orig ${WRKSRC}/${f}
.endfor
.include <bsd.port.mk>

View file

@ -0,0 +1,12 @@
# $FreeBSD$
PORTVERSION= 2.4.2.418
PORTREVISION?= 0 # Leave this zero. Set in Makefile instead.
CATEGORIES= devel
MASTER_SITES= GNU_ALPHA/libtool
DISTNAME= libtool-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
DISTINFO_FILE= ${.CURDIR}/../libtool/distinfo
USES= tar:xz

View file

@ -1,2 +1,2 @@
SHA256 (libtool-2.4.2.tar.gz) = b38de44862a987293cd3d8dfae1c409d514b6c4e794ebc93648febf9afc38918
SIZE (libtool-2.4.2.tar.gz) = 2632347
SHA256 (libtool-2.4.2.418.tar.xz) = 6465c7e6ebb7c9083aa610d510498aadf7be0c6dc5f2f4e57008686879d27d8c
SIZE (libtool-2.4.2.418.tar.xz) = 941808

View file

@ -0,0 +1,30 @@
--- build-aux/ltmain.sh.orig 2013-10-26 22:53:58 UTC
+++ build-aux/ltmain.sh
@@ -8598,13 +8598,13 @@ func_mode_link ()
#
case $version_type in
# correct linux to gnu/linux during the next big refactor
- darwin|linux|osf|windows|none)
+ darwin|freebsd-elf|linux|osf|windows|none)
func_arith $number_major + $number_minor
current=$func_arith_result
age=$number_minor
revision=$number_revision
;;
- freebsd-aout|freebsd-elf|qnx|sunos)
+ freebsd-aout|qnx|sunos)
current=$number_major
revision=$number_minor
age=0
@@ -8690,8 +8690,9 @@ func_mode_link ()
;;
freebsd-elf)
- major=.$current
- versuffix=.$current
+ func_arith $current - $age
+ major=.$func_arith_result
+ versuffix=$major.$age.$revision
;;
irix | nonstopux)

View file

@ -0,0 +1,42 @@
--- configure.orig 2013-10-26 22:53:35 UTC
+++ configure
@@ -11582,7 +11582,8 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
;;
@@ -16739,7 +16740,8 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
;;
@@ -19695,7 +19697,8 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
;;
@@ -22786,7 +22789,8 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
;;

View file

@ -1,23 +0,0 @@
--- libltdl/Makefile.in.orig 2009-11-19 14:55:46.000000000 +0100
+++ libltdl/Makefile.in 2009-11-19 14:56:35.000000000 +0100
@@ -402,12 +402,6 @@
$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
$(SHELL) ./config.status --recheck
-$(top_srcdir)/configure: $(am__configure_deps)
- $(am__cd) $(srcdir) && $(AUTOCONF)
-$(ACLOCAL_M4): $(am__aclocal_m4_deps)
- $(am__cd) $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
-$(am__aclocal_m4_deps):
-
config.h: stamp-h1
@if test ! -f $@; then \
rm -f stamp-h1; \
@@ -418,7 +412,6 @@
@rm -f stamp-h1
cd $(top_builddir) && $(SHELL) ./config.status config.h
$(srcdir)/config-h.in: $(am__configure_deps)
- ($(am__cd) $(top_srcdir) && $(AUTOHEADER))
rm -f stamp-h1
touch $@

View file

@ -1,83 +0,0 @@
--- libltdl/config/ltmain.sh.orig 2010-09-22 09:45:43.000000000 -0500
+++ libltdl/config/ltmain.sh 2011-01-18 12:59:46.000000000 -0600
@@ -1376,2 +1376,17 @@
$opt_debug
+
+ # FreeBSD-specific: where we install compilers with non-standard names
+ tag_compilers_CC="*cc cc* *gcc gcc* clang*"
+ tag_compilers_CXX="*c++ c++* *g++ g++* clang++*"
+ base_compiler=`set -- "$@"; echo $1`
+
+ # If $tagname isn't set, then try to infer if the default "CC" tag applies
+ if test -z "$tagname"; then
+ for zp in $tag_compilers_CC; do
+ case $base_compiler in
+ $zp) tagname="CC"; break;;
+ esac
+ done
+ fi
+
if test -n "$available_tags" && test -z "$tagname"; then
@@ -1412,3 +1427,18 @@
esac
- fi
+
+ # FreeBSD-specific: try compilers based on inferred tag
+ if test -z "$tagname"; then
+ eval "tag_compilers=\$tag_compilers_${z}"
+ if test -n "$tag_compilers"; then
+ for zp in $tag_compilers; do
+ case $base_compiler in
+ $zp) tagname=$z; break;;
+ esac
+ done
+ if test -n "$tagname"; then
+ break
+ fi
+ fi
+ fi
+ fi
done
@@ -3516,2 +3546,5 @@
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
@@ -5585,2 +5618,3 @@
esac
+ deplibs="$deplibs $arg"
continue
@@ -6155,9 +6189,26 @@
func_append compiler_flags " $deplib"
- if test "$linkmode" = lib ; then
- case "$new_inherited_linker_flags " in
- *" $deplib "*) ;;
- * ) func_append new_inherited_linker_flags " $deplib" ;;
- esac
- fi
fi
+
+ case $linkmode in
+ lib)
+ deplibs="$deplib $deplibs"
+ test "$pass" = conv && continue
+ newdependency_libs="$deplib $newdependency_libs"
+ ;;
+ prog)
+ if test "$pass" = conv; then
+ deplibs="$deplib $deplibs"
+ continue
+ fi
+ if test "$pass" = scan; then
+ deplibs="$deplib $deplibs"
+ else
+ compile_deplibs="$deplib $compile_deplibs"
+ finalize_deplibs="$deplib $finalize_deplibs"
+ fi
+ ;;
+ *)
+ ;;
+ esac # linkmode
+
continue

View file

@ -0,0 +1,34 @@
--- libtoolize.in.orig 2013-08-23 05:06:01 UTC
+++ libtoolize.in
@@ -393,7 +393,7 @@ func_copy ()
# Filters always take priority.
if test -n "$my_filter"; then
if $opt_dry_run || {
- ( umask 0
+ (
$SED -e "$my_filter" "$my_srcfile" > "$my_destfile"
) >/dev/null 2>&1
}
@@ -423,7 +423,7 @@ func_copy ()
$opt_verbose && my_copy_msg="$my_copycmd $my_srcfile $my_destdir"
if $opt_dry_run || {
- ( umask 0
+ (
$my_copycmd "$my_srcfile" "$my_destfile"
) >/dev/null 2>&1
}
@@ -1894,9 +1894,10 @@ func_require_seen_libtool ()
# Lists of all files libtoolize has ever installed. These are removed
# before installing the latest files when --force was passed to help
# ensure a clean upgrade.
- # Do not remove config.guess nor config.sub, we don't install them
- # without --install, and the project may not be using Automake.
- all_pkgaux_files="compile install-sh depcomp missing ltmain.sh snippet/_Noreturn.h snippet/arg-nonnull.h snippet/c++defs.h snippet/warn-on-use.h"
+ # Do not remove config.guess, config.sub or install-sh, we don't
+ # install them without --install, and the project may not be using
+ # Automake.
+ all_pkgaux_files="compile depcomp missing ltmain.sh snippet/_Noreturn.h snippet/arg-nonnull.h snippet/c++defs.h snippet/warn-on-use.h"
all_pkgmacro_files="argz.m4 libtool.m4 ltdl.m4 ltoptions.m4 ltsugar.m4 ltversion.in ltversion.m4 lt~obsolete.m4"
all_pkgltdl_files="COPYING.LIB Makefile Makefile.in Makefile.inc Makefile.am README acinclude.m4 aclocal.m4 argz_.h argz.c config.h.in config-h.in configure configure.ac configure.in libltdl/lt__alloc.h libltdl/lt__dirent.h libltdl/lt__glibc.h libltdl/lt__private.h libltdl/lt__strl.h libltdl/lt_dlloader.h libltdl/lt_error.h libltdl/lt_system.h libltdl/slist.h loaders/dld_link.c loaders/dlopen.c loaders/dyld.c loaders/load_add_on.c loaders/loadlibrary.c loaders/preopen.c loaders/shl_load.c lt__alloc.c lt__dirent.c lt__strl.c lt_dlloader.c lt_error.c ltdl.c ltdl.h ltdl.mk slist.c"

View file

@ -0,0 +1,12 @@
--- m4/libtool.m4.orig 2013-10-25 23:37:46 UTC
+++ m4/libtool.m4
@@ -2547,7 +2547,8 @@ freebsd* | dragonfly*)
version_type=freebsd-$objformat
case $version_type in
freebsd-elf*)
- library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext $libname$shared_ext'
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext'
+ soname_spec='$libname$release$shared_ext$major'
need_version=no
need_lib_prefix=no
;;

View file

@ -9,50 +9,45 @@ share/aclocal/ltoptions.m4
share/aclocal/ltsugar.m4
share/aclocal/ltversion.m4
share/aclocal/lt~obsolete.m4
share/libtool/config/compile
share/libtool/config/config.guess
share/libtool/config/config.sub
share/libtool/config/depcomp
share/libtool/config/install-sh
share/libtool/config/ltmain.sh
share/libtool/config/missing
share/libtool/libltdl/COPYING.LIB
share/libtool/libltdl/Makefile.am
share/libtool/libltdl/Makefile.in
share/libtool/libltdl/Makefile.inc
share/libtool/libltdl/README
share/libtool/libltdl/aclocal.m4
share/libtool/libltdl/argz.c
share/libtool/libltdl/argz_.h
share/libtool/libltdl/config-h.in
share/libtool/libltdl/configure
share/libtool/libltdl/configure.ac
share/libtool/libltdl/libltdl/lt__alloc.h
share/libtool/libltdl/libltdl/lt__dirent.h
share/libtool/libltdl/libltdl/lt__glibc.h
share/libtool/libltdl/libltdl/lt__private.h
share/libtool/libltdl/libltdl/lt__strl.h
share/libtool/libltdl/libltdl/lt_dlloader.h
share/libtool/libltdl/libltdl/lt_error.h
share/libtool/libltdl/libltdl/lt_system.h
share/libtool/libltdl/libltdl/slist.h
share/libtool/libltdl/loaders/dld_link.c
share/libtool/libltdl/loaders/dlopen.c
share/libtool/libltdl/loaders/dyld.c
share/libtool/libltdl/loaders/load_add_on.c
share/libtool/libltdl/loaders/loadlibrary.c
share/libtool/libltdl/loaders/preopen.c
share/libtool/libltdl/loaders/shl_load.c
share/libtool/libltdl/lt__alloc.c
share/libtool/libltdl/lt__dirent.c
share/libtool/libltdl/lt__strl.c
share/libtool/libltdl/lt_dlloader.c
share/libtool/libltdl/lt_error.c
share/libtool/libltdl/ltdl.c
share/libtool/libltdl/ltdl.h
share/libtool/libltdl/slist.c
@dirrm share/libtool/libltdl/loaders
@dirrm share/libtool/libltdl/libltdl
@dirrm share/libtool/libltdl
@dirrm share/libtool/config
@dirrm share/libtool
%%DATADIR%%/COPYING.LIB
%%DATADIR%%/Makefile.am
%%DATADIR%%/Makefile.in
%%DATADIR%%/README
%%DATADIR%%/aclocal.m4
%%DATADIR%%/argz.c
%%DATADIR%%/argz_.h
%%DATADIR%%/build-aux/compile
%%DATADIR%%/build-aux/config.guess
%%DATADIR%%/build-aux/config.sub
%%DATADIR%%/build-aux/depcomp
%%DATADIR%%/build-aux/install-sh
%%DATADIR%%/build-aux/ltmain.sh
%%DATADIR%%/build-aux/missing
%%DATADIR%%/config-h.in
%%DATADIR%%/configure
%%DATADIR%%/configure.ac
%%DATADIR%%/libltdl/lt__alloc.h
%%DATADIR%%/libltdl/lt__dirent.h
%%DATADIR%%/libltdl/lt__glibc.h
%%DATADIR%%/libltdl/lt__private.h
%%DATADIR%%/libltdl/lt__strl.h
%%DATADIR%%/libltdl/lt_dlloader.h
%%DATADIR%%/libltdl/lt_error.h
%%DATADIR%%/libltdl/lt_system.h
%%DATADIR%%/libltdl/slist.h
%%DATADIR%%/loaders/dld_link.c
%%DATADIR%%/loaders/dlopen.c
%%DATADIR%%/loaders/dyld.c
%%DATADIR%%/loaders/load_add_on.c
%%DATADIR%%/loaders/loadlibrary.c
%%DATADIR%%/loaders/preopen.c
%%DATADIR%%/loaders/shl_load.c
%%DATADIR%%/lt__alloc.c
%%DATADIR%%/lt__dirent.c
%%DATADIR%%/lt__strl.c
%%DATADIR%%/lt_dlloader.c
%%DATADIR%%/lt_error.c
%%DATADIR%%/ltdl.c
%%DATADIR%%/ltdl.h
%%DATADIR%%/ltdl.mk
%%DATADIR%%/slist.c

View file

@ -3,7 +3,7 @@
PORTNAME= srecord
PORTVERSION= 1.64
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF

View file

@ -143,6 +143,7 @@ include/srecord/string.h
lib/libsrecord.a
lib/libsrecord.so
lib/libsrecord.so.0
lib/libsrecord.so.0.0.0
libdata/pkgconfig/srecord.pc
man/man1/srec_cat.1.gz
man/man1/srec_cmp.1.gz

View file

@ -3,7 +3,7 @@
PORTNAME= xparam
PORTVERSION= 1.22
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF

View file

@ -84,4 +84,4 @@ include/xparam_extend.h
lib/libxparam.a
lib/libxparam.so
lib/libxparam.so.1
@dirrm include/xparam
lib/libxparam.so.1.0.0

View file

@ -3,6 +3,7 @@
PORTNAME= dnsutl
PORTVERSION= 1.12
PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}

View file

@ -3,6 +3,7 @@
PORTNAME= twoftpd
PORTVERSION= 1.42
PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= http://untroubled.org/${PORTNAME}/

View file

@ -3,7 +3,7 @@
PORTNAME= gexiv2
PORTVERSION= 0.6.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://yorba.org/download/${PORTNAME}/${PORTVERSION:R}/
DISTNAME= lib${PORTNAME}_${PORTVERSION}

View file

@ -5,11 +5,9 @@ include/gexiv2/gexiv2-managed-stream.h
include/gexiv2/gexiv2-preview-properties.h
include/gexiv2/gexiv2-preview-image.h
include/gexiv2/gexiv2-startup.h
lib/libgexiv2.so.2
lib/libgexiv2.so
lib/libgexiv2.a
lib/libgexiv2.so
lib/libgexiv2.so.2
lib/libgexiv2.so.2.0.0
libdata/pkgconfig/gexiv2.pc
share/vala/vapi/gexiv2.vapi
@dirrmtry include/gexiv2
@dirrmtry share/vala/vapi
@dirrmtry share/vala

View file

@ -3,7 +3,7 @@
PORTNAME= gforth
PORTVERSION= 0.7.3
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= http://www.complang.tuwien.ac.at/forth/gforth/ \
GNU

View file

@ -12,18 +12,22 @@ include/gforth/%%PORTVERSION%%/config.h
include/gforth/%%PORTVERSION%%/libcc.h
lib/gforth/%%PORTVERSION%%/gforth-ditc
lib/gforth/%%PORTVERSION%%/gforth.fi
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.a
lib/gforth/%%PORTVERSION%%/libcc-named/socket.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/socket.so
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/cstr.so.0.0.0
lib/gforth/%%PORTVERSION%%/libcc-named/socket.a
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so
lib/gforth/%%PORTVERSION%%/libcc-named/socket.so
lib/gforth/%%PORTVERSION%%/libcc-named/socket.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/socket.so.0.0.0
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.a
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/libffi.so.0.0.0
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.a
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so.0
lib/gforth/%%PORTVERSION%%/libcc-named/fflib.so.0.0.0
man/man1/gforth.1.gz
%%DATADIR%%/%%PORTVERSION%%/TAGS
%%DATADIR%%/%%PORTVERSION%%/add.fs

View file

@ -3,7 +3,7 @@
PORTNAME= oo2c
PORTVERSION= 2.1.11
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= SF/ooc/ooc2/${PORTVERSION}
DISTNAME= ${PORTNAME}_${BITS}-${PORTVERSION}

View file

@ -10,6 +10,7 @@ man/man1/oowhereis.1.gz
lib/liboo2c.a
lib/liboo2c.so
lib/liboo2c.so.3
lib/liboo2c.so.3.0.0
lib/oo2c/emacs/o2-default.el
lib/oo2c/emacs/o2-indent.el
lib/oo2c/emacs/o2-insert.el

View file

@ -3,6 +3,7 @@
PORTNAME= mailfront
PORTVERSION= 2.01
PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/${PORTNAME}/ \
http://untroubled.org/${PORTNAME}/archive/

View file

@ -3,7 +3,7 @@
PORTNAME= qmail-autoresponder
PORTVERSION= 0.97
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/${PORTNAME}/

View file

@ -3,7 +3,7 @@
PORTNAME= qmail-qfilter
PORTVERSION= 2.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= http://untroubled.org/${PORTNAME}/

View file

@ -2,7 +2,7 @@
PORTNAME= libtommath
PORTVERSION= 0.42.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= http://libtom.org/files/
DISTNAME= ltm-${PORTVERSION}
@ -31,7 +31,7 @@ post-patch:
.if ${PORT_OPTIONS:MSHARED}
USES+= libtool:build
USE_LDCONFIG= yes
PLIST_FILES+= lib/libtommath.so.0 lib/libtommath.so
PLIST_FILES+= lib/libtommath.so lib/libtommath.so.0 lib/libtommath.so.0.0.41
MAKEFILE= makefile.shared
.else
MAKEFILE= makefile

View file

@ -3,7 +3,7 @@
PORTNAME= cvm
PORTVERSION= 0.96
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://untroubled.org/${PORTNAME}/ \
http://untroubled.org/${PORTNAME}/archive/

View file

@ -26,31 +26,40 @@ lib/libcvm-client.a
lib/libcvm-client.so
lib/libcvm-command.a
lib/libcvm-command.so
lib/libcvm-command.so.2
lib/libcvm-command.so.1
lib/libcvm-command.so.1.1.0
lib/libcvm-local.a
lib/libcvm-local.so
lib/libcvm-local.so.2
lib/libcvm-local.so.1
lib/libcvm-local.so.1.1.0
lib/libcvm-module.a
lib/libcvm-module.so
lib/libcvm-module.so.2
lib/libcvm-module.so.1
lib/libcvm-module.so.1.1.0
lib/libcvm-qmail.a
lib/libcvm-qmail.so
lib/libcvm-qmail.so.2
lib/libcvm-qmail.so.1
lib/libcvm-qmail.so.1.1.0
lib/libcvm-sasl.a
lib/libcvm-sasl.so
lib/libcvm-sasl.so.2
lib/libcvm-sasl.so.1
lib/libcvm-sasl.so.1.1.0
lib/libcvm-sql.a
lib/libcvm-sql.so
lib/libcvm-sql.so.2
lib/libcvm-sql.so.1
lib/libcvm-sql.so.1.1.0
lib/libcvm-udp.a
lib/libcvm-udp.so
lib/libcvm-udp.so.2
lib/libcvm-udp.so.1
lib/libcvm-udp.so.1.1.0
lib/libcvm-v1client.a
lib/libcvm-v1client.so
lib/libcvm-v1client.so.2
lib/libcvm-v1client.so.1
lib/libcvm-v1client.so.1.1.0
lib/libcvm-v2client.a
lib/libcvm-v2client.so
lib/libcvm-v2client.so.2
lib/libcvm-v2client.so.1
lib/libcvm-v2client.so.1.1.0
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
@ -77,5 +86,3 @@ lib/libcvm-v2client.so.2
%%PORTDOCS%%%%DOCSDIR%%/sql.html
%%PORTDOCS%%%%DOCSDIR%%/v1client.html
%%PORTDOCS%%%%DOCSDIR%%/v2client.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/cvm

View file

@ -3,7 +3,7 @@
PORTNAME= libtomcrypt
PORTVERSION= 1.17
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= http://libtom.org/files/
DISTNAME= crypt-${PORTVERSION}

View file

@ -15,9 +15,11 @@ include/tomcrypt_test.h
lib/libtomcrypt.a
lib/libtomcrypt.so
lib/libtomcrypt.so.0
lib/libtomcrypt.so.0.0.117
lib/libtomcrypt_prof.a
lib/libtomcrypt_prof.so
lib/libtomcrypt_prof.so.0
lib/libtomcrypt_prof.so.0.0.117
%%PORTDOCS%%%%DOCSDIR%%/pdf/crypt.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%

View file

@ -3,7 +3,7 @@
PORTNAME= ucspi-proxy
PORTVERSION= 0.98
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://untroubled.org/ucspi-proxy/

View file

@ -3,7 +3,7 @@
PORTNAME= vii
PORTVERSION= 4.2
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= http://vii.sourceforge.net/ \
CRITICAL

View file

@ -3,6 +3,7 @@
PORTNAME= XmHTML
PORTVERSION= 1.1.9
PORTREVISION= 1
CATEGORIES= x11-toolkits www
MASTER_SITES= SF/${PORTNAME:tl}

View file

@ -14,6 +14,7 @@ include/XmHTML/toolkit.h
lib/libXmHTML.a
lib/libXmHTML.so
lib/libXmHTML.so.1
lib/libXmHTML.so.1.0.2
%%PORTDOCS%%%%DOCSDIR%%/GPL.html
%%PORTDOCS%%%%DOCSDIR%%/LGPL.html
%%PORTDOCS%%%%DOCSDIR%%/XmHTML.html