- Update to 0.5.098
- Modify options PR: 190902 Submitted by: ports fury
This commit is contained in:
parent
03c2f48939
commit
88eaf67f49
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=357743
7 changed files with 38 additions and 68 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gxine
|
||||
PORTVERSION= 0.5.907
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 0.5.908
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= SF/xine/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
|
@ -16,10 +15,7 @@ LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr \
|
|||
libmozjs185.so:${PORTSDIR}/lang/spidermonkey185 \
|
||||
libxine.so:${PORTSDIR}/multimedia/libxine
|
||||
|
||||
OPTIONS_DEFINE= MOZILLA_PLUGIN GNOME LIRC
|
||||
MOZILLA_PLUGIN_DESC= Mozilla plugin
|
||||
|
||||
USES= gmake libtool:keepla pathfix pkgconfig tar:xz
|
||||
USES= desktop-file-utils gmake libtool pathfix pkgconfig tar:xz
|
||||
USE_GNOME= gtk20
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --without-hal --with-libintl-prefix=${LOCALBASE}
|
||||
|
@ -28,33 +24,27 @@ INSTALLS_ICONS= yes
|
|||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
OPTIONS_DEFINE= GNOME LIRC WEBPLUGIN
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
GNOME_BUILD_DEPENDS= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
|
||||
GNOME_LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
|
||||
GNOME_RUN_DEPENDS= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
|
||||
GNOME_CONFIGURE_ON= --with-dbus
|
||||
GNOME_CONFIGURE_OFF= --disable-integration-wizard --without-dbus
|
||||
LIRC_LIB_DEPENDS= liblirc_client.so:${PORTSDIR}/comms/lirc
|
||||
LIRC_CONFIGURE_ON= --enable-lirc
|
||||
LIRC_CONFIGURE_OFF= --disable-lirc
|
||||
WEBPLUGIN_DESC= Build and/or install Web browser plugins
|
||||
WEBPLUGIN_USE= xorg=xaw
|
||||
WEBPLUGIN_USES= webplugin:native
|
||||
WEBPLUGIN_CONFIGURE_OFF= --without-browser-plugin
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MMOZILLA_PLUGIN}
|
||||
USE_XORG+= xaw
|
||||
USES+= webplugin:native
|
||||
.if ${PORT_OPTIONS:MWEBPLUGIN}
|
||||
WEBPLUGIN_DIR= ${PREFIX}/lib/gxine
|
||||
WEBPLUGIN_FILES=gxineplugin.so
|
||||
PLIST_SUB+= MOZILLA_PLUGIN=""
|
||||
.else
|
||||
CONFIGURE_ARGS+=--without-browser-plugin
|
||||
PLIST_SUB+= MOZILLA_PLUGIN="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MGNOME}
|
||||
BUILD_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
|
||||
LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
|
||||
RUN_DEPENDS+= gnome-screensaver:${PORTSDIR}/x11/gnome-screensaver
|
||||
CONFIGURE_ARGS+=--with-dbus
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-integration-wizard --without-dbus
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MLIRC}
|
||||
LIB_DEPENDS+= liblirc_client.so:${PORTSDIR}/comms/lirc
|
||||
CONFIGURE_ARGS+=--enable-lirc
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-lirc
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
|
@ -66,4 +56,9 @@ post-patch:
|
|||
@${REINPLACE_CMD} -e \
|
||||
's|@MAKE_PNG_TRUE@|#|' ${WRKSRC}/pixmaps/Makefile.in
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MWEBPLUGIN}
|
||||
@${STRIP_CMD} ${STAGEDIR}${WEBPLUGIN_DIR}/${WEBPLUGIN_FILES}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (gxine-0.5.907.tar.xz) = b5c925806a35cb23a24a80a39d494cefb529e22c957987741f269a994ab258d5
|
||||
SIZE (gxine-0.5.907.tar.xz) = 910528
|
||||
SHA256 (gxine-0.5.908.tar.xz) = 832e47136ec68a573b22b6cc1c1d57607e78b05712ba9fb8e64464b5201ed9e7
|
||||
SIZE (gxine-0.5.908.tar.xz) = 917780
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- src/Makefile.in.orig 2012-02-21 04:10:20.000000000 +0900
|
||||
+++ src/Makefile.in 2012-05-15 17:11:18.000000000 +0900
|
||||
@@ -330,12 +330,12 @@
|
||||
@@ -405,12 +405,12 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
GNU_VERBOSITY := $(if $(findstring GNU,$(shell $(MAKE) -v)),0,1)
|
||||
|
@ -16,3 +16,12 @@
|
|||
-DLOCALEDIR=\"$(localedir)\"
|
||||
|
||||
gxine_SOURCES = \
|
||||
@@ -452,7 +452,7 @@
|
||||
gxine_LDADD = $(XINE_LIBS) $(GTK2_LIBS) $(GTHREAD2_LIBS) \
|
||||
$(JS_LIBS) $(HAL_LIBS) $(UDEV_LIBS) $(DBUS_LIBS) $(LIRC_LIBS) \
|
||||
$(X_LIBS) $(X_EXTRA_LIBS) $(XEXT_LIBS) $(XTEST_LIBS) \
|
||||
- $(XINERAMA_LIBS) $(XRANDR_LIBS) $(XCB_LIBS) -ldl -lm
|
||||
+ $(XINERAMA_LIBS) $(XRANDR_LIBS) $(XCB_LIBS) -lm
|
||||
|
||||
gxine_client_SOURCES = client.c console_output.c
|
||||
gxine_client_CFLAGS = $(AM_CFLAGS) -DGXINE_CLIENT
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- src/console_output.h.orig 2010-04-11 23:46:54.000000000 +0900
|
||||
+++ src/console_output.h 2012-05-15 04:21:37.000000000 +0900
|
||||
@@ -21,7 +21,7 @@
|
||||
#ifndef GXINE_CONSOLE_OUTPUT_H
|
||||
#define GXINE_CONSOLE_OUTPUT_H
|
||||
|
||||
-#include <glib/gmessages.h>
|
||||
+#include <glib.h>
|
||||
|
||||
void console_output_init (void);
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
--- src/engine.c.orig 2011-10-12 07:47:52.000000000 +0900
|
||||
+++ src/engine.c 2012-05-15 04:22:54.000000000 +0900
|
||||
@@ -30,7 +30,7 @@
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
|
||||
-#include <glib/gthread.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "engine.h"
|
||||
#include "ui.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- src/main.c.orig 2010-12-05 20:38:44.000000000 +0900
|
||||
+++ src/main.c 2012-05-15 04:23:45.000000000 +0900
|
||||
@@ -46,7 +46,6 @@
|
||||
#include <gdk/gdk.h>
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
#include <glib.h>
|
||||
-#include <glib/gmessages.h>
|
||||
|
||||
#include "desktop_integration.h"
|
||||
#include "engine.h"
|
|
@ -5,9 +5,7 @@ bin/gxine_client
|
|||
%%ETCDIR%%/startup
|
||||
%%ETCDIR%%/toolbar-fullscreen.xml
|
||||
%%ETCDIR%%/toolbar-window.xml
|
||||
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.a
|
||||
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.la
|
||||
%%MOZILLA_PLUGIN%%lib/gxine/gxineplugin.so
|
||||
%%WEBPLUGIN%%lib/gxine/gxineplugin.so
|
||||
man/man1/gxine.1.gz
|
||||
man/man1/gxine_client.1.gz
|
||||
man/de/man1/gxine.1.gz
|
||||
|
@ -62,5 +60,5 @@ share/pixmaps/gxine.png
|
|||
@dirrmtry man/es
|
||||
@dirrmtry man/de/man1
|
||||
@dirrmtry man/de
|
||||
@dirrm lib/gxine
|
||||
%%WEBPLUGIN%%@dirrm lib/gxine
|
||||
@dirrm %%ETCDIR%%
|
||||
|
|
Loading…
Reference in a new issue