- Update to 1.4.1

This commit is contained in:
Dmitry Marakasov 2015-10-26 11:43:56 +00:00
parent 9febae8b79
commit 88fc8decfa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=400181
3 changed files with 11 additions and 16 deletions

View file

@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= wyrmgus
PORTVERSION= git20150601
PORTVERSION= 1.4.1
DISTVERSIONPREFIX= v
CATEGORIES= games devel
MAINTAINER= amdmi3@FreeBSD.org
@ -17,7 +18,6 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= Andrettin
GH_PROJECT= Wyrmgus
GH_TAGNAME= 80c76abcc6
USE_GL= gl glu
USE_SDL= sdl
@ -64,8 +64,14 @@ FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:${PORTSDIR}/audio/fluidsynth
FLUIDSYNTH_CMAKE_ON= -DWITH_FLUIDSYNTH:BOOL=ON
FLUIDSYNTH_CMAKE_OFF= -DWITH_FLUIDSYNTH:BOOL=OFF
.include <bsd.port.pre.mk>
.if ${COMPILER_TYPE} == gcc
CXXFLAGS+= -D_GLIBCXX_USE_C99 # gcc c++11 support is broken on FreeBSD
.endif
do-install:
${INSTALL_PROGRAM} ${CONFIGURE_WRKSRC}/stratagus ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/src/win32/wyrmsun.ico ${STAGEDIR}${PREFIX}/share/pixmaps/
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (Andrettin-Wyrmgus-git20150601-80c76abcc6_GH0.tar.gz) = 1032a1b372061c36c9a1615ace17db5307923bbc209fa15c34a4d55cfbacd720
SIZE (Andrettin-Wyrmgus-git20150601-80c76abcc6_GH0.tar.gz) = 1076866
SHA256 (Andrettin-Wyrmgus-v1.4.1_GH0.tar.gz) = bee4c96ddd74e6c3105d725c37dfb774a6be53465355c7b578824b28719b89dc
SIZE (Andrettin-Wyrmgus-v1.4.1_GH0.tar.gz) = 1176777

View file

@ -1,11 +0,0 @@
--- src/unit/script_unittype.cpp.orig 2015-06-01 15:35:14 UTC
+++ src/unit/script_unittype.cpp
@@ -1342,7 +1342,7 @@ static int CclDefineUnitType(lua_State *
type->Parent = LuaToString(l, -1);
CUnitType *parent_type = UnitTypeByIdent(type->Parent);
if (!parent_type) {
- LuaError(l, "Unit type %s not defined" _C_ type->Parent);
+ LuaError(l, "Unit type %s not defined" _C_ type->Parent.c_str());
}
type->Class = parent_type->Class;
type->DrawLevel = parent_type->DrawLevel;