New poert: math/optpp: Object-oriented nonlinear optimization library
This commit is contained in:
parent
0bf701cd49
commit
8914aaead0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=500457
6 changed files with 141 additions and 0 deletions
|
@ -498,6 +498,7 @@
|
|||
SUBDIR += openlibm
|
||||
SUBDIR += openmesh
|
||||
SUBDIR += opensolaris-libm
|
||||
SUBDIR += optpp
|
||||
SUBDIR += orpie
|
||||
SUBDIR += osi
|
||||
SUBDIR += osqp
|
||||
|
|
22
math/optpp/Makefile
Normal file
22
math/optpp/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= optpp
|
||||
DISTVERSION= 2.4
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= https://software.sandia.gov/opt++/downloads/
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Object-oriented nonlinear optimization library
|
||||
|
||||
LICENSE= LGPL21
|
||||
LICENSE_FILE= ${WRKSRC}/GNU_LGPL
|
||||
|
||||
USES= fortran gmake libtool
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-shared
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
post-stage: # installs the conflicting file
|
||||
@${RM} ${STAGEDIR}${PREFIX}/include/cblas.h
|
||||
|
||||
.include <bsd.port.mk>
|
3
math/optpp/distinfo
Normal file
3
math/optpp/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
TIMESTAMP = 1556600038
|
||||
SHA256 (optpp-2.4.tar.gz) = b452cdf8aa770088e26b49e07b5cf13ae5972832c032abcad07a56baa2a588ef
|
||||
SIZE (optpp-2.4.tar.gz) = 2233938
|
10
math/optpp/files/patch-include_ConstraintBase.h
Normal file
10
math/optpp/files/patch-include_ConstraintBase.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- include/ConstraintBase.h.orig 2019-04-30 05:23:10 UTC
|
||||
+++ include/ConstraintBase.h
|
||||
@@ -8,6 +8,7 @@
|
||||
----------------------------------------------------------------------*/
|
||||
|
||||
#include <iostream>
|
||||
+#include <float.h>
|
||||
|
||||
#include "globals.h"
|
||||
|
12
math/optpp/pkg-descr
Normal file
12
math/optpp/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
OPT++ is a library of nonlinear optimization algorithms written in C++. The
|
||||
motivation for this package is to build an environment for the rapid prototyping
|
||||
and development of new optimization algorithms. In particular, the focus is on
|
||||
robust and efficient algorithms for problems in which the function and
|
||||
constraint evaluations require the execution of an expensive computer
|
||||
simulation. Currently, OPT++ includes the classic Newton methods, a nonlinear
|
||||
interior-point method, parallel direct search, generating set search, a trust
|
||||
region - parallel direct search hybrid, and a wrapper to NPSOL. Between these
|
||||
methods, a wide range of problems can be solved, e.g. with or without
|
||||
constraints, with or without analytic gradients, simulation based, etc.
|
||||
|
||||
WWW: https://software.sandia.gov/opt++/
|
93
math/optpp/pkg-plist
Normal file
93
math/optpp/pkg-plist
Normal file
|
@ -0,0 +1,93 @@
|
|||
include/AppLauncher.h
|
||||
include/Appl_Data.h
|
||||
include/Appl_Data_NPSOL.h
|
||||
include/BoolVector.h
|
||||
include/BoundConstraint.h
|
||||
include/CGProblem.h
|
||||
include/CompoundConstraint.h
|
||||
include/Constraint.h
|
||||
include/ConstraintBase.h
|
||||
include/GenSet.h
|
||||
include/GenSetBase.h
|
||||
include/GenSetBox2d.h
|
||||
include/GenSetMin.h
|
||||
include/GenSetStd.h
|
||||
include/LSQNLF.h
|
||||
include/LinearConstraint.h
|
||||
include/LinearEquation.h
|
||||
include/LinearInequality.h
|
||||
include/NIPSProblem.h
|
||||
include/NLF.h
|
||||
include/NLFAPP.h
|
||||
include/NLP.h
|
||||
include/NLP0.h
|
||||
include/NLP1.h
|
||||
include/NLP2.h
|
||||
include/NLPBase.h
|
||||
include/NPSOLProblem.h
|
||||
include/NewtonProblem.h
|
||||
include/NonLinearConstraint.h
|
||||
include/NonLinearEquation.h
|
||||
include/NonLinearInequality.h
|
||||
include/Opt.h
|
||||
include/OptBCEllipsoid.h
|
||||
include/OptBCFDNewton.h
|
||||
include/OptBCNewton.h
|
||||
include/OptBCNewtonLike.h
|
||||
include/OptBCQNewton.h
|
||||
include/OptBaNewton.h
|
||||
include/OptBaQNewton.h
|
||||
include/OptCG.h
|
||||
include/OptConstrFDNewton.h
|
||||
include/OptConstrNewton.h
|
||||
include/OptConstrNewtonLike.h
|
||||
include/OptConstrQNewton.h
|
||||
include/OptDHNIPS.h
|
||||
include/OptDirect.h
|
||||
include/OptFDNIPS.h
|
||||
include/OptFDNewton.h
|
||||
include/OptGSS.h
|
||||
include/OptLBFGS.h
|
||||
include/OptNIPS.h
|
||||
include/OptNIPSLike.h
|
||||
include/OptNPSOL.h
|
||||
include/OptNewton.h
|
||||
include/OptNewtonLike.h
|
||||
include/OptPDS.h
|
||||
include/OptQNIPS.h
|
||||
include/OptQNewton.h
|
||||
include/Opt_PARAMS.h
|
||||
include/OptppArray.h
|
||||
include/OptppExceptions.h
|
||||
include/OptppFatalError.h
|
||||
include/OptppSmartPtr.h
|
||||
include/PDSProblem.h
|
||||
include/Problem.h
|
||||
include/TOLS.h
|
||||
include/VariableList.h
|
||||
include/abbrev_copyright.h
|
||||
include/common.h
|
||||
include/controlw.h
|
||||
include/globals.h
|
||||
include/include.h
|
||||
include/ioformat.h
|
||||
include/myexcept.h
|
||||
include/newmat.h
|
||||
include/newmatap.h
|
||||
include/newmatio.h
|
||||
include/newmatnl.h
|
||||
include/newmatrc.h
|
||||
include/newmatrm.h
|
||||
include/pds.h
|
||||
include/precisio.h
|
||||
include/proto.h
|
||||
include/solution.h
|
||||
include/tmt.h
|
||||
lib/libnewmat.a
|
||||
lib/libnewmat.so
|
||||
lib/libnewmat.so.0
|
||||
lib/libnewmat.so.0.0.0
|
||||
lib/libopt.a
|
||||
lib/libopt.so
|
||||
lib/libopt.so.0
|
||||
lib/libopt.so.0.0.0
|
Loading…
Reference in a new issue