- Unbreak build on ARM. Use malloc instead of sbrk.
This commit is contained in:
parent
fe8e91ba7d
commit
892b80d343
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=473367
2 changed files with 12 additions and 2 deletions
|
@ -3,6 +3,7 @@
|
|||
|
||||
PORTNAME= irsim
|
||||
PORTVERSION= 9.7.100
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= http://opencircuitdesign.com/irsim/archive/
|
||||
|
||||
|
@ -31,8 +32,6 @@ GNU_CONFIGURE= yes
|
|||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
BROKEN_aarch64= Fails to link: missing sbrk
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MTCL}
|
||||
|
|
11
cad/irsim/files/patch-base_mem.c
Normal file
11
cad/irsim/files/patch-base_mem.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- base/mem.c.orig 2018-06-25 17:36:40 UTC
|
||||
+++ base/mem.c
|
||||
@@ -126,7 +126,7 @@ extern unsigned sleep();
|
||||
#define PAGE_MASK ( PAGE_SIZE - 1 )
|
||||
|
||||
#define FPRINTF (void) fprintf
|
||||
-#if defined(CYGWIN) || defined(__APPLE__)
|
||||
+#if defined(CYGWIN) || defined(__APPLE__) || defined(__FreeBSD__)
|
||||
private Pointer GetMoreCore( npages )
|
||||
int npages;
|
||||
{
|
Loading…
Reference in a new issue