- Unbreak after yacc update in r235723

PR:	ports/168311
Submitted by:	Jan Beich <jbeich@tormail.org>
Approved by:	eadler, itetcu (mentors, implicit)
This commit is contained in:
Alex Kozlov 2012-05-27 09:14:07 +00:00
parent f2e15dd6ee
commit 892c1a6750
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=297532
2 changed files with 19 additions and 0 deletions

View file

@ -40,6 +40,8 @@ MAKE_ENV+= DEBUG_FLAGS='${DEBUG_FLAGS}'
.if ${OSVERSION} < 800069
IGNORE= does not build with the old USB stack
.elif ${OSVERSION} > 1000012
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-uhidd-parser.y
.endif
.if !(exists(${SYSDIR}/Makefile) || exists(${SRC_BASE}/sys/Makefile))

View file

@ -0,0 +1,17 @@
--- uhidd/parser.y~
+++ uhidd/parser.y
@@ -32,13 +32,13 @@
#include <err.h>
#include <errno.h>
#include <stdio.h>
+#include <stdlib.h>
#include <string.h>
#include <syslog.h>
#include "uhidd.h"
extern int yylex(void);
-extern int yyparse(void);
extern int lineno;
extern FILE *yyin;